update puppet to 3.8.3

Bug #1500414 reported by Matthew Mosesohn on 2015-09-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Artem Silenkov

Bug Description

Several bugs have been fixed upstream in puppet, but we are still runing 3.4.2. There are no Ruby requirement changes from 3.4.2 to 3.8, so it should be safe to migrate to the current release.

Upgrading would resolve one bug that occasionally plagues development regarding obsolete package names:
https://tickets.puppetlabs.com/browse/PUP-897
This was resolved upstream 1.5 years ago, but we have an antique version of Puppet in Fuel now.

mos-linux does not deal with puppet and/or its modules.

Changed in fuel:
assignee: MOS Linux (mos-linux) → Fuel Library Team (fuel-library)
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Fuel build team (fuel-build)
status: New → Confirmed
importance: Undecided → High
Changed in fuel:
assignee: Fuel build team (fuel-build) → Artem Silenkov (asilenkov)
Artem Silenkov (asilenkov) wrote :

We are rebuilding all ruby stuff for centos7 basically from scratch. It could take some time.
The overall progress could be monitored here: https://docs.google.com/spreadsheets/d/1iJDwbZxP8jH3AYjLrv6CWSTzbmFzckl5HBCU_x3xZDY
RUBY spreadsheet

ETA 8 Oct.

Artem, can you also take care of facter? We're currently on some really old version, it would be nice to have 2.4.4 instead.

Never mind, I checked the spreadsheet. Thanks.

Artem Silenkov (asilenkov) wrote :

I'm building 4.1.0, @mattymo confirmed we could try to use this one with no harm.

summary: - update puppet to 3.8
+ update puppet to 4.1
Changed in fuel:
status: Confirmed → Fix Committed

It's not actually fixed yet, deb package isn't rebuilt, fuel-library isn't adapted yet

Changed in fuel:
status: Fix Committed → In Progress
Artem Silenkov (asilenkov) wrote :

We can't merge ubuntu version for this moment. This will break 8.0_kilo.
Request is on the way, but we can't merge it until full Liberty is arrived.

summary: - update puppet to 4.1
+ update puppet to 4.2.1

I don't think, that upgrading to 4.x puppet version is a good idea.

At first, community mostly uses puppet 3.8.3 (e.g. http://logs.openstack.org/75/229675/2/gate/gate-puppet-neutron-puppet-beaker-rspec-dsvm-trusty/54aa7ac/console.html#_2015-10-15_20_59_59_447). So, we should keep the same way for Liberty cycle.

Secondarily, we don't ready for upgrading puppet to 4.x - we should rewrite so many code for keeping it alive. I suggest to use 3.8.3 puppet version and also prepare one more testing job with a new puppet version (4.1 or 4.2) in non-voting mode just for analyse - how many changes do we need to prepare.

And last one, if we are going to upgrade puppet to 4.x version we also need additional testing.

So, my point is do not upgrade to 4.x version and use 3.8.3.

Aleksandr Didenko (adidenko) wrote :

+1 to Denis, we should use puppet-3.8 for now.

Artem Silenkov (asilenkov) wrote :

Agreed.

1. We are downgrading to 3.8.3 for production.
2. We are preparing new package puppet4=4.1.2.

So no impact and you could work with new version in parallel.

Reviewed: https://review.fuel-infra.org/12904
Submitter: Igor Shishkin <email address hidden>
Branch: master

Commit: 375cf2495f04c5ac5d6c4e3a1ad8364c3c004968
Author: Artem Silenkov <email address hidden>
Date: Fri Oct 16 13:09:15 2015

rubygem-safe_yaml packaged for centos7 Liberty

* project: packages/centos7/rubygem-safe_yaml
  as dependency for puppet 3.8.3

* project: packages/centos7/puppet4
  as temporary transition to unblock developers

Related-bug: #1500414

Change-Id: If4cbb10edb407c61154ac30e4e69c13d5d3d7a07

Reviewed: https://review.fuel-infra.org/12899
Submitter: Daniil Trishkin <email address hidden>
Branch: master

Commit: 972bd0de9ebfd45b1d1286481484a22601fb2525
Author: Artem Silenkov <email address hidden>
Date: Fri Oct 16 15:24:32 2015

puppet 3.8.3 packaged for centos7 Liberty

Related-Bug: #1500414

Change-Id: If598a4cf1e53e9c3f77431bc141a4d9674d82e13

Please confirm, that puppet=3.8.3 is suitable for us.
I could see that some work should be done to upgrade even to this version.
Ubuntu version is still blocked in order not to break 8.0_kilo stuff.

Yes, 3.8 is suitable.

Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-build
Artem Silenkov (asilenkov) wrote :

3.8.3 is merged to centos

ubuntu merge is not possible yet because it breaks 8.0_liberty iso.

Matthew Mosesohn (raytrac3r) wrote :

Artem, what is broken? Is it puppet code related or deps related? Can you link to a failed job related to this?

Artem Silenkov (asilenkov) wrote :

My local tests are broken after puppet updated in ubuntu env. It is some puppet incompatibility I guess.

We could try to merge if you are ok with possibility to break existing 8.0_liberty ISO.

Matthew Mosesohn (raytrac3r) wrote :

Artem, you shouldn't merge any packages that are broken. Let's get an ISO and see what exactly is broken. Do you have any logs?

Related fix proposed to branch: master
Change author: Artem Silenkov <email address hidden>
Review: https://review.fuel-infra.org/13147

Artem Silenkov (asilenkov) wrote :

BVT is green. Could you please verify that I tested it correctly ?

http://jenkins-product.srt.mirantis.net:8080/job/8.0.custom.ubuntu.bvt_2/118/consoleFull

LGTM

Reviewed: https://review.fuel-infra.org/13147
Submitter: Artem Silenkov <email address hidden>
Branch: master

Commit: c489686bb3fec83f79930a1b3aa2e3bc13002cf4
Author: Artem Silenkov <email address hidden>
Date: Sat Oct 24 11:54:05 2015

Version bump to 3.8.3

Change-Id: I7c8ad44c94d69a97a2ff7570f7a6b4b4796c2380
Related-Bug: #1500414

Puppet 3.8.3 is placed inside master repos for centos7 and ubuntu.

Puppet4 is on the way.

Changed in fuel:
status: In Progress → Fix Committed

This is still not done. It's not available on master ISO. We can't mark this bug as done until it's really in the product ISO.

Changed in fuel:
status: Fix Committed → In Progress
summary: - update puppet to 4.2.1
+ update puppet to 3.8.3

Reviewed: https://review.fuel-infra.org/13971
Submitter: Pkgs Jenkins <email address hidden>
Branch: 8.0

Commit: e3983607167721550ac2e9f38699549050e5c136
Author: Artem Silenkov <email address hidden>
Date: Tue Dec 1 14:52:32 2015

puppet rebuild for 8.0 trusty

* sources are from http://anonscm.debian.org/cgit/pkg-puppet/puppet.git

Related-Bug: #1500414

Change-Id: I2d60ba070801d4c1e66fb80fd8caafacd91eccc3

Artem Silenkov (asilenkov) wrote :
Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/242638
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=a26619dc7a2baae76db1f6589bea0a31e266038b
Submitter: Jenkins
Branch: master

commit a26619dc7a2baae76db1f6589bea0a31e266038b
Author: Alex Schultz <email address hidden>
Date: Fri Nov 6 15:19:58 2015 -0600

    Update Fuel CI script to use puppet 3.8

    This change updates the scripts used by Fuel CI to pull in puppet 3.8
    rather than 3.4.

    In order to support testing under Puppet 3.8, we have to setup the
    puppet settings as part of our overrides setup. This is due to a change
    after 3.4 where these settings are no longer setup as part of the
    TestHelper inititalize call. This was done as part of PUP-11118.
    Without setting up up the settings, rspec may error when we attempt
    to access the Puppet scope or functions.

    Change-Id: I26c20036cc9a829fc5d7d351530ac358b1a5ace8
    Related-Bug: 1500414
    Closes-Bug: 1513969

Reviewed: https://review.openstack.org/273612
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=32c3d8c1f077836d4c449ed55db551b3bce30e82
Submitter: Jenkins
Branch: master

commit 32c3d8c1f077836d4c449ed55db551b3bce30e82
Author: Alex Schultz <email address hidden>
Date: Thu Jan 28 08:15:48 2016 -0700

    Update update_modules.sh to use puppet 3.8

    This change fixes the default puppet version for the update_modules.sh
    script to 3.8.x since we've moved to that as our default deployment
    version.

    Change-Id: Ie7b30f86ae618b62a9c757ba69b8a2433b0b995b
    Related-Bug: #1500414

Changed in fuel:
status: Fix Committed → Fix Released

Change abandoned by Ivan Berezovskiy (<email address hidden>) on branch: master
Review: https://review.openstack.org/235809

Reviewed: https://review.openstack.org/296801
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=16f46f943025512386ceb4aa05334345f0afb188
Submitter: Jenkins
Branch: master

commit 16f46f943025512386ceb4aa05334345f0afb188
Author: Maksim Malchuk <email address hidden>
Date: Wed Mar 23 19:50:43 2016 +0300

    Change the type of mounts fact to array

    With this change no need to parse string and use split() in the
    fuel-library manifests.

    Change-Id: If775d1097e9b1ff6d8f85af878693e876082a1f3
    Depends-On: Ib70ae937165ddb2968c9e4346434f18778b31714
    Closes-bug: 1500825
    Related-bug: 1500414

Change abandoned by Fuel DevOps Robot (<email address hidden>) on branch: master
Review: https://review.openstack.org/235272
Reason: This review is > 4 weeks without comment, and failed Jenkins the last time it was checked. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

Change abandoned by Fuel DevOps Robot (<email address hidden>) on branch: master
Review: https://review.openstack.org/228851
Reason: This review is > 4 weeks without comment, and failed Jenkins the last time it was checked. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers