Network verification fails with networking template when adding new node to operational cluster: 'Some untagged networks are assigned to the same physical interface.'

Bug #1493391 reported by Artem Panchenko on 2015-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Ryan Moe
7.0.x
High
Ryan Moe

Bug Description

Fuel version info (7.0 build #253): http://paste.openstack.org/show/450069/

After adding new network groups they are automatically assigned to nics on new nodes:

2015-09-08 11:47:37.435 WARNING [7f2a0ad54740] (manager) Cannot assign all networks appropriately fornode u'Untitled (4a:90)'. Set all unassigned networks to theinterface u'eth0'

That causes network verification failure, because few networks without VLAN tags can be assigned to the same interface:

Verification failed.
Some untagged networks are assigned to the same physical interface. You should assign them to different physical interfaces. Affected: "admin (PXE)", "mongo", "database", "ceph", "openstack", "services", "messaging", "ha" networks at node "cz5551"

Steps to reproduce:

1. Create environment
2. Upload network template for it
3. Add custom networks for environment. Do not assign vlan tags to them because L2 configuration is taken from template only.
4. Add nodes to cluster.
5. Run network verification

Expected result: network verification passed

Actual result: network verification failed because custom networks are automatically assigned to nodes nics

There is no sense to assign custom networks to nics in DB, because they can be used with networking templates only. And if net template is uploaded to environment then networks to nics mapping is taken from it, not from DB.

@Artem, could you please provide used network template.

Artem Panchenko (apanchenko-8) wrote :

@Alexander,

attached net template I used. But actually to reproduce this bug you can use any valid template.

Fix proposed to branch: master
Review: https://review.openstack.org/221542

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Ryan Moe (rmoe)
status: New → In Progress
Aleksey Kasatkin (alekseyk-ru) wrote :

Workaround: setup vlan tags to networks.
BTW, we can use custom networks w/o templates for now and they will be serialized correctly. So, it's needed to take into account https://bugs.launchpad.net/fuel/+bug/1425907 also.

Reviewed: https://review.openstack.org/221987
Committed: https://git.openstack.org/cgit/stackforge/fuel-qa/commit/?id=4d2ea49519a6a4414513df1b9a6fa47fa3a3bcaf
Submitter: Jenkins
Branch: master

commit 4d2ea49519a6a4414513df1b9a6fa47fa3a3bcaf
Author: Artem Panchenko <email address hidden>
Date: Thu Sep 10 01:43:32 2015 +0300

    Test adding nodes to cloud with network template

    Cover case with adding nodes to operational environment
    which uses networking template. It should be possible
    to update network template after deployment in order to
    specify nics mapping for new nodes.

    Related blueprint templates-for-networking
    Related-bug: #1493391

    Change-Id: Ib4d13b31b4b92a30d2dc86ae78c2447522edf415

Artem Panchenko (apanchenko-8) wrote :

@Nastya,

there was a related patch to tests, the bug isn't fixed, so changing status back to 'in progress'

Aleksey Kasatkin (alekseyk-ru) wrote :

Agreed for "won't fix" in 7.0 as it has a workaround and does not seem to be critical. 7.0 is in HCF stage already.

Dmitry Pyzhov (dpyzhov) on 2015-10-09
no longer affects: fuel/8.0.x
Changed in fuel:
milestone: 7.0 → 8.0
tags: added: swarm-blocker
Changed in fuel:
assignee: Ryan Moe (rmoe) → Igor Kalnitsky (ikalnitsky)
Changed in fuel:
assignee: Igor Kalnitsky (ikalnitsky) → Ryan Moe (rmoe)

Reviewed: https://review.openstack.org/221542
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=09a256d9c892893d78e5dd618274b80c1f59cb71
Submitter: Jenkins
Branch: master

commit 09a256d9c892893d78e5dd618274b80c1f59cb71
Author: Ryan Moe <email address hidden>
Date: Tue Sep 15 14:58:11 2015 -0700

    Assign networks based on template

    When a node is added to a cluster with a network template
    networks will be mapped to NICs based on transformations
    in the template. Any bonds will be created in the database.
    Any time the cluster's network template is changed the NIC
    mapping will be recreated.

    Change-Id: I2b52444f3019241362e5a957bf191645b94ebaa7
    Closes-bug: #1493391

Changed in fuel:
status: In Progress → Fix Committed
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Vitaly Sedelnik (vsedelnik) wrote :

This is feature request not a bug - Won't Fix for 7.0-updates

tags: added: on-verification

Verified on iso #478

tags: removed: on-verification
Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers