fuel-agent failed to apply new partitioning scheme if upgrade from 5.1 to 7.0 happened and partition preservation was enabled

Bug #1492199 reported by slava valyavskiy on 2015-09-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Unassigned
7.0.x
High
Alexander Gordeev

Bug Description

Currently, we faced the issue that we are not able to re-provison nodes from the 5.1 env using ibp approach if partition preservation feature was applied. Main rootcase there that agent expects that 'os' vg has been created, but in 5.1 release, 'root' partition was placed on physical partion, but not on lvm volume.

As result agent fails on swap creating step:
2015-09-04T00:25:06.086632+00:00 info: 2015-09-04 00:25:05.815 1610 WARNING fuel_agent.utils.utils [-] Failed to ex
ecute command: Unexpected error while running command.
2015-09-04T00:25:06.086744+00:00 info: Command: mkswap /dev/mapper/os-swap
2015-09-04T00:25:06.086854+00:00 info: Exit code: 1
2015-09-04T00:25:06.086989+00:00 info: Stdout: ''
2015-09-04T00:25:06.087094+00:00 info: Stderr: '/dev/mapper/os-swap: No such file or directory\n'
2015-09-04T00:25:06.087204+00:00 info: 2015-09-04 00:25:05.815 1610 ERROR fuel_agent.cmd.agent [-] Unexpected error while running command.

slava valyavskiy (slava-val-al) wrote :

Full agent log

Changed in fuel:
assignee: nobody → Aleksandr Gordeev (a-gordeev)
importance: Undecided → High
tags: added: feature-image-based
Changed in fuel:
status: New → Confirmed
milestone: none → 8.0
tags: added: tricky

The reason for this issue to appear is that in 5.1 we only had "Classic" provisioning scheme. In case of Ubuntu we put root file system on plane partition (not on logical volume) due to limitations of debian-installer partman. So, there is no logical volume for root file system on 5.1 Ubuntu nodes. Partition preservation feature assumes we don't touch partition tables on disks, but nailgun fuel-agent driver places root file system on logical volume which is not there.

The issue can be addressed by re-working nailgun driver so it makes a decision whether to place root file system on plane partition or logical volume depending on actual node partition scheme (partitions, md, lvm), which means we need to have partition scheme discovering functionality, but we don't have such functionality at the moment (need blueprint). Octane team however reported they have managed to implement a workaround for their case. So, I am changing 7.0 bug status to 'won't fix'.

Changed in fuel:
status: Confirmed → Won't Fix
tags: added: feature-upgrade
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
assignee: Alexander Gordeev (a-gordeev) → Fuel Octane Dev Team (fuel-octane)
milestone: 7.0 → 8.0
status: Won't Fix → Confirmed
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-21
tags: added: module-octane
Dmitry Pyzhov (dpyzhov) on 2015-10-27
tags: added: area-octane
Dmitry Pyzhov (dpyzhov) on 2015-10-29
tags: added: area-python
removed: area-octane
Oleg S. Gelbukh (gelbuhos) wrote :

This bug does not affect 8.0 development, since 'classic' provisioning schema is deprecated since 7.0, and in 8.0 we aim for 7.0->8.0 upgrade only. I'm going to mark it Invalid for 8.0, if no one objects in a day or so.

Changed in fuel:
status: Confirmed → Won't Fix
Curtis Hovey (sinzui) on 2017-04-13
Changed in fuel:
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments