fuel-createmirror requires internet access to docker repository and fails by default if it can't access it

Bug #1485758 reported by Alex Schultz on 2015-08-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Bulat Gaifullin
7.0.x
High
Bulat Gaifullin

Bug Description

The fuel-createmirror script tries to reach out to the index.docker.io repository to pull down an image as part of the repository sync process. If the user does not allow access to this it fails with a error message "* FATAL: Cannot calculate list of dependencies" that does not point to what the problem actually is.

Once a user turns on debugging, we can see that the script was unable to pull down the docker image.

Script log: http://paste.openstack.org/show/419543/
ubuntu-ubuntu.log: http://paste.openstack.org/show/419544/

We need to improve the error message around this and document the required network connectivity for the fuel-createmirror script. We should provide a complete list of urls that may need to be whitelisted in order for the local mirror creation process to work.

UX impact poor error messaging, lack of documentation

summary: fuel-createmirror requires internet access to docker repository and
- fails by default
+ fails by default if it can't access it
Changed in fuel:
importance: Undecided → Medium
assignee: nobody → Fuel Library Team (fuel-library)
milestone: none → 8.0
status: New → Confirmed
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Vitaly Parakhin (vparakhin)
krogon-intel (krogon-intel) wrote :

I thing that this docker should be stored locally.

krogon-intel (krogon-intel) wrote :

The precheck will use proxy configuration from ./config/common.cfg (or ENV variables) which may work (False-Positive).
Proxy for docker have to be set separately in /etc/sysconfig/docker.

BTW. How to run fuel-createmirror in debbuging mode. It was a bit hard for me to find out the root cause.

Alex Schultz (alex-schultz) wrote :

To run fuel-createmirror in debug, edit /etc/fuel-createmirror/ubuntu.cfg and mos-ubuntu.cfg and change DEBUG="yes"

Sheena Conant (sheena-conant) wrote :

We're discussing removing MOS DEB from the ISO, which is the reason for the elevated priority. This needs to be addressed immediately if we're going to continue to pull content from the ISO and expect users to use the fuel-createmirror script to pull everything down.

Changed in fuel:
importance: Medium → High
Changed in fuel:
assignee: Vitaly Parakhin (vparakhin) → Fuel Python Team (fuel-python)
Andrew Maksimov (maximov) wrote :

Moving out of 7.0 scope since we cannot fix High bugs after HCF

Dmitry Pyzhov (dpyzhov) on 2015-09-22
tags: added: fuel-createmirror
Dmitry Pyzhov (dpyzhov) on 2015-09-29
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Bulat Gaifullin (bgaifullin)
Dmitry Pyzhov (dpyzhov) on 2015-09-29
tags: added: covered-by-bp

Fix proposed to branch: master
Review: https://review.openstack.org/234779

Changed in fuel:
status: Confirmed → In Progress
tags: added: 70mu1-confirmed
Dmitry Pyzhov (dpyzhov) on 2015-10-14
tags: removed: covered-by-bp

Reviewed: https://review.openstack.org/234779
Committed: https://git.openstack.org/cgit/stackforge/fuel-mirror/commit/?id=fe81731b76071dc0a4ffdf039080732243f5a871
Submitter: Jenkins
Branch: master

commit fe81731b76071dc0a4ffdf039080732243f5a871
Author: Bulat Gaifullin <email address hidden>
Date: Wed Oct 14 16:00:44 2015 +0300

    Check that docker-container runs successfully.

    Break execution with error message in case if
    the docker fails to start new container.

    Change-Id: I2880a0a569dc3a56a73c0f9deea018f5b626ae10
    Closes-bug: #1485758

Changed in fuel:
status: In Progress → Fix Committed
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python

Reviewed: https://review.openstack.org/235772
Committed: https://git.openstack.org/cgit/openstack/fuel-mirror/commit/?id=9c00e595b49f87575a0ae4c877c5f5b519853683
Submitter: Jenkins
Branch: stable/7.0

commit 9c00e595b49f87575a0ae4c877c5f5b519853683
Author: Bulat Gaifullin <email address hidden>
Date: Wed Oct 14 16:00:44 2015 +0300

    Check that docker-container runs successfully.

    Break execution with error message in case if
    the docker fails to start new container.

    Change-Id: I2880a0a569dc3a56a73c0f9deea018f5b626ae10
    Closes-bug: #1485758
    (cherry picked from commit fe81731b76071dc0a4ffdf039080732243f5a871)

tags: added: on-verification
tags: removed: 70mu1-confirmed

verified on 7.0-301 iso with MU

tags: added: 70mu1-confirmed verified
removed: on-verification
tags: removed: 70mu1-confirmed
Nastya Urlapova (aurlapova) wrote :

Moved to Fix Released according to a comment above.

tags: removed: verified
Jeff Wong (jeff-ny-wong) wrote :

How can I download the patch since I encountered the same problem.

EP KOMARLA (ep-komarla) wrote :

Please tell me how to get this patch - I am seeing the same error

Alex Schultz (alex-schultz) wrote :

If you are receiving an error about docker, please see bug https://bugs.launchpad.net/fuel/+bug/1528498

tags: added: on-verification
Dmitriy Kruglov (dkruglov) wrote :

Fuel-createmirror was deprecated and replaced by fuel-mirror in 8.0.

Changed in fuel:
status: Fix Committed → Won't Fix
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers