Address space intersection error after creating a node group

Bug #1484008 reported by Przemyslaw Kaminski on 2015-08-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Aleksey Kasatkin
7.0.x
High
Fuel Python (Deprecated)

Bug Description

1. Create ENV
2. Add nodegroup
3. Download network YAML file
4. Upload same network YAML file

This results in:

{
    "cluster": 1,
    "id": 1,
    "message": "Address space intersection between networks:\npublic, public\nAddress space intersection between networks:\nmanagement, management\nAddress space intersection between networks:\nstorage, storage",
    "name": "check_networks",
    "progress": 100,
    "result": [
        {
            "errors": [
                "cidr"
            ],
            "ids": [
                2,
                6
            ]
        },
        {
            "errors": [
                "cidr"
            ],
            "ids": [
                3,
                7
            ]
        },
        {
            "errors": [
                "cidr"
            ],
            "ids": [
                4,
                8
            ]
        }
    ],
    "status": "error",
    "uuid": "a5392bb1-4ec4-4268-98d3-6df562eea38b"
}

This is because there are duplicate "public", etc. networks with different node group id. Validation should be fixed for this case.

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Liubov Efremova (lefremova)

Fix proposed to branch: master
Review: https://review.openstack.org/211889

Changed in fuel:
assignee: Liubov Efremova (lefremova) → Przemyslaw Kaminski (pkaminski)
status: New → In Progress
Przemyslaw Kaminski (pkaminski) wrote :

So it seems fixing this is a matter of creating sane defaults for new networks, instead of copying the fixtures.

tags: added: feature-nodegroup
Aleksey Kasatkin (alekseyk-ru) wrote :

It's known behaviour since 6.0. It will simplify UX but does not look like High for 7.0. Actually, network verification will not pass so it does not break deployment.

tags: added: known-issue release-notes
Changed in fuel:
milestone: 7.0 → 8.0
Changed in fuel:
assignee: Przemyslaw Kaminski (pkaminski) → Fuel Python Team (fuel-python)
assignee: Fuel Python Team (fuel-python) → Przemyslaw Kaminski (pkaminski)
Dmitry Pyzhov (dpyzhov) on 2015-09-21
Changed in fuel:
status: In Progress → Confirmed
assignee: Przemyslaw Kaminski (pkaminski) → Fuel Python Team (fuel-python)
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Maciej Kwiek (maciej-iai)
status: Confirmed → In Progress
Changed in fuel:
status: In Progress → Confirmed
assignee: Maciej Kwiek (maciej-iai) → Fuel Python Team (fuel-python)
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Alexander Kislitsky (akislitsky)
Dmitry Pyzhov (dpyzhov) on 2015-10-05
Changed in fuel:
assignee: Alexander Kislitsky (akislitsky) → Fuel Python Team (fuel-python)
Dmitry Pyzhov (dpyzhov) wrote :

Note from Alexey Kasatkin: not sure that it's useful to backport it. We live from 6.0 with it and, afaic, just proper instruction how to setup networks with multi-node-groups should be enough here.

tags: added: customer-found
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Aleksey Kasatkin (alekseyk-ru) wrote :

This will be resolved when https://bugs.launchpad.net/fuel/+bug/1473047 is fixed.

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Aleksey Kasatkin (alekseyk-ru)
status: Confirmed → In Progress
Dmitry Pyzhov (dpyzhov) on 2015-11-20
tags: added: team-net
tags: added: team-networks
removed: team-net
Dmitry Pyzhov (dpyzhov) on 2015-11-21
tags: added: team-network
removed: team-networks
Aleksey Kasatkin (alekseyk-ru) wrote :

Regarding comment #5: need to fix both https://bugs.launchpad.net/fuel/+bug/1473047 and https://bugs.launchpad.net/fuel/+bug/1517400 in order to fix this one.

Reviewed: https://review.openstack.org/247731
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=482743e3e7df0e95e4dae728a872e9233bb72298
Submitter: Jenkins
Branch: master

commit 482743e3e7df0e95e4dae728a872e9233bb72298
Author: Aleksey Kasatkin <email address hidden>
Date: Thu Nov 19 20:33:55 2015 +0200

    Allow sharing of networks between nodegroups

    Networks are considered as shared if they are in different nodegroups,
    have the same Name, CIDR and Gateway values. No routes are geneated between
    shared segments of networks.

    Partial-Bug: #1484008
    Partial-Bug: #1473047

    Change-Id: Ifeaffd76d52a46d95918527c62c302ad356d2fe5
    Blueprint: nodegroups-share-network-parameters

Reviewed: https://review.openstack.org/258479
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=469f5629a196122d7f3ee82e3e4c778439d48e24
Submitter: Jenkins
Branch: master

commit 469f5629a196122d7f3ee82e3e4c778439d48e24
Author: Aleksey Kasatkin <email address hidden>
Date: Tue Dec 15 19:28:36 2015 +0200

    Add gateways everywhere when new node group is added

    It is required for environments with multiple node groups.
    Before, user should set gateways for all networks via API.
    Otherwise, he had got an error.

    Now, it is done automatically on node group creation:
    1. Set gateways for all networks in new node group.
    2. Set gateways for networks in default node group where they were not set.

    IP ranges of networks of default node group are cut or deleted if they
    intersect with new gateways. IP addresses which intersect with new gateways
    are deleted as well. Need to add appropriate message on UI when new node
    group is being added.

    DocImpact
    Closes-Bug: #1517400
    Partial-Bug: #1484008

    Change-Id: I6580d97b849ccd991bbfb65308aa35f217f30987

Change abandoned by Igor Kalnitsky (<email address hidden>) on branch: master
Review: https://review.openstack.org/211889
Reason: No updates for 4 months.

Changed in fuel:
status: In Progress → Fix Committed
tags: added: on-verification
Dmitriy Kruglov (dkruglov) wrote :

Verified on MOS 8.0, build 364. The issue is fixed.

ISO details:
VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  api: "1.0"
  build_number: "364"
  build_id: "364"
  fuel-nailgun_sha: "53c72a9600158bea873eec2af1322a716e079ea0"
  python-fuelclient_sha: "4f234669cfe88a9406f4e438b1e1f74f1ef484a5"
  fuel-agent_sha: "7463551bc74841d1049869aaee777634fb0e5149"
  fuel-nailgun-agent_sha: "92ebd5ade6fab60897761bfa084aefc320bff246"
  astute_sha: "c7ca63a49216744e0bfdfff5cb527556aad2e2a5"
  fuel-library_sha: "ba8063d34ff6419bddf2a82b1de1f37108d96082"
  fuel-ostf_sha: "889ddb0f1a4fa5f839fd4ea0c0017a3c181aa0c1"
  fuel-mirror_sha: "8adb10618bb72bb36bb018386d329b494b036573"
  fuelmenu_sha: "824f6d3ebdc10daf2f7195c82a8ca66da5abee99"
  shotgun_sha: "63645dea384a37dde5c01d4f8905566978e5d906"
  network-checker_sha: "9f0ba4577915ce1e77f5dc9c639a5ef66ca45896"
  fuel-upgrade_sha: "616a7490ec7199f69759e97e42f9b97dfc87e85b"
  fuelmain_sha: "07d5f1c3e1b352cb713852a3a96022ddb8fe2676"

Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: on-verification
tags: added: wontfix-workaround
tags: added: 8.0 release-notes-done
removed: release-notes
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers