[plugin] Wildcard group isn't supported in deployment_tasks.yaml

Bug #1480930 reported by Sergii Golovatiuk on 2015-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Andriy Popovych

Bug Description

There is a case when plugin should be run on some sets of groups. Some groups may be realized by other plugins. Wildcard will eliminate a case when one plugin will require some modification such as

https://github.com/mattymo/detach-database/blob/master/deployment_tasks.yaml#L62-L65

There should be wildcard operators. In this case orchestrator will run plugin on all groups.
the regular expressions (perl format) should be used to specify wildcard.
groups: .* # any group

groups: "^(?!mongo$)" # all groups except mongo

groups: (?=mongo)(?=^((?!^primary).)*$) #all mongo, except primary-mongo

groups: "mongo|astute" # mongo or astute

tags: added: customer-found
Changed in fuel:
milestone: none → 7.0
assignee: nobody → Fuel Python Team (fuel-python)
importance: Undecided → High
status: New → Confirmed
Simon Pasquier (simon-pasquier) wrote :

@Sergii, I've updated the title of the bug to reflect that it affects deployment_tasks.yaml (and not tasks.yaml).

summary: - [plugin] No wildcard in group: in plugins
+ [plugin] Wildcard group isn't supported in deployment_tasks.yaml
Igor Marnat (imarnat) on 2015-08-06
tags: added: fuel-to-mos
tags: added: feature
Changed in fuel:
status: Confirmed → Won't Fix
tags: added: qa-agree-8.0

Fix proposed to branch: master
Review: https://review.openstack.org/217772

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Kseniya Tychkova (ktychkova)
status: Won't Fix → In Progress
Changed in fuel:
status: In Progress → Won't Fix
Changed in fuel:
status: Won't Fix → In Progress
Changed in fuel:
status: In Progress → Won't Fix
Changed in fuel:
status: Won't Fix → In Progress
Mike Scherbakov (mihgen) on 2015-09-02
Changed in fuel:
status: In Progress → Won't Fix
Changed in fuel:
status: Won't Fix → In Progress
tags: added: non-release
Changed in fuel:
status: In Progress → Won't Fix
Changed in fuel:
status: Won't Fix → In Progress
Matthew Mosesohn (raytrac3r) wrote :

What is the status of this bug? There is -1 on the review

Kseniya Tychkova (ktychkova) wrote :

I'm going to fix review comments today or tomorrow

After discussing with @sgolovatiuk, @dshulyak and @akislitsky, @ashtocolov, make design to use regular-expressions (perl format) to describe pattern for group, because
   - it is simple to implement. (python has native support for regular expressions. module "re")
   - any admin or programmer knows the regular expressions.

description: updated
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Alexander Rozdymakha (arozdymakha)

Fix proposed to branch: master
Review: https://review.openstack.org/242122

Changed in fuel:
status: Triaged → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/242133

Change abandoned by Alexander Rozdymakha (<email address hidden>) on branch: master
Review: https://review.openstack.org/242122
Reason: Closed as duplicate to https://review.openstack.org/#/c/242133/

Change abandoned by Kseniya Tychkova (<email address hidden>) on branch: master
Review: https://review.openstack.org/217772

Changed in fuel:
assignee: Alexander Rozdymakha (arozdymakha) → Andriy Popovych (popovych-andrey)

Reviewed: https://review.openstack.org/242133
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=e434546d6854db879f5ffafc15405f8f8a01b113
Submitter: Jenkins
Branch: master

commit e434546d6854db879f5ffafc15405f8f8a01b113
Author: Alexander Rozdymakha <email address hidden>
Date: Thu Nov 5 18:01:01 2015 +0200

    Added support of regexp patterns for groups in deployment_tasks.yaml

    Regular expressions (perl format) should be used to specify wildcard.
    '/' used on the end of group name to distinguish regexp from simple string.

    groups: '/.*/' # any group
    groups: '/^(?!controller$)/' # all groups except controller
    groups: '/(?=controller)(?=^((?!^primary).)*$)/' # all controller,
            except primary-controller
    groups: '/mongo|compute/' # mongo or compute

    DocImpact
    Closes-Bug: #1480930

    Change-Id: I1f279fbd585775fc7b5af1ecbbaa24be21d831c9

Changed in fuel:
status: In Progress → Fix Committed
Olesia Tsvigun (otsvigun) wrote :

Verified at Fuel ISO
VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  api: "1.0"
  build_number: "507"
  build_id: "507"
  fuel-nailgun_sha: "8e954abd70ef0083109f34289de2553dcda544d4"
  python-fuelclient_sha: "4f234669cfe88a9406f4e438b1e1f74f1ef484a5"
  fuel-agent_sha: "658be72c4b42d3e1436b86ac4567ab914bfb451b"
  fuel-nailgun-agent_sha: "b2bb466fd5bd92da614cdbd819d6999c510ebfb1"
  astute_sha: "b81577a5b7857c4be8748492bae1dec2fa89b446"
  fuel-library_sha: "ec7e212972ead554f21b52b9e165156665f659df"
  fuel-ostf_sha: "ab5fd151fc6c1aa0b35bc2023631b1f4836ecd61"
  fuel-mirror_sha: "351d568fa3b3e4dd062054b91d766aa54d379867"
  fuelmenu_sha: "234cb4cbb30fbd2df00f388c28f31606d9cae15f"
  shotgun_sha: "63645dea384a37dde5c01d4f8905566978e5d906"
  network-checker_sha: "a43cf96cd9532f10794dce736350bf5bed350e9d"
  fuel-upgrade_sha: "616a7490ec7199f69759e97e42f9b97dfc87e85b"
  fuelmain_sha: "94507c5e4dad6d8cfbd8f5d41aa8389d5335990a"

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers