"verify Network" does not detect overlap of L3 Network and public network

Bug #1478225 reported by Rajesh Mallah on 2015-07-25

This bug report was converted into a question: question #269633: "verify Network" does not detect overlap of L3 Network and public network .

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Fuel Python (Deprecated)

Bug Description

In a fresh environment consisting of bare metal server . "Verify Network" passes even if there is an overlap between "public network" and internal L3 Network. This misconfiguration is manifested during open stack controller installation in the puppet log as "Bad Request" .

also running the below from cmdline of controller after source sourcing
env variables:

# /usr/bin/neutron router-interface-add --format=shell router04 subnet=net04__subnet

Bad Request (HTTP 400) (Request-ID: req-e222ae9e-c124-43a8-a9b8-eaad9fe1cbdc)

checking the neutron log reveals the overlap message.

Revision history for this message
Rajesh Mallah (mallah) wrote :

this entry was inadvertently submitted.

Changed in fuel:
assignee: nobody → Rajesh Mallah (mallah)
status: New → Invalid
Revision history for this message
Rajesh Mallah (mallah) wrote :

Intended Subject : "verify Network" does not detect invalid L3 Neutron configuration.

Intended Body:

In a fresh environment consisting of bare metal server . "Verify Network" passes even if
there is an overlap between "public network" and internal L3 Network.

This misconfiguration is manifested during openstack controller installation in the
puppet log as "Bad Request" .

/usr/bin/neutron router-interface-add --format=shell router04 subnet=net04__subnet
Bad Request (HTTP 400) (Request-ID: req-e222ae9e-c124-43a8-a9b8-eaad9fe1cbdc)

checking the neutron log reveals the overlap message.

@Admin , please correct the subject of the entry. thanks.

Rajesh Mallah (mallah) on 2015-07-25
Changed in fuel:
status: Invalid → New
summary: - Verify Network"
+ "verify Network" does not detect overlap of L3 Network and public
+ network
description: updated
Rajesh Mallah (mallah) on 2015-07-25
Changed in fuel:
assignee: Rajesh Mallah (mallah) → nobody
Changed in fuel:
milestone: none → 7.0
assignee: nobody → Fuel Python Team (fuel-python)
Revision history for this message
Ihor Kalnytskyi (ikalnytskyi) wrote :

Rajesh Mallah, could you please provide a diagnostic snapshot?

Changed in fuel:
importance: Undecided → High
status: New → Confirmed
tags: added: module-netcheck
tags: added: module-nailgun
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers