We need to turn rabbit heartbeats for Neutron off in 7.0

Bug #1477689 reported by Alexander Ignatov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Fix Released
Medium
Sergey Kolekonov

Bug Description

In 6.1 mos-neutron team with approval from qa team turned off oslo.messaging heartbeats because of those issues:

https://bugs.launchpad.net/mos/+bug/1430894
https://bugs.launchpad.net/mos/+bug/1410797

In Kilo release olso.messaging feature was turned off for the whole OpenStack so it's time to do it in fuel-library.

Tags: neutron
Revision history for this message
Alexander Ignatov (aignatov) wrote :

Btw there is patch in 7.0 which is do the same but correct way to do that is in fuel-library:

https://review.fuel-infra.org/#/c/8033/

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-library (master)

Fix proposed to branch: master
Review: https://review.openstack.org/205175

Changed in fuel:
status: Confirmed → In Progress
Revision history for this message
Bogdan Dobrelya (bogdando) wrote : Re: We need to turn rabbit heartbeats off in 7.0

Note, the patch looks correct and configures rabbit heartbeats from oslo for neutron turned off by default. The question is that the bug looks not correct in the part of "In Kilo release olso.messaging feature was turned off for the whole OpenStack so it's time to do it in fuel-library." Please elaborate and provide more details. Defaults disabled in core modules != disabling everythere. There are custom composition layers for any OpenStack deployment tool, and I believe that rabbit heartbeats still have to be kept enabled *everythere* due to HA resiliency reasons.

Changed in fuel:
status: In Progress → Opinion
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-library (master)

Reviewed: https://review.openstack.org/205175
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=ac0718c113fab951db1714f6fc52e15e369cd81d
Submitter: Jenkins
Branch: master

commit ac0718c113fab951db1714f6fc52e15e369cd81d
Author: Sergey Kolekonov <email address hidden>
Date: Thu Jul 23 18:27:26 2015 +0300

    Add RabbitMQ connection heartbeat options to Neutron module

    Kilo oslo.messaging added heartbeating support for RabbitMQ
    connections. This patch adds support for this in Neutron module
    by managing the oslo_messaging_rabbit/heartbeat_timeout_threshold
    and oslo_messaging_rabbit/heartbeat_rate settings.

    For Neutron heartbeat_timeout_threshold should be set to 0
    (this is the default value)

    Upstream patch: I44ec6712d93dac497ab832cb0aa18da508778d16 (merged)
    Closes-bug: #1477689
    Related-bug: #1430894
    Related-bug: #1410797

    Change-Id: I5810c71a3de5123a43852e37e481d35f5f174ac8

Changed in fuel:
status: Opinion → Fix Committed
Revision history for this message
Alexander Ignatov (aignatov) wrote : Re: We need to turn rabbit heartbeats off in 7.0

@Bogdan, agree "modules != disabling everywhere", I meant that we need to disable it only in Neutron since heartbeats help in Neutron was not confirmed since 6.1 so I prefer to keep it disabled in fuel-library in case if it's will be enabled in upcoming oslo.messaging version someday.

Revision history for this message
Bogdan Dobrelya (bogdando) wrote :

I returned this bug to confirmed state considering the following ML http://lists.openstack.org/pipermail/openstack-dev/2015-July/068751.html. Do you think we should instead restrict the bug scope only to Neutron and close it, ot should we address disabled state of upstream heartbeats for the rest of Puppet Openstack modules AND Fuel composition level as well?

If you prefer the former one, I'd create separate bug to disable upstream implementation of the heartbeats Fuel-wide.

Changed in fuel:
status: Fix Committed → Confirmed
Revision history for this message
Alexander Ignatov (aignatov) wrote :

@Bogdan, this bug is created specifically for Neutron because only Neutron was affected by wrong internal implementation of heartbeats in oslo.messaging. Related bugs are mentioned in bug description. Yeah, title of this bug is not correct, it's not contain information that fix needed is only for Neutron. Yes, I think it would be better to create separate bug related to all OS components.

Revision history for this message
Bogdan Dobrelya (bogdando) wrote :

Ok, understood. Closing then.
Separate bug will be created depending on results of http://lists.openstack.org/pipermail/openstack-dev/2015-July/070757.html

summary: - We need to turn rabbit heartbeats off in 7.0
+ We need to turn rabbit heartbeats for Neutron off in 7.0
Changed in fuel:
status: Confirmed → Fix Committed
Revision history for this message
Ksenia Svechnikova (kdemina) wrote :

Verify at MOS 7.0, build 301

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers