[fuel-main] Support to build nailgun-agent from separate repository

Bug #1475726 reported by Vladimir Sharshov on 2015-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Sergey Kulanov

Bug Description

We have created new repository for nailgun-agent and move it from fuel-web.

Before we finally remove nailgun-agent we need changes in our build system.

Please looks in this repository: https://github.com/stackforge/fuel-nailgun-agent
Also i think would be useful this request: https://review.openstack.org/#/c/202713/ which contain specs for building.

More details about moving: https://bugs.launchpad.net/fuel/+bug/1473893

Feel free to contact me for any questions about this bug.

Roman Vyalov (r0mikiam) on 2015-07-17
Changed in fuel:
assignee: Fuel build team (fuel-build) → Sergey Kulanov (skulanov)

Related fix proposed to branch: master
Change author: Sergey Kulanov <email address hidden>
Review: https://review.fuel-infra.org/9608

Related fix proposed to branch: master
Change author: Vladimir Sharshov <email address hidden>
Review: https://review.fuel-infra.org/9673

Reviewed: https://review.openstack.org/202713
Committed: https://git.openstack.org/cgit/stackforge/fuel-nailgun-agent/commit/?id=2e4f17f6016a7ca8553df8db21eba0feb0c1ce7d
Submitter: Jenkins
Branch: master

commit 2e4f17f6016a7ca8553df8db21eba0feb0c1ce7d
Author: Vladimir Sharshov (warpc) <email address hidden>
Date: Thu Jul 16 20:28:26 2015 +0300

    Add package specs for CentOS, Debian and Ubuntu

    Related-Bug: #1473893
    Related-Bug: #1475726

    Change-Id: Ibb0da01904f361ed8acb0edf311d87721928fa07

Reviewed: https://review.fuel-infra.org/9673
Submitter: Aleksandra Fedorova <email address hidden>
Branch: master

Commit: e885a19a283ed72947042c6e1f7548aa3fbce6e0
Author: Vladimir Sharshov <email address hidden>
Date: Mon Jul 20 19:43:55 2015

Added verification jobs for Fuel nailgun agent

Change-Id: I78e6f52d9a2344886f6eb3d202546352848d3f31
Related-Bug: #1473893
Related-Bug: #1475726

Reviewed: https://review.fuel-infra.org/9608
Submitter: Sergey Kulanov <email address hidden>
Branch: master

Commit: fc006b567bd8fc2cb49a4e8a640bc2de3d89e900
Author: Sergey Kulanov <email address hidden>
Date: Mon Jul 27 08:28:23 2015

Build fuel-nailgun-agent from separate repository

Since we are moving fuel-nailgun-agent[1] from fuel-web project[2]
we need to build it as separate entity

[1]. https://github.com/stackforge/fuel-nailgun-agent
[2]. https://github.com/stackforge/fuel-web

Related-bug: #1475726

Change-Id: I3e0dbb36bee33d038b1b0edfcca29970556a1613

Reviewed: https://review.openstack.org/203667
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=992cfa612e7ed06160f93c923bf96e560a8b74ba
Submitter: Jenkins
Branch: master

commit 992cfa612e7ed06160f93c923bf96e560a8b74ba
Author: Sergey Kulanov <email address hidden>
Date: Mon Jul 20 17:15:08 2015 +0300

    Remove nailgun-agent related stuff from fuel-web repo

    Move nailgun-agent from fuel-web project[1] to
    separate stackforge repo [2]

    [1]. https://github.com/stackforge/fuel-web
    [2]. https://github.com/stackforge/fuel-nailgun-agent

    Change-Id: I893646dda915b867fcb1b2c99be1d9e3acc37a3d
    Related-bug: #1475726

Reviewed: https://review.openstack.org/203624
Committed: https://git.openstack.org/cgit/stackforge/fuel-main/commit/?id=0d6ff4c9ec156196cc4d9a36db314ba7346942f7
Submitter: Jenkins
Branch: master

commit 0d6ff4c9ec156196cc4d9a36db314ba7346942f7
Author: Sergey Kulanov <email address hidden>
Date: Mon Jul 20 16:00:37 2015 +0300

    Separate repository for Fuel Nailgun Agent

    * added stackforge/fuel-nailgun-agent repository
    * added fuel-nailgun-agent package (rpm, deb)

    Change-Id: I5166cfafe5ed09d4012ead49fcdf5ba69bc50d11
    Related-bug: #1475726

Changed in fuel:
status: Confirmed → Fix Committed
Vladimir Sharshov (vsharshov) wrote :

We passed BVT many times after this change was merged, we remove old destination and apply several changes to new repository which was delivered to nodes with changes.

We can mark it as Fix Released.

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers