[kilo] Swarm tests for nova network on Ubuntu failed on openstack-controller with No ability to determine if nova_floating_range exists

Bug #1472529 reported by Tatyanka
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Fix Released
Critical
Ivan Berezovskiy

Bug Description

Steps to reproduce:

1. Deploy any cluster with nova network,
2. Run ostf

Actual result:
Deployment of controller failed on modular task openstack-controller.pp with :
http://paste.openstack.org/show/354638/

http://paste.openstack.org/show/354638/

VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "7.0"
  openstack_version: "2014.2.2-7.0"
  api: "1.0"
  build_number: "239"
  build_id: "2015-07-07_18-02-36"
  nailgun_sha: "2f8d9be6bca0c32a83acda02e1689a44f0d8eefe"
  python-fuelclient_sha: "018c53561baa87397e50368c7f48674829c322c0"
  astute_sha: "9cbb8ae5adbe6e758b24b3c1021aac1b662344e8"
  fuel-library_sha: "93a5fe7251f3eb932d588ba338920e9e7cfe7f0c"
  fuel-ostf_sha: "ba48d52474515bcd1ad2a9dfa5228bff36ee98d7"
  fuelmain_sha: "c53bb47881f0bb9ba14274a596923d9860140406"

Tags: kilo
Revision history for this message
Tatyanka (tatyana-leontovich) wrote :
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Ivan Berezovskiy (iberezovskiy)
Changed in fuel:
status: New → In Progress
Revision history for this message
Ivan Berezovskiy (iberezovskiy) wrote :
Changed in fuel:
assignee: Ivan Berezovskiy (iberezovskiy) → Aleksandr Didenko (adidenko)
Changed in fuel:
assignee: Aleksandr Didenko (adidenko) → Ivan Berezovskiy (iberezovskiy)
Revision history for this message
Dmitry Borodaenko (angdraug) wrote :

Once the root cause is found, please don't forget to update the bug summary, right now the definition is very generic and likely to match future bugs with similar symptoms.

summary: - [kilo] Swarm tests for nova network on ubunru failed on openstack-
+ [kilo] Swarm tests for nova network on Ubuntu failed on openstack-
controller with No ability to determine if nova_floating_range exists
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-library (master)

Reviewed: https://review.openstack.org/199557
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=6f78b4214f71cca90dcb2119152e00a8fbbe8fee
Submitter: Jenkins
Branch: master

commit 6f78b4214f71cca90dcb2119152e00a8fbbe8fee
Author: iberezovskiy <email address hidden>
Date: Wed Jul 8 16:06:48 2015 +0300

    Return back nova floating IP range support

      This patch: a88bc1906a6670c672d145508a1aa516682db28b
      was missed by mistake in adapt of nova module,
      which broke deployment with nova network.
      So, we should move back this provider as addition
      to adapt nova module.

      Add noop test coverage for this resource.

      Closes-bug: #1472529

      TODO (iberezovskiy): rework this change using
      one of the following ways:
        1. Get rid of usage of custom ruby-openstack and
           ruby-netaddr packages and propose
           this patch to upstream module
        2. Move floating ip range support out of nova module
        3. Merge new functions to nova_floating provider
           and use it in deployment
          (also with proposed patch to upstream)

    Change-Id: Ie1f48b9bb58b8ab205ee1b7eabe9fc4787aa8011

Changed in fuel:
status: In Progress → Fix Committed
Revision history for this message
Dennis Dmitriev (ddmitriev) wrote :

Fix released for ISO #31:

ISO version: {u'build_id': u'2015-07-12_15-52-44', u'build_number': u'31', u'auth_required': True, u'fuel-ostf_sha': u'62785c16f8399f30526d24c52bb9ca23e1585bfb', u'fuel-library_sha': u'49c7ddeb5e4257bb52862bc5aa22600df71bb52a', u'nailgun_sha': u'60f9bf536e30efd896b7b4da1830e71adda19e30', u'openstack_version': u'2014.2.2-7.0', u'production': u'docker', u'api': u'1.0', u'python-fuelclient_sha': u'accd6493bf034ba7c70c987ace8f1dcd960cbdf5', u'astute_sha': u'9cbb8ae5adbe6e758b24b3c1021aac1b662344e8', u'fuelmain_sha': u'28551be12a050acb9a633933ed6a8b25e2dc411c', u'feature_groups': [u'mirantis'], u'release': u'7.0', u'release_versions': {u'2014.2.2-7.0': {u'VERSION': {u'build_id': u'2015-07-12_15-52-44', u'build_number': u'31', u'fuel-library_sha': u'49c7ddeb5e4257bb52862bc5aa22600df71bb52a', u'nailgun_sha': u'60f9bf536e30efd896b7b4da1830e71adda19e30', u'fuel-ostf_sha': u'62785c16f8399f30526d24c52bb9ca23e1585bfb', u'production': u'docker', u'api': u'1.0', u'python-fuelclient_sha': u'accd6493bf034ba7c70c987ace8f1dcd960cbdf5', u'astute_sha': u'9cbb8ae5adbe6e758b24b3c1021aac1b662344e8', u'fuelmain_sha': u'28551be12a050acb9a633933ed6a8b25e2dc411c', u'feature_groups': [u'mirantis'], u'release': u'7.0', u'openstack_version': u'2014.2.2-7.0'}}}}

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers