API restriction on nova-network selection

Bug #1470488 reported by Sheena Conant
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Fix Released
Critical
Roman Prykhodchenko

Bug Description

API should only allow for nova-network to be selected in the following cases:
1) User has selected vCenter as only hypervisor
2) User has selected vCenter + KVM/QEMU for multi-HV deployment

The API should not allow a user to select nova-network if they are using KVM/QEMU hypervisors only.

Revision history for this message
Sheena Conant (sheena-conant) wrote :

Note this applies to 7.0 only, should not be backported to earlier releases.

Changed in fuel:
milestone: none → 7.0
assignee: nobody → Fuel Python Team (fuel-python)
Changed in fuel:
status: New → Confirmed
tags: added: module-client module-nailgun module-networks
Changed in fuel:
importance: Undecided → Medium
Dmitry Pyzhov (dpyzhov)
Changed in fuel:
importance: Medium → High
assignee: Fuel Python Team (fuel-python) → Roman Prykhodchenko (romcheg)
Revision history for this message
Roman Prykhodchenko (romcheg) wrote :

The described restrictions should be done on the API side. CLI does not control them.

Changed in fuel:
status: Confirmed → Invalid
Revision history for this message
Roman Prykhodchenko (romcheg) wrote :

@Sheena: I can fix that on the Nailgun side, but please modify the description and the title of the bug then.

Revision history for this message
Sheena Conant (sheena-conant) wrote :

@Roman: I updated them to show API instead of CLI - apologies for the confusion. Please let me know if there is anything else I need to update for you to move forward.

summary: - CLI restriction on nova-network selection
+ API restriction on nova-network selection
description: updated
Dmitry Pyzhov (dpyzhov)
Changed in fuel:
status: Invalid → Confirmed
Revision history for this message
Roman Prykhodchenko (romcheg) wrote :

Sheena, thank's for your help. I will put an additional check to the verification process on the API side.

Changed in fuel:
status: Confirmed → Triaged
Revision history for this message
Sheena Conant (sheena-conant) wrote :

Roman - thank you for being so responsive! Happy to hear this is being addressed.

tags: removed: module-client module-networks
Revision history for this message
Nastya Urlapova (aurlapova) wrote :

Moved to Critical status, according changes that should be done in prod(+ ostf) and system tests, we have to do as soon as possible.

Changed in fuel:
importance: High → Critical
Revision history for this message
Mike Scherbakov (mihgen) wrote :

I've started a converstation in openstack-dev. I completely disagree with the approach of introducing limitations in API or anywhere else. Let's have just a warning.

Revision history for this message
Sheena Conant (sheena-conant) wrote : RE: [Bug 1470488] Re: API restriction on nova-network selection

We literally discussed this a month ago and agreed on the restriction since
it is the first step to deprecating nova-network completely.

I'm not sure why your opinion on this changed, but I think restriction is
still the way to go. I will respond on os-dev.

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Mike
Scherbakov
Sent: Wednesday, July 29, 2015 12:48 PM
To: <email address hidden>
Subject: [Bug 1470488] Re: API restriction on nova-network selection

I've started a converstation in openstack-dev. I completely disagree with
the approach of introducing limitations in API or anywhere else.
Let's have just a warning.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1470488

Title:
  API restriction on nova-network selection

Status in Fuel for OpenStack:
  Triaged

Bug description:
  API should only allow for nova-network to be selected in the following
cases:
  1) User has selected vCenter as only hypervisor
  2) User has selected vCenter + KVM/QEMU for multi-HV deployment

  The API should not allow a user to select nova-network if they are
  using KVM/QEMU hypervisors only.

To manage notifications about this bug go to:
https://bugs.launchpad.net/fuel/+bug/1470488/+subscriptions

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-web (master)

Fix proposed to branch: master
Review: https://review.openstack.org/207877

Changed in fuel:
status: Triaged → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-web (master)

Reviewed: https://review.openstack.org/207877
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=54230ccea18e46db22d2a4b17bc9194fa6bebfca
Submitter: Jenkins
Branch: master

commit 54230ccea18e46db22d2a4b17bc9194fa6bebfca
Author: Roman Prykhodchenko <email address hidden>
Date: Fri Jul 31 14:54:46 2015 +0200

    Require Nova Network if vCenter is used

    Fuel cannot deploy clusters, if they use vCenter and
    Neutron as a network provider. This patch restricts
    network provider selection to Nova Network for the
    mentioned cases.

    Change-Id: I4b4f861058f6b93ec519fa1d655edecb5cee90aa
    Closes-bug: #1470488

Changed in fuel:
status: In Progress → Fix Committed
Revision history for this message
Artem Roma (aroma-x) wrote :

Verified

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers