Fuel plugin builder: Privileges are not managed for plugin repositories

Bug #1456577 reported by Sergey Levchenko on 2015-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Fuel Documentation Team

Bug Description

Packages needed for deployment should have 755 mode, so wrong mode on packages included into plugin may lead to deployment failure during repositories merge:
...
multipath-tools
Authentication warning overridden.
Err http://10.20.0.2/plugins/huawei_multibackend-1.0.0/repositories/ubuntu/ multipath-tools 0.4.9-3ubuntu5
 403 Forbidden
Failed to fetch http://10.20.0.2:8080/plugins/huawei_multibackend-1.0.0/repositories/ubuntu/./multipath-tools_0.4.9-3ubuntu5_amd64.deb 403 Forbidden
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Error: /Stage[main]/Huawei_multibackend::Fc_packages/Package[multipath_tools]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold --force-yes install multipath-tools' returned 100:
...

Issue:
The issue is that plugin builder not manages situation when privileges mode is different from expected by deployment framework.

FPB version:
fuel-plugin-builder==2.0.0

affects: fuel-plugins → fuel
Evgeniy L (rustyrobot) on 2015-05-19
Changed in fuel:
importance: Undecided → Medium
assignee: nobody → Fuel Python Team (fuel-python)
Changed in fuel:
importance: Medium → Wishlist
tags: added: fuel-plugin-builder
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Andriy Popovych (popovych-andrey)
status: New → Confirmed
milestone: none → next
milestone: next → 7.0
importance: Wishlist → Medium
Evgeniy L (rustyrobot) wrote :

I would like to see other people's opinions about this issue, as for me fuel plugin builder should not set priorities for packages which user adds, permissions should be management by user.

Sergey Levchenko (slevchenko) wrote :

I used word "manage" because I'm not sure if plugin-builder must set privileges, but as I have found from my experience and experience of people helped me, not everyone know that development framework expects 755 mode. The way to resolve this either set these privileges, or at least warn user about mode expectations.

Vladimir Sharshov (vsharshov) wrote :

Looks like this issue require documentation. It is all what we can do. Move it fuel-docs team.

Changed in fuel:
assignee: Andriy Popovych (popovych-andrey) → Fuel Documentation Team (fuel-docs)
Igor Shishkin (teran) on 2015-10-08
Changed in fuel:
milestone: 7.0 → 8.0
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-docs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers