Locks list shouldn't be cleared on flush call in DeadlockDetectingSession

Bug #1452359 reported by Alexander Kislitsky on 2015-05-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Alexander Kislitsky
7.0.x
High
Fuel Python (Deprecated)

Bug Description

Locks in DB don't released on the flush call. Flush method in shouldn't call clean_locks. Cleaning of locks list on flush breaks deadlocks detecting.

For performance tests we should disable deadlocks detecting.

tags: added: tricky

Looks like feature.
Bulletin for feature proposed in mailing list [openstack-dev] [Fuel] Transaction scheme

Changed in fuel:
assignee: Alexander Kislitsky (akislitsky) → Fuel Python Team (fuel-python)
tags: added: feature
Changed in fuel:
status: Confirmed → Won't Fix
tags: added: qa-agree-8.0
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Alexander Kislitsky (akislitsky)
status: Won't Fix → In Progress

Reviewed: https://review.openstack.org/224161
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=ad79aecc37d1b6e3003fffe132064433ba09e43d
Submitter: Jenkins
Branch: master

commit ad79aecc37d1b6e3003fffe132064433ba09e43d
Author: Alexander Kislitsky <email address hidden>
Date: Mon Sep 14 13:18:57 2015 +0300

    Detection of possible deadlocks improved

    Tracing of locking order of objects with ids added:
     - object modifications traced
     - object deletion traced
     - object getting traced
     - fetching first object traced
     - fetching one object traced
     - bulk upgrade query traced
     - bulk delete query traced
     - added mixin class for locking ordered objects with
       before deletion and updating

    Observing DB model added for ids tracing.
    Cleaning of locks on flush removed.
    Raising of errors on detection of possible deadlocks
    enabled only for deadlock_detector test.

    Change-Id: I73830cbcb84466171eb25f922fff4da2aaa25a1d
    Partial-Bug: #1433528
    Closes-Bug: #1452359

Changed in fuel:
status: In Progress → Fix Committed

Change abandoned by Igor Kalnitsky (<email address hidden>) on branch: master
Review: https://review.openstack.org/224799
Reason: it was done in other patch

Dmitry Pyzhov (dpyzhov) on 2015-10-07
no longer affects: fuel/8.0.x
Changed in fuel:
milestone: 7.0 → 8.0
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python

Because this bug couldn't be verified via usual methods, and there is a mandatory unit test for every commit that checks locks when flushing environment [1] , I assume that bug is gone. So I move state to Fix Released.

[1]https://github.com/openstack/fuel-web/blob/46fbd9e21e91af057335cfa7e1f29159c1eb82ac/nailgun/nailgun/test/unit/test_deadlock_detector.py#L80-L85

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers