UX improvement of healtch check credentials form

Bug #1428129 reported by Anastasia Palkina on 2015-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Nastya Urlapova
7.0.x
High
Fuel Python (Deprecated)

Bug Description

"build_id": "2015-03-03_22-54-44",
"ostf_sha": "b47bb2ad09e60a25040e21f250018e256f3bebdd",
"build_number": "158",
"release_versions": {"2014.2-6.1": {"VERSION": {"build_id": "2015-03-03_22-54-44", "ostf_sha": "b47bb2ad09e60a25040e21f250018e256f3bebdd", "build_number": "158", "api": "1.0", "nailgun_sha": "1d168667db45ca32274afba44ab14d9a940abc1c", "production": "docker", "python-fuelclient_sha": "7c8c5f77776daf13c04003b42a2727f94e838030", "astute_sha": "1be5b9b827f512d740fe907c7ff72486d4030938", "feature_groups": ["mirantis"], "release": "6.1", "fuelmain_sha": "baf24424a4e056c6753913de5f8c94851903f718", "fuellib_sha": "54a559f127c9605436f1d5ff443d3ce15cd08944"}}},
"auth_required": true,
"api": "1.0",
"nailgun_sha": "1d168667db45ca32274afba44ab14d9a940abc1c",
"production": "docker",
"python-fuelclient_sha": "7c8c5f77776daf13c04003b42a2727f94e838030",
"astute_sha": "1be5b9b827f512d740fe907c7ff72486d4030938",
"feature_groups": ["mirantis"],
"release": "6.1",
"fuelmain_sha": "baf24424a4e056c6753913de5f8c94851903f718",
"fuellib_sha": "54a559f127c9605436f1d5ff443d3ce15cd08944"

We have credentials form on HealthCheck tab.

It is used ONLY in one case: when user changes credentials in Horizon.

But the message in form is not obvious. User may not read this message and changes credentials there and OSTF tests have failed in this case because credentials in form will differ from default in Horizon.

I think that we need to do the following:
1. Write an obvious message, for example: "If you changed credentials after deployment in Horizon, you need to provide it here. In other cases do nothing". And this message must be yellow to attract the user's attention
2. If user changes credentials only in form, not in Horizon after deployment, we should provide a message like: "Credentials are differ from default in Horizon. Please, check it". Because otherwise user sees only errors "Keystone is not available" and doesn't understand the reason of it.

Changed in fuel:
status: New → Confirmed

issues from point #1 are fixed and as for #2 - it's barely possible because currently we have no way to compare or get credentials from the Horizon.

Fix proposed to branch: master
Review: https://review.openstack.org/168342

Changed in fuel:
assignee: Fuel UI Team (fuel-ui) → Alexandra Morozova (astepanchuk)
status: Confirmed → In Progress
Vitaly Kramskikh (vkramskikh) wrote :

I reviewed the proposed fix and I don't think the text or its representation should be changed:

1) I'm ok with the text. No need to add "in Horizon" (credentials can be changed without help of Horizon). "In other cases do nothing" is also useless.
2) No need to ephasize it with yellow text - it is the only message in the form describing it.

I agree that error message should be changed, maybe it should metion this form. So I'm passing this to fuel-python

Changed in fuel:
status: In Progress → Confirmed
assignee: Alexandra Morozova (astepanchuk) → Fuel Python Team (fuel-python)
Dmitry Pyzhov (dpyzhov) on 2015-03-30
tags: added: feature
removed: ui
Changed in fuel:
milestone: 6.1 → next
Dmitry Pyzhov (dpyzhov) on 2015-06-01
Changed in fuel:
milestone: next → 7.0
Vladimir Sharshov (vsharshov) wrote :

Bad UX, but do not affect deployment. Moving to 8.0

tags: added: ux
tags: added: low-hanging-fruit
Changed in fuel:
status: Confirmed → Won't Fix
Changed in fuel:
status: Triaged → Won't Fix
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
status: Won't Fix → Triaged
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Bulat Gaifullin (bgaifullin)
status: Triaged → In Progress
Changed in fuel:
assignee: Bulat Gaifullin (bgaifullin) → Nastya Urlapova (aurlapova)

Reviewed: https://review.openstack.org/242580
Committed: https://git.openstack.org/cgit/openstack/fuel-ostf/commit/?id=86225d7bee29203f789580aa0584611e81aacd8a
Submitter: Jenkins
Branch: master

commit 86225d7bee29203f789580aa0584611e81aacd8a
Author: Bulat Gaifullin <email address hidden>
Date: Fri Nov 6 20:07:15 2015 +0300

    Fix handling Unauthorized exception

    Added class of exceptions - InvalidCredentials

    Change-Id: Ic8250b138210e544b6194f59accdfe653f36667e
    Closes-bug: #1428129

Changed in fuel:
status: In Progress → Fix Committed
tags: added: on-verification
Anastasia Palkina (apalkina) wrote :

Verified on ISO #166

"release_versions": {"2015.1.0-8.0": {"VERSION": {"fuel-upgrade_sha": "1e894e26d4e1423a9b0d66abd6a79505f4175ff6", "fuel-createmirror_sha": "e34a0dd080fe6c133bcc75a00c31b27934ba51bc", "shotgun_sha": "25dd78a3118267e3616df0727ce746e7dead2d67", "api": "1.0", "fuelmain_sha": "266f9b374934c64629a84b5146632cc0de70ac91", "astute_sha": "959b06c5ef8143125efd1727d350c050a922eb12", "fuel-ostf_sha": "9690a2de829d3b063ed1e64b0b10dde39f711dc0", "openstack_version": "2015.1.0-8.0", "build_id": "166", "fuelmenu_sha": "06bbcebed6c8d0b0f9279e2997d2f958c800e98c", "build_number": "166", "fuel-library_sha": "0d210dc3851ac6c74b3914ef4df0139defc8d117", "fuel-nailgun-agent_sha": "3e9d17211d65c80bf97c8d83979979f6c7feb687", "fuel-nailgun_sha": "a5f4c44d08715f3be6b200a69032b30d347ac911", "fuel-agent_sha": "2750600e946e96701099dfef5a7d69017f2e9956", "production": "docker", "network-checker_sha": "a57e1d69acb5e765eb22cab0251c589cd76f51da", "feature_groups": ["mirantis"], "release": "8.0", "python-fuelclient_sha": "e685d68c1c0d0fa0491a250f07d9c3a8d0f9608c"}}}, "fuel-upgrade_sha": "1e894e26d4e1423a9b0d66abd6a79505f4175ff6", "fuel-createmirror_sha": "e34a0dd080fe6c133bcc75a00c31b27934ba51bc", "shotgun_sha": "25dd78a3118267e3616df0727ce746e7dead2d67", "api": "1.0", "fuelmain_sha": "266f9b374934c64629a84b5146632cc0de70ac91", "astute_sha": "959b06c5ef8143125efd1727d350c050a922eb12", "fuel-ostf_sha": "9690a2de829d3b063ed1e64b0b10dde39f711dc0", "openstack_version": "2015.1.0-8.0", "build_id": "166", "fuelmenu_sha": "06bbcebed6c8d0b0f9279e2997d2f958c800e98c", "build_number": "166", "auth_required": true, "fuel-library_sha": "0d210dc3851ac6c74b3914ef4df0139defc8d117", "fuel-nailgun-agent_sha": "3e9d17211d65c80bf97c8d83979979f6c7feb687", "fuel-nailgun_sha": "a5f4c44d08715f3be6b200a69032b30d347ac911", "fuel-agent_sha": "2750600e946e96701099dfef5a7d69017f2e9956", "production": "docker", "network-checker_sha": "a57e1d69acb5e765eb22cab0251c589cd76f51da", "feature_groups": ["mirantis"], "release": "8.0", "python-fuelclient_sha": "e685d68c1c0d0fa0491a250f07d9c3a8d0f9608c"

Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: on-verification
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers