granular graph re-runs completed tasks with multiple roles

Bug #1424295 reported by Andrew Woodward on 2015-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Fuel Python (Deprecated)

Bug Description

{"build_id": "2015-02-21_05-47-15", "ostf_sha": "1a0b2c6618fac098473c2ed5a9af11d3a886a3bb", "build_number": "90", "release_versions": {"2014.2-6.1": {"VERSION": {"build_id": "2015-02-21_05-47-15", "ostf_sha": "1a0b2c6618fac098473c2ed5a9af11d3a886a3bb", "build_number": "90", "api": "1.0", "nailgun_sha": "8a1e03b5863f4e91981278f154b088069415efae", "production": "docker", "python-fuelclient_sha": "5657dbf06fddb74adb61e9668eb579a1c57d8af8", "astute_sha": "d81ff53c2f467151ecde120d3a4d284e3b5b3dfc", "feature_groups": ["experimental"], "release": "6.1", "fuelmain_sha": "b975019fabdb429c1869047df18dd792d2163ecc", "fuellib_sha": "f5d713a3121fa971d63386f0d751a37dc58d061c"}}}, "auth_required": true, "api": "1.0", "nailgun_sha": "8a1e03b5863f4e91981278f154b088069415efae", "production": "docker", "python-fuelclient_sha": "5657dbf06fddb74adb61e9668eb579a1c57d8af8", "astute_sha": "d81ff53c2f467151ecde120d3a4d284e3b5b3dfc", "feature_groups": ["experimental"], "release": "6.1", "fuelmain_sha": "b975019fabdb429c1869047df18dd792d2163ecc", "fuellib_sha": "f5d713a3121fa971d63386f0d751a37dc58d061c"}

In the new granular deployments tasks graph completed tasks are re-run even though a completed role/task-group has already run them during this deployment.

steps to reproduce
deploy:
controller + ceph-osd
compute + ceph-osd

deploy changes

on either node:

grep -i MODULAR /var/log/puppet.log
Sat Feb 21 15:58:57 -0800 2015 Scope(Class[main]) (notice): MODULAR: hiera.pp
Sat Feb 21 15:59:01 -0800 2015 Scope(Class[main]) (notice): MODULAR: globals.pp
Sat Feb 21 15:59:28 -0800 2015 Scope(Class[main]) (notice): MODULAR: logging.pp
Sat Feb 21 15:59:35 -0800 2015 Scope(Class[main]) (notice): MODULAR: netconfig.pp
Sat Feb 21 16:00:46 -0800 2015 Scope(Class[main]) (notice): MODULAR: firewall.pp
Sat Feb 21 16:01:15 -0800 2015 Scope(Class[main]) (notice): MODULAR: hosts.pp
Sat Feb 21 16:01:22 -0800 2015 Scope(Class[main]) (notice): MODULAR: zabbix.pp
Sat Feb 21 16:01:46 -0800 2015 Scope(Class[main]) (notice): MODULAR: compute.pp
Sat Feb 21 16:02:58 -0800 2015 Scope(Class[main]) (notice): MODULAR: tools.pp
Sat Feb 21 16:03:55 -0800 2015 Scope(Class[main]) (notice): MODULAR: hiera.pp
Sat Feb 21 16:04:00 -0800 2015 Scope(Class[main]) (notice): MODULAR: globals.pp
Sat Feb 21 16:04:07 -0800 2015 Scope(Class[main]) (notice): MODULAR: logging.pp
Sat Feb 21 16:04:15 -0800 2015 Scope(Class[main]) (notice): MODULAR: netconfig.pp
Sat Feb 21 16:04:26 -0800 2015 Scope(Class[main]) (notice): MODULAR: firewall.pp
Sat Feb 21 16:04:33 -0800 2015 Scope(Class[main]) (notice): MODULAR: hosts.pp
Sat Feb 21 16:04:38 -0800 2015 Scope(Class[main]) (notice): MODULAR: zabbix.pp
Sat Feb 21 16:04:45 -0800 2015 Scope(Class[main]) (notice): MODULAR: ceph-osd.pp
Sat Feb 21 16:05:08 -0800 2015 Scope(Class[main]) (notice): MODULAR: tools.pp
Sat Feb 21 16:05:23 -0800 2015 Scope(Class[main]) (notice): MODULAR: hosts.pp

expected result

tasks like hiera, globals, logging, netconfig, firewall, hosts, zabbix would only be run once during deployment for each node.

this causes us to spend extra time running components that don't need to be re-run.

Dima Shulyak (dshulyak) wrote :

That is known limitation, it is possible to workaround that by introducing queue of tasks during serialization,
but i want to address in a different way, by removing such entity as groups from deployment graph, and probably
this issue will be wont fix in 6.1

Also duplicated tasks should take less time, so this is not a big deal

Changed in fuel:
importance: Undecided → Medium
Dmitry Pyzhov (dpyzhov) on 2015-03-27
tags: added: feature-tasks
removed: granular
tags: added: module-tasks
removed: feature-tasks
Dima Shulyak (dshulyak) on 2015-04-03
Changed in fuel:
milestone: 6.1 → 7.0
tags: added: qa-agree-7.0 release-notes
Aleksey Kasatkin (alekseyk-ru) wrote :

Does not break deployment. Moving to 8.0.

tags: added: known-issue
Changed in fuel:
status: Confirmed → Won't Fix
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
status: Won't Fix → Confirmed
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Changed in fuel:
milestone: 8.0 → 9.0

We passed SCF in 8.0. Moving the bug to 9.0.

(This check performed automatically)
Please, make sure that bug description contains the following sections filled in with the appropriate data related to the bug you are describing:

actual result

For more detailed information on the contents of each of the listed sections see https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Here_is_how_you_file_a_bug

tags: added: need-info

Since 9.0 the task deployment engine is used by default instead of granular deploy. this bug is not actual more.

Changed in fuel:
status: Confirmed → Invalid
tags: removed: release-notes
tags: added: release-notes
tags: added: release-notes-done
removed: release-notes
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers