No feedback between fuel ui and granular deployment

Bug #1422435 reported by Igor Gajsin on 2015-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Bulat Gaifullin

Bug Description

If deployment fails Fuel show notification "Error. Deployment has failed ...". It's ok. But if after that we start deployment task on failed node separately and fix the problem this notification doesn't hide. Therefore we have correctly working environment which marked as failed. It's may confuse customers.

See screen for detail: http://tinypic.com/view.php?pic=5djep4&s=8
All nodes was deployed correctly but error-mark still here.

Dima Shulyak (dshulyak) wrote :

This behaviour is the same as if user will execute all deployment on nodes with:

fuel node --node 1,2 --deploy

I'm not sure if we are going to fix that, but anyway it is not for UI team

Changed in fuel:
assignee: Fuel UI Team (fuel-ui) → Fuel Python Team (fuel-python)
importance: Undecided → Medium
status: New → Confirmed
Dmitry Pyzhov (dpyzhov) on 2015-03-27
tags: added: module-tasks
removed: fuel-ui
Dima Shulyak (dshulyak) on 2015-04-03
Changed in fuel:
milestone: 6.1 → 7.0
tags: added: qa-agree-7.0 release-notes
tags: added: known-issue
Aleksey Kasatkin (alekseyk-ru) wrote :

Does not break deployment. Refers to feature on extended cluster status. Moving to 8.0.

Changed in fuel:
status: Confirmed → Won't Fix
Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
status: Won't Fix → Confirmed
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Changed in fuel:
milestone: 8.0 → 9.0
Dmitry Pyzhov (dpyzhov) wrote :

Looks like it should be fixed with patch for bug #1542201

Dmitry Pyzhov (dpyzhov) on 2016-03-02
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Bulat Gaifullin (bgaifullin)
status: Confirmed → Fix Committed
tags: added: on-verification

Steps used for verification:
1) Setup the master node
2) Make change at a compute.pp file, add fail statement
3) Create a cluster with controller and compute nodes
4) Start a deployment
5) After the deployment have failed remove the fail statement
6) Re-deploy the cluster

Result: deployment passed. there is no any error.

Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: on-verification
tags: added: release-notes-done
removed: release-notes
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers