ceilometer-api doesn't responce on requests

Bug #1415955 reported by Anastasia Palkina on 2015-01-29
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Ilya Tyaptin
6.0.x
High
Ilya Tyaptin

Bug Description

"build_id": "2015-01-28_22-55-01",
"ostf_sha": "c9100263140008abfcc2704732e98fbdfd644068",
"build_number": "84",
"release_versions": {"2014.2-6.1": {"VERSION": {"build_id": "2015-01-28_22-55-01", "ostf_sha": "c9100263140008abfcc2704732e98fbdfd644068", "build_number": "84", "api": "1.0", "nailgun_sha": "92a85025f0ef9b3c5b42a1ba172573aa0ac54e33", "production": "docker", "python-fuelclient_sha": "cb8928ce34f5ca88c0d6cecc6331488db75362ac", "astute_sha": "ed5270bf9c6c1234797e00bd7d4dd3213253a413", "feature_groups": ["mirantis"], "release": "6.1", "fuelmain_sha": "", "fuellib_sha": "b2fbaa9ffb74fafe1f5c2c480944a78424e1ae28"}}},
"auth_required": true,
"api": "1.0",
"nailgun_sha": "92a85025f0ef9b3c5b42a1ba172573aa0ac54e33",
"production": "docker",
"python-fuelclient_sha": "cb8928ce34f5ca88c0d6cecc6331488db75362ac",
"astute_sha": "ed5270bf9c6c1234797e00bd7d4dd3213253a413",
"feature_groups": ["mirantis"],
"release": "6.1",
"fuelmain_sha": "",
"fuellib_sha": "b2fbaa9ffb74fafe1f5c2c480944a78424e1ae28"

1. Create new environment (CentOS)
2. Choose neutron, GRE
3. Choose Ceilometer
4. Add 3 controller+cinder+mongo, 2 compute, 1 cinder, 2 mongo
5. Start deployment. It was successful
6. Start OSTF tests. Tests with ceilometer have failed.

[root@node-5 ~]# ceilometer meter-list
HTTPConnectionPool(host='172.16.0.2', port=8777): Max retries exceeded with url: /v2/meters (Caused by <class 'httplib.BadStatusLine'>: )
[root@node-5 ~]

Logs are here: https://drive.google.com/a/mirantis.com/file/d/0B6SjzarTGFxaemtKU0tMOUVjZE0/view?usp=sharing

Changed in fuel:
status: New → Confirmed
assignee: MOS Ceilometer (mos-ceilometer) → Ilya Tyaptin (ityaptin)
OSCI Robot (oscirobot) wrote :

RPM package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.1.mira21.git.97323d8.b6b17a4

Changeset: https://review.fuel-infra.org/2763
project: openstack/ceilometer
branch: openstack-ci/fuel-6.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: patchset-created

Files placed on repository:
openstack-ceilometer-alarm-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
openstack-ceilometer-api-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
openstack-ceilometer-central-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
openstack-ceilometer-collector-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
openstack-ceilometer-common-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
openstack-ceilometer-compute-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
openstack-ceilometer-notification-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm
python-ceilometer-2014.2-fuel6.1.mira21.git.97323d8.b6b17a4.noarch.rpm

NOTE: Changeset is not merged, created temporary package repository.
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.1-stable-2763/centos

OSCI Robot (oscirobot) wrote :

DEB package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.1~mira20+git.97323d8.b6b17a4

Changeset: https://review.fuel-infra.org/2763
project: openstack/ceilometer
branch: openstack-ci/fuel-6.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: patchset-created

Files placed on repository:
ceilometer-agent-central_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-agent-compute_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-agent-notification_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-alarm-evaluator_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-alarm-notifier_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-api_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-collector_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
ceilometer-common_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb
python-ceilometer_2014.2-fuel6.1~mira20+git.97323d8.b6b17a4_all.deb

NOTE: Changeset is not merged, created temporary package repository.
DEB repository URL: http://osci-obs.vm.mirantis.net:82/ubuntu-fuel-6.1-stable-2763/ubuntu

OSCI Robot (oscirobot) wrote :

RPM package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.0.1.mira22.git.14fc64e.b6b17a4

Changeset: https://review.fuel-infra.org/2764
project: openstack/ceilometer
branch: openstack-ci/fuel-6.0.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: patchset-created

Files placed on repository:
openstack-ceilometer-alarm-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
openstack-ceilometer-api-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
openstack-ceilometer-central-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
openstack-ceilometer-collector-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
openstack-ceilometer-common-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
openstack-ceilometer-compute-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
openstack-ceilometer-notification-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm
python-ceilometer-2014.2-fuel6.0.1.mira22.git.14fc64e.b6b17a4.noarch.rpm

NOTE: Changeset is not merged, created temporary package repository.
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.0.1-stable-2764/centos

OSCI Robot (oscirobot) wrote :

DEB package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.0.1~mira21+git.14fc64e.b6b17a4

Changeset: https://review.fuel-infra.org/2764
project: openstack/ceilometer
branch: openstack-ci/fuel-6.0.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: patchset-created

Files placed on repository:
ceilometer-agent-central_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-agent-compute_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-agent-notification_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-alarm-evaluator_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-alarm-notifier_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-api_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-collector_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
ceilometer-common_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb
python-ceilometer_2014.2-fuel6.0.1~mira21+git.14fc64e.b6b17a4_all.deb

NOTE: Changeset is not merged, created temporary package repository.
DEB repository URL: http://osci-obs.vm.mirantis.net:82/ubuntu-fuel-6.0.1-stable-2764/ubuntu

OSCI Robot (oscirobot) wrote :

RPM package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.0.1.mira22

Changeset: https://review.fuel-infra.org/2764
project: openstack/ceilometer
branch: openstack-ci/fuel-6.0.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: change-merged

Files placed on repository:
openstack-ceilometer-alarm-2014.2-fuel6.0.1.mira22.noarch.rpm
openstack-ceilometer-api-2014.2-fuel6.0.1.mira22.noarch.rpm
openstack-ceilometer-central-2014.2-fuel6.0.1.mira22.noarch.rpm
openstack-ceilometer-collector-2014.2-fuel6.0.1.mira22.noarch.rpm
openstack-ceilometer-common-2014.2-fuel6.0.1.mira22.noarch.rpm
openstack-ceilometer-compute-2014.2-fuel6.0.1.mira22.noarch.rpm
openstack-ceilometer-notification-2014.2-fuel6.0.1.mira22.noarch.rpm
python-ceilometer-2014.2-fuel6.0.1.mira22.noarch.rpm

Changeset merged. Package placed on primary repository
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.0.1-stable/centos

OSCI Robot (oscirobot) wrote :

RPM package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.1.mira21

Changeset: https://review.fuel-infra.org/2763
project: openstack/ceilometer
branch: openstack-ci/fuel-6.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: change-merged

Files placed on repository:
openstack-ceilometer-alarm-2014.2-fuel6.1.mira21.noarch.rpm
openstack-ceilometer-api-2014.2-fuel6.1.mira21.noarch.rpm
openstack-ceilometer-central-2014.2-fuel6.1.mira21.noarch.rpm
openstack-ceilometer-collector-2014.2-fuel6.1.mira21.noarch.rpm
openstack-ceilometer-common-2014.2-fuel6.1.mira21.noarch.rpm
openstack-ceilometer-compute-2014.2-fuel6.1.mira21.noarch.rpm
openstack-ceilometer-notification-2014.2-fuel6.1.mira21.noarch.rpm
python-ceilometer-2014.2-fuel6.1.mira21.noarch.rpm

Changeset merged. Package placed on primary repository
RPM repository URL: http://osci-obs.vm.mirantis.net:82/centos-fuel-6.1-stable/centos

OSCI Robot (oscirobot) wrote :

DEB package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.0.1~mira21

Changeset: https://review.fuel-infra.org/2764
project: openstack/ceilometer
branch: openstack-ci/fuel-6.0.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: change-merged

Files placed on repository:
ceilometer-agent-central_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-agent-compute_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-agent-notification_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-alarm-evaluator_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-alarm-notifier_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-api_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-collector_2014.2-fuel6.0.1~mira21_all.deb
ceilometer-common_2014.2-fuel6.0.1~mira21_all.deb
python-ceilometer_2014.2-fuel6.0.1~mira21_all.deb

Changeset merged. Package placed on primary repository
DEB repository URL: http://osci-obs.vm.mirantis.net:82/ubuntu-fuel-6.0.1-stable/ubuntu

OSCI Robot (oscirobot) wrote :

DEB package ceilometer has been built for project openstack/ceilometer
Package version == 2014.2, package release == fuel6.1~mira20

Changeset: https://review.fuel-infra.org/2763
project: openstack/ceilometer
branch: openstack-ci/fuel-6.1/2014.2
author: Ilya Tyaptin
committer: Ilya Tyaptin
subject: Fix getattr in CursorProxy
status: change-merged

Files placed on repository:
ceilometer-agent-central_2014.2-fuel6.1~mira20_all.deb
ceilometer-agent-compute_2014.2-fuel6.1~mira20_all.deb
ceilometer-agent-notification_2014.2-fuel6.1~mira20_all.deb
ceilometer-alarm-evaluator_2014.2-fuel6.1~mira20_all.deb
ceilometer-alarm-notifier_2014.2-fuel6.1~mira20_all.deb
ceilometer-api_2014.2-fuel6.1~mira20_all.deb
ceilometer-collector_2014.2-fuel6.1~mira20_all.deb
ceilometer-common_2014.2-fuel6.1~mira20_all.deb
python-ceilometer_2014.2-fuel6.1~mira20_all.deb

Changeset merged. Package placed on primary repository
DEB repository URL: http://osci-obs.vm.mirantis.net:82/ubuntu-fuel-6.1-stable/ubuntu

Changed in fuel:
status: Confirmed → Fix Committed
Anastasia Palkina (apalkina) wrote :

Verified on ISO #92

"build_id": "2015-02-01_22-55-01", "ostf_sha": "c9100263140008abfcc2704732e98fbdfd644068", "build_number": "92", "release_versions": {"2014.2-6.1": {"VERSION": {"build_id": "2015-02-01_22-55-01", "ostf_sha": "c9100263140008abfcc2704732e98fbdfd644068", "build_number": "92", "api": "1.0", "nailgun_sha": "c0932eb5c2aa7fd1e13a999cb1b4bf5aff101c3b", "production": "docker", "python-fuelclient_sha": "2ea7b3e91c1d2ff85110bf5abb161a6f4e537358", "astute_sha": "ed5270bf9c6c1234797e00bd7d4dd3213253a413", "feature_groups": ["mirantis"], "release": "6.1", "fuelmain_sha": "", "fuellib_sha": "c5e4a0410ba66f9e9911f62b3b71c0b9c29aed6e"}}}, "auth_required": true, "api": "1.0", "nailgun_sha": "c0932eb5c2aa7fd1e13a999cb1b4bf5aff101c3b", "production": "docker", "python-fuelclient_sha": "2ea7b3e91c1d2ff85110bf5abb161a6f4e537358", "astute_sha": "ed5270bf9c6c1234797e00bd7d4dd3213253a413", "feature_groups": ["mirantis"], "release": "6.1", "fuelmain_sha": "", "fuellib_sha": "c5e4a0410ba66f9e9911f62b3b71c0b9c29aed6e"

Changed in fuel:
status: Fix Committed → Fix Released

Fix proposed to branch: openstack-ci/fuel-6.0-updates/2014.2
Change author: Ilya Tyaptin <email address hidden>
Review: https://review.fuel-infra.org/6803

Reviewed: https://review.fuel-infra.org/6803
Submitter: mos-infra-ci <>
Branch: openstack-ci/fuel-6.0-updates/2014.2

Commit: 69c7c93778c61954419649e838c40c2b885f7bb2
Author: Ilya Tyaptin <email address hidden>
Date: Tue May 19 15:21:03 2015

Fix getattr in CursorProxy

Change-Id: I5af9f05a13b0be4538f9c2a3f472cbc9886f78c6
Closes-bug: #1415955
(cherry picked from commit 97323d8b947ad0db7dabd424fa4f15731286f6e6)

Ilya Tyaptin (ityaptin) wrote :

This fix is not actual for openstack-ci/fuel-6.0-updates/2014.2, because it fixes a bug that has been landed during the developing MOS 6.0.1 [1].
So, the cherry-picking this commit to 6.0-updates breaks the ceilometer, I think.
Please, mark this bug Invalid for 6.0-updates and revert.

[1] https://review.fuel-infra.org/gitweb?p=openstack/ceilometer.git;a=commit;h=dee803e959ba859c95a172c898b9c5ad595db28b

Thank you,
Ilya Tyaptin,
Ceilometer developer,
Mirantis Inc.

Fix proposed to branch: openstack-ci/fuel-7.0/2015.1.0
Change author: Ilya Tyaptin <email address hidden>
Review: https://review.fuel-infra.org/8060

Change abandoned by Ilya Tyaptin <email address hidden> on branch: openstack-ci/fuel-7.0/2015.1.0
Review: https://review.fuel-infra.org/8060

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers