Version of plugins is incompatible with release version

Bug #1415058 reported by Tatyanka on 2015-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Fuel Python (Deprecated)
6.0.x
Medium
Fuel Python (Deprecated)
7.0.x
Medium
Fuel Python (Deprecated)

Bug Description

http://jenkins-product.srt.mirantis.net:8080/view/6.1_swarm/job/6.1.system_test.centos.plugins

For plugins: glusterfs, exemple, lbaas we have next data
# The plugin is compatible with releases in the list
releases:
  - os: ubuntu
    version: 2014.2-6.0
    mode: ['ha', 'multinode']
    deployment_scripts_path: deployment_scripts/
    repository_path: repositories/ubuntu
  - os: centos
    version: 2014.2-6.0
    mode: ['ha', 'multinode']
    deployment_scripts_path: deployment_scripts/
    repository_path: repositories/centos

As result those plugins is unavailable for 2014.1-6.1 release

Dima Shulyak (dshulyak) on 2015-02-09
Changed in fuel:
status: New → Triaged

Guys, please fix this bug, because it affects 3 system tests. Now they are failed.

Changed in fuel:
importance: Medium → High
Dmitry Pyzhov (dpyzhov) on 2015-03-27
tags: added: feature-plugins
Tatyanka (tatyana-leontovich) wrote :

the same for 6.0 for now we have 6.0.1

Tomasz 'Zen' Napierala (tzn) wrote :

This bug is +2 months old, I think we should assigne it to a person, not the team.

Fix proposed to branch: master
Review: https://review.openstack.org/169683

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Przemyslaw Kaminski (pkaminski)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/170094
Committed: https://git.openstack.org/cgit/stackforge/fuel-qa/commit/?id=c4e1ddaa718a53774b7bf9835304eee5dc9b2a8c
Submitter: Jenkins
Branch: master

commit c4e1ddaa718a53774b7bf9835304eee5dc9b2a8c
Author: Przemyslaw Kaminski <email address hidden>
Date: Thu Apr 2 13:59:08 2015 +0200

    Fix the incorrect get_node_by_name

    Change-Id: I603503bb1116e1c13115ef72bd953de3fa1a3b26
    Related-Bug: #1415058

Przemyslaw Kaminski (pkaminski) wrote :

As for milestone 6.0.x -- it's enough to leave '6.0' version in manifests provided this patch is landed to 6.0.x:

https://review.openstack.org/#/c/161197/2

Changed in fuel:
assignee: Przemyslaw Kaminski (pkaminski) → Sebastian Kalinowski (prmtl)

Reviewed: https://review.openstack.org/169683
Committed: https://git.openstack.org/cgit/stackforge/fuel-plugin-external-glusterfs/commit/?id=f9e49d151f4cb5e1f2142f019e2ba372d601a440
Submitter: Jenkins
Branch: master

commit f9e49d151f4cb5e1f2142f019e2ba372d601a440
Author: Przemyslaw Kaminski <email address hidden>
Date: Wed Apr 1 12:07:13 2015 +0200

    Ad 6.1 as supported version

    6.0.1 is accepted automatically since 6.0 is present.

    Change-Id: Ib2634718d4fe7e557758305a58744db538e5350e
    Partial-Bug: #1415058

Changed in fuel:
status: In Progress → Fix Committed
assignee: Sebastian Kalinowski (prmtl) → Przemyslaw Kaminski (pkaminski)

For now this bug is partly fixed. It is fixed only for glusterfs plugin [1], but it isn't for example [2] plugin

[1] https://github.com/stackforge/fuel-plugin-external-glusterfs
[2] https://github.com/stackforge/fuel-plugins

Changed in fuel:
status: Fix Committed → Incomplete

Reviewed: https://review.openstack.org/176314
Committed: https://git.openstack.org/cgit/stackforge/fuel-plugins/commit/?id=fd6ba4b81dd4c601afc66a2a0cce0c528f8c9d80
Submitter: Jenkins
Branch: master

commit fd6ba4b81dd4c601afc66a2a0cce0c528f8c9d80
Author: Evgeniy L <email address hidden>
Date: Wed Apr 22 16:48:21 2015 +0300

    Fix plugin example to be compatible with newer version of Fuel

    Change-Id: Ida4f2c1304a82fc48dfc157b76ef83f963124b31
    Related-bug: #1415058

Łukasz Oleś (loles) on 2015-04-28
Changed in fuel:
status: Incomplete → Fix Committed
tags: added: on-verification
Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: on-verification
Maksym Strukov (unbelll) wrote :

Reproduced again on 7.0-7

Maksym Strukov (unbelll) wrote :

Can't reproduce in 7.0-127

Alexey Stupnikov (astupnikov) wrote :

We no longer support MOS5.1, MOS6.0, MOS6.1
We deliver only Critical/Security fixes to MOS7.0, MOS8.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers