make iso fail because of missing apparmor

Bug #1387999 reported by Daniele Pizzolli on 2014-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Fuel Documentation Team

Bug Description

Steps to reproduce:

1. Download an mini.iso of ubuntu 14.04 from:
   http://archive.ubuntu.com/ubuntu/dists/trusty-updates/main/installer-amd64/current/images/netboot

2. Install it following the default settings.

3. Follow the instructions at
   http://docs.mirantis.com/fuel-dev/develop/env.html#building-the-fuel-iso

4. The make iso process will fail with:

2014/10/31 09:18:51 Cannot connect to the Docker daemon. Is 'docker -d' running on this host?
2014/10/31 09:18:51 Cannot connect to the Docker daemon. Is 'docker -d' running on this host?
2014/10/31 09:18:51 Cannot connect to the Docker daemon. Is 'docker -d' running on this host?
make: *** [/home/cd/fuel-main/build/docker/base-images.done] Error 123

An investigation shows:

cd@ubuntu:~/fuel-main$ sudo docker -d
2014/10/31 09:20:48 docker daemon: 1.3.1 4e9bbfa; execdriver: native; graphdriver:
[3ab1b669] +job serveapi(unix:///var/run/docker.sock)
[info] Listening for HTTP on unix (/var/run/docker.sock)
[3ab1b669] +job init_networkdriver()
[3ab1b669] -job init_networkdriver() = OK (0)
2014/10/31 09:20:48 WARNING: Your kernel does not support cgroup swap limit.
2014/10/31 09:20:48 Error loading docker apparmor profile: fork/exec /sbin/apparmor_parser: no such file or directory ()

And the solution is:

sudo apt-get install apparmor

I guess this should be installed with docker.

Changed in fuel:
assignee: nobody → Fuel OSCI Team (fuel-osci)
milestone: none → 6.0
Roman Vyalov (r0mikiam) on 2014-11-03
Changed in fuel:
importance: Undecided → Medium
status: New → Confirmed
assignee: Fuel OSCI Team (fuel-osci) → Fuel DevOps (fuel-devops)
Roman Vyalov (r0mikiam) on 2014-11-06
Changed in fuel:
assignee: Fuel DevOps (fuel-devops) → Matthew Mosesohn (raytrac3r)
Matthew Mosesohn (raytrac3r) wrote :

This is for fuel-devops. We're using a docker packaged by Ubuntu. It's fixed in the latest upstream version to have this dependency[1]. I suggest you just update the prepare Jenkins slave puppet manifests to include this package. We are still blocked from upgrading Docker beyond 0.10, so we must resort to local fixes to work around the problem.

[1]https://launchpad.net/ubuntu/vivid/+source/docker.io/1.2.0~dfsg1-1ubuntu1

Changed in fuel:
assignee: Matthew Mosesohn (raytrac3r) → Fuel DevOps (fuel-devops)
Mike Scherbakov (mihgen) on 2014-12-22
Changed in fuel:
milestone: 6.0 → 6.1
Alexander Charykov (acharykov) wrote :

Please use ./prepare-build-env.sh which is located in https://github.com/stackforge/fuel-main to build ISO.

tags: added: non-release
Aleksandra Fedorova (bookwar) wrote :

We've updated docker build dependency to 1.5.0.

https://github.com/stackforge/fuel-main/commit/3bc810418c9b28246a0f0d8e9f9b29200c9fabf1

Is this bug still relevant?

Changed in fuel:
status: Confirmed → Incomplete
Changed in fuel:
status: Incomplete → Invalid
Matthew Mosesohn (raytrac3r) wrote :

This is from several months ago now. If you can reproduce this on Ubuntu 14.04 after running prepare-build-env.sh, please reopen.

Hello,
yes, the problem is still here:

touch /home/user/fuel-main/build/iso/isoroot-dotfiles.done
for container in /home/user/fuel-main/local_mirror/docker/*.xz; do xz -dkc -T0 $container | sudo docker load; done
FATA[0001] Cannot connect to the Docker daemon. Is 'docker -d' running on this host?
FATA[0000] Cannot connect to the Docker daemon. Is 'docker -d' running on this host?
make: *** [/home/user/fuel-main/build/docker/base-images.done] Error 1

I noticed also that you need to add the universe to the repo in order to have a correct run of prepare-build-env.sh

Changed in fuel:
status: Invalid → New
Sergey Kulanov (skulanov) wrote :

Hello Daniele, could you please share any additional details?

Because,
1) I've installed iso from the link http://archive.ubuntu.com/ubuntu/dists/trusty-updates/main/installer-amd64/current/images/netboot
2) ran ./prepare-build-env.sh
3) ran make iso

and it works

Hello Sergey,

Thanks for the investigation.

I selected the expert console install and skipped almost all the
configuration options and additional packages.

This installs a really minimal ubuntu, without apparmor.

If at the end of the ubuntu installation dpkg -l | grep apparmor
return something, you have installed something more than the minimal
ubuntu and thus you will be unable to reproduce this problem.

I can create a preseeding file to ease the reproduction of the problem.

Best,
Daniele

Igor Shishkin (teran) wrote :

Since it's related to documentation on docs.mirantis.com reassigning to docs team.

tags: added: docs
Changed in fuel:
assignee: Fuel DevOps (fuel-devops) → Fuel Documentation Team (fuel-docs)
Changed in fuel:
status: New → Confirmed
Changed in fuel:
milestone: 6.1 → 7.0
Igor Shishkin (teran) on 2015-10-08
Changed in fuel:
milestone: 7.0 → 8.0
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-docs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers