Spapshot of instance failed when vCenter used as backend for glance

Bug #1383241 reported by Stepan Rogov on 2014-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Stepan Rogov

Bug Description

VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "6.0"
  api: "1.0"
  build_number: "17"
  build_id: "2014-10-17_00-01-06"
  astute_sha: "c3e7c7a18528cf9acca48021488a93dff74f5c97"
  fuellib_sha: "1e5ec2f960c0eca36d9c2192bbad47dbfe55052e"
  ostf_sha: "de177931b53fbe9655502b73d03910b8118e25f1"
  nailgun_sha: "e548b10542d11fdb53ba448c98d30f61af3194fa"
  fuelmain_sha: "451001142c4974023682e52af7fdd4d01281e1d3"

Simple Centos + vCenter + ( Glance + vCenter backend )

After deploy, when i try to make an shapshot, after some time(3-4 min) the process is terminated with an Glance error:

2014-10-20 10:41:20.649 24721 INFO glance.wsgi.server [53c4840b-8703-4deb-88e8-bb71be24eb2b ef04c5fee6674b8bb52206c8bb120ea6 9b00c79fa8ae46e2b29cbb945e0df7ff - - -] 172.16.0.2 - - [20/Oct/2014 10:41:20] "HEAD /v1/images/cffcb268-65e0-42b7-88cb-7a177fba3e1e HTTP/1.1" 200 1909 0.058548
2014-10-20 10:41:25.563 24719 ERROR glance.store.vmware_datastore [8abae469-7225-4bf1-ad50-bd20a04026e9 ef04c5fee6674b8bb52206c8bb120ea6 9b00c79fa8ae46e2b29cbb945e0df7ff - - -] Failed to upload content of image cffcb268-65e0-42b7-88cb-7a177fba3e1e
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore Traceback (most recent call last):
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore File "/usr/lib/python2.6/site-packages/glance/store/vmware_datastore.py", line 277, in add
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore res = conn.getresponse()
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore File "/usr/lib64/python2.6/httplib.py", line 990, in getresponse
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore response.begin()
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore File "/usr/lib64/python2.6/httplib.py", line 391, in begin
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore version, status, reason = self._read_status()
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore File "/usr/lib64/python2.6/httplib.py", line 355, in _read_status
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore raise BadStatusLine(line)
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore BadStatusLine
2014-10-20 10:41:25.563 24719 TRACE glance.store.vmware_datastore
............................................................................

Stepan Rogov (srogov) on 2014-10-20
description: updated
Changed in fuel:
assignee: nobody → Stepan Rogov (srogov)
description: updated
Stepan Rogov (srogov) on 2014-10-20
Changed in fuel:
milestone: none → 6.0
importance: Undecided → High
Changed in fuel:
status: New → Confirmed
Stepan Rogov (srogov) wrote :

The problem was in the configuration of our lab.
After switching from the virtualbox to vmware workstation, everything works fine.

Changed in fuel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers