Need to set optimized parameters for installation on SSD disks

Bug #1374968 reported by Timur Nurlygayanov on 2014-09-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Kostiantyn Danylov
8.0.x
Medium
MOS Ceph
Mitaka
Medium
Kostiantyn Danylov

Bug Description

When we use SSD disks for installation of OpenStack/Ceph we need to use more optimized parameters to get normal performance.

1. Need to set disks scheduler to 'deadline' for SSD disks:
echo "deadline" >> /sys/block/<disk>/queue/scheduler

2. Mount it with the following options:
rw,noexec,inode64,logbsize=256k,delaylog,nodev,noatime,nodiratime,user_xattr,data=writeback

tags: added: customer-found
Changed in fuel:
assignee: nobody → Fuel Library Team (fuel-library)
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Vladimir Kozhukalov (kozhukalov)
Sergii Golovatiuk (sgolovatiuk) wrote :

This bug is related to
https://bugs.launchpad.net/fuel/+bug/1318614

which causes high degradation because of 512b blocks instead of 4k. There should be a logic that will set the most optimal settings for different types of RAID or SSD disks.

Changed in fuel:
status: New → Triaged
Dmitry Borodaenko (angdraug) wrote :

Please use deadline scheduler instead of noop:
https://wiki.debian.org/SSDOptimization#Low-Latency_IO-Scheduler

Dmitry, thank you! Description was updated.

description: updated
Changed in fuel:
milestone: 6.0 → 6.1
Dmitry Pyzhov (dpyzhov) on 2015-02-17
Changed in fuel:
milestone: 6.1 → 7.0

Since https://bugs.launchpad.net/fuel/+bug/1418126 we are now use deadline as default for all disks

Dmitry Pyzhov (dpyzhov) on 2015-03-23
tags: added: volumes
Dmitry Pyzhov (dpyzhov) on 2015-03-30
tags: added: module-volumes
removed: volumes
Mike Scherbakov (mihgen) wrote :

Please consider if we can do required changes now since we've got IBP. It might be just simple logic as "if it's SSD, run these few lines / choose to run specific mount command". Please comment here.

tags: added: feature
Changed in fuel:
assignee: Vladimir Kozhukalov (kozhukalov) → Fuel Python Team (fuel-python)
Aleksey Kasatkin (alekseyk-ru) wrote :

It's feature-dependent and related BPs are moved to future release. So, it is moved to 8.0.

Changed in fuel:
status: Triaged → Won't Fix
Aleksey Kasatkin (alekseyk-ru) wrote :
Alex Schultz (alex-schultz) wrote :

MOS-Ceph please investigate what default configuration should be used.

Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 7.0 → 8.0
status: Won't Fix → Triaged
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-mos
Alexey Shtokolov (ashtokolov) wrote :

MOS-Ceph please give us an update about what default configuration should be used.

Changed in fuel:
status: Triaged → Incomplete
Changed in fuel:
status: Incomplete → Confirmed

> 2. Mount it with the following options: rw,noexec,inode64,logbsize=256k,delaylog,nodev,noatime,nodiratime,user_xattr,data=writeback

The recommended filesystem for OSD storage is XFS. Unlike ext[34] it has a single journaling algorithm
(which is somewhat similar to data=writeback of ext[34]). Therefore there's no mount option(s) which
specify the journaling algorithm (which is what data=writeback|ordered|journal does for ext[34]]).

noexec,nodev have no effect on performance

delaylog is the XFS' default
inode64 is enabled on 64-bit systems by default
user_xattr is not a valid XFS mount option (extended attributes are always enabled)

Piotr Skamruk (jell) wrote :

AIR filesystem options was secondary in this issue. Main difference was done by IO scheduler for specific device.

If now XFS is default fs for OSD (as it should be, similar approach is usual suggestion for databases also) - second point is in fact out of date...

tags: added: wontfix-feature
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers