[library] neutron.rb uses cached call to keystone provider and can end up raising nil exception or otherwise fail to find resources created during this run of puppet

Bug #1344293 reported by Andrew Woodward on 2014-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Bogdan Dobrelya
puppet-keystone
Undecided
Unassigned
puppet-neutron
Undecided
Unassigned

Bug Description

https://github.com/stackforge/puppet-neutron/blob/master/lib/puppet/provider/neutron.rb#L157-170 can end up raising a nil exception in https://github.com/stackforge/puppet-keystone/blob/master/lib/puppet/provider/keystone_tenant/keystone.rb

changing https://github.com/stackforge/puppet-keystone/blob/master/lib/puppet/provider/keystone_tenant/keystone.rb#L29

from
  @tenant_hash ||= build_tenant_hash
to
 @tenant_hash = build_tenant_hash

was enough to stop the error.

Note this was noted with an much older version of keystone and could possibly not apply any longer, however it will be re-evaluated when we pull the new kesystone module in the next couple of weeks

Andrew Woodward (xarses) on 2014-07-18
Changed in fuel:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Andrew Woodward (xarses)
milestone: none → 5.1
Dmitry Ilyin (idv1985) on 2014-07-21
summary: - neutron.rb uses cached call to keystone provider and can end up raising
- nil exception or otherwise fail to find resources created during this
- run of puppet
+ [library] neutron.rb uses cached call to keystone provider and can end
+ up raising nil exception or otherwise fail to find resources created
+ during this run of puppet
Andrew Woodward (xarses) on 2014-07-22
summary: - [library] neutron.rb uses cached call to keystone provider and can end
- up raising nil exception or otherwise fail to find resources created
- during this run of puppet
+ neutron.rb uses cached call to keystone provider and can end up raising
+ nil exception or otherwise fail to find resources created during this
+ run of puppet
tags: added: library
Dmitry Ilyin (idv1985) on 2014-07-23
Changed in fuel:
assignee: Andrew Woodward (xarses) → Dmitry Ilyin (idv1985)
summary: - neutron.rb uses cached call to keystone provider and can end up raising
- nil exception or otherwise fail to find resources created during this
- run of puppet
+ [library] neutron.rb uses cached call to keystone provider and can end
+ up raising nil exception or otherwise fail to find resources created
+ during this run of puppet
Dmitry Ilyin (idv1985) wrote :

It's easy to fix but it will require modificaton of the upstream keystone module. I don't think its woth it.
Or we can send patch to the upstream...

Changed in fuel:
status: Confirmed → Won't Fix
assignee: Dmitry Ilyin (idv1985) → Fuel Library Team (fuel-library)
Andrew Woodward (xarses) wrote :

This is a confirmed issue and must be addressed upstream or in fuel before closing

Changed in fuel:
status: Won't Fix → Confirmed
milestone: 5.1 → 6.0
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Sergey Vasilenko (xenolog)
Matthew Mosesohn (raytrac3r) wrote :

Status update?

Changed in fuel:
assignee: Sergey Vasilenko (xenolog) → Fuel Library Team (fuel-library)
Changed in fuel:
milestone: 6.0 → 6.1
Changed in fuel:
status: Confirmed → Triaged
Changed in puppet-neutron:
status: New → Confirmed
Changed in puppet-keystone:
status: New → Confirmed
assignee: nobody → Bogdan Dobrelya (bogdando)
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Bogdan Dobrelya (bogdando)
milestone: 6.1 → 6.0

Fix proposed to branch: master
Review: https://review.openstack.org/134305

Changed in puppet-keystone:
status: Confirmed → In Progress
Changed in fuel:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/134566
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=0ef4afd9f5a78b82e50bb85affcce8afa5421544
Submitter: Jenkins
Branch: master

commit 0ef4afd9f5a78b82e50bb85affcce8afa5421544
Author: Bogdan Dobrelya <email address hidden>
Date: Fri Nov 14 16:25:10 2014 +0100

    Sync fix keystone entities evaluation for cached catalog usage

    Source upstream patch-set: https://review.openstack.org/#/c/134305/

    Closes-bug: #1344293

    Change-Id: I2fc529155c7e6f615fcf1b32247f890266f7d6c9
    Signed-off-by: Bogdan Dobrelya <email address hidden>

Changed in fuel:
status: In Progress → Fix Committed
Sergey Vasilenko (xenolog) wrote :

Can't reproduce on #114 and later

Change abandoned by Bogdan Dobrelya (<email address hidden>) on branch: master
Review: https://review.openstack.org/134305

Changed in puppet-keystone:
assignee: Bogdan Dobrelya (bogdando) → nobody
Emilien Macchi (emilienm) wrote :

is this bug still in progress upstream side?

Changed in puppet-keystone:
status: In Progress → New
Matt Fischer (mfisch) on 2015-09-02
Changed in puppet-keystone:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers