Savanna deployment failed with error

Bug #1327987 reported by Nastya Urlapova on 2014-06-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Sergii Golovatiuk

Bug Description

iso fuel-4.1-357-2014-06-09_00-40-36.iso

Scenario:
            1. Create cluster. Set install Savanna option
            2. Add 1 node with controller role
            3. Add 1 node with compute role
            4. Deploy the cluster

2014-06-08T22:27:02.067120+00:00 err: Duplicate declaration: Nova_config[DEFAULT/scheduler_default_filters] is already declared in file /etc/puppet/modules/nova/manifests/scheduler/filter.pp at line 91; cannot redeclare at /etc/puppet/modules/savanna/manifests/api.pp:131 on node node-2.test.domain.local

Nastya Urlapova (aurlapova) wrote :
Changed in fuel:
milestone: none → 4.1.1
assignee: Fuel Library Team (fuel-library) → Sergii Golovatiuk (sgolovatiuk)
Changed in fuel:
status: New → Confirmed

Reviewed: https://review.openstack.org/98717
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=245b99f3733fa1b24208c2d732236d404e79abd1
Submitter: Jenkins
Branch: stable/4.1

commit 245b99f3733fa1b24208c2d732236d404e79abd1
Author: Sergii Golovatiuk <email address hidden>
Date: Sat Apr 26 18:45:54 2014 +0000

    Fixes bug in scheduler filter for Savanna

    Merge default options for Savanna filter
    and define it in the upper layer to avoid
    duplicates

    Change-Id: I833354d3872a3a86accfe1bb6ec51438bfc5618e
    Closes-Bug: #1327987

Changed in fuel:
status: Confirmed → Fix Committed
Dmitry Borodaenko (angdraug) wrote :

This was a duplicate of https://bugs.launchpad.net/fuel/+bug/1312790 and was fixed by backporting https://review.openstack.org/90562 to stable/4.1.

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers