Node bootstraped but in UI no info about bootsraped nodes

Bug #1327229 reported by Egor Kotko on 2014-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Unassigned

Bug Description

{"build_id": "2014-06-06_15-09-28", "mirantis": "yes", "build_number": "350", "nailgun_sha": "bdc747cd70721874d1e8af36181fd4179cce4fce", "ostf_sha": "2b7b39e4b6ea89751b65171f24a8e80b5cac56aa", "fuelmain_sha": "1e0f6790c46cc06af329729010b678acefce85c2", "astute_sha": "55df06b2e84fa5d71a1cc0e78dbccab5db29d968", "release": "4.1B", "fuellib_sha": "db24da4030c5d3f9e7743cd872b0deec094217d3"}

1. Setup master
2. Create nodes
3. Boot its via PXE

Expected result:
Nodes will bee accessible via UI
Actual result
Nodes bootstrapped but no notifications via UI and no possibility manage its trough UI.

Egor Kotko (ykotko) wrote :
Artem Panchenko (apanchenko-8) wrote :

This issue is caused by wrong dependency in openssl-1.0.1e-16.14.mira2.x86_64.rpm package:

# rpm -qp --requires openssl-1.0.1e-16.14.mira2.x86_64.rpm | grep make
make

During building of Fuel iso we create initramfs image for cobbler bootstrap profile based on CentOS and remove 'make' utility there. So that dependency causes deleting of openssl and lots of other packages in initramfs image (including dhclient). So bootstraped nodes can't get IP configuration from master node.

Changed in fuel:
assignee: nobody → Fuel OSCI Team (fuel-osci)
importance: High → Critical
Changed in fuel:
status: New → Confirmed

Reviewed: https://review.openstack.org/98436
Committed: https://git.openstack.org/cgit/stackforge/fuel-main/commit/?id=99c4841d3403c89f5f29247469e9ab478283e943
Submitter: Jenkins
Branch: stable/4.1

commit 99c4841d3403c89f5f29247469e9ab478283e943
Author: Dmitry Burmistrov <email address hidden>
Date: Fri Jun 6 18:50:44 2014 +0400

    Keep 'make' package in bootstrap image

    Change-Id: Iecc2947198261fc58cdf6ad46716190ee7829c2a
    Closes-Bug: #1327229

Changed in fuel:
status: Confirmed → In Progress
Changed in fuel:
status: In Progress → Fix Committed
Egor Kotko (ykotko) wrote :

Verified on:
{"build_id": "2014-06-09_18-57-15", "mirantis": "yes", "build_number": "358", "nailgun_sha": "bdc747cd70721874d1e8af36181fd4179cce4fce", "ostf_sha": "2b7b39e4b6ea89751b65171f24a8e80b5cac56aa", "fuelmain_sha": "d78592dddb1364693457d90363bfd335f0496ea1", "astute_sha": "55df06b2e84fa5d71a1cc0e78dbccab5db29d968", "release": "4.1.1", "fuellib_sha": "245b99f3733fa1b24208c2d732236d404e79abd1"}

Changed in fuel:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2016-07-29
Changed in fuel:
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers