Fuel marks all nodes as offline (deployment with VirtualBox)

Bug #1323316 reported by Nikolay Pliashechnikov on 2014-05-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Dmitry Burmistrov

Bug Description

Version information:
{
    "astute_sha": "55df06b2e84fa5d71a1cc0e78dbccab5db29d968",
    "build_id": "2014-05-26_04-18-31",
    "build_number": "325",
    "fuellib_sha": "c64ffdc5e7bfe7fa8eb971be1fea2260ee849ab5",
    "fuelmain_sha": "57de6680c01f587e7c2e4b5903317625b62f365a",
    "mirantis": "yes",
    "nailgun_sha": "e5e2894703bd5e5218ad96d6884bd39dc8e4e921",
    "ostf_sha": "3690709d95c1f42506b6d955b44221910cec8527",
    "release": "4.1B"
}

I deployed the 3-node non-HA Fuel 4.1 cluster using Ubuntu 12.04 and VirtualBox 4.3. Fuel was deployed with Ubuntu and Neutron/GRE, using VirtualBox scripts from Mirantis website. Shortly after OS installation, Web UI marked all 3 nodes as offline, but deployment continued successfully.
For now, Openstack cluster is online and nodes report to fuelmaster via API, but both Web UI and Fuel CLI still report them as offline:
[root@fuel ~]# fuel node
id | status | name | cluster | mac | roles | pending_roles | online
---|--------|------------------|---------|-------------------|-----------------|---------------|-------
1 | ready | Untitled (95:B0) | 1 | c6:df:08:ac:c8:49 | [u'compute'] | [] | False
3 | ready | Untitled (38:74) | 1 | e6:28:ac:fb:39:46 | [u'controller'] | [] | False
2 | ready | Untitled (35:16) | 1 | 46:67:09:fe:12:4e | [u'cinder'] | [] | False

Environment could be accessed if you have connectivity to KHA Mirantis office. Credentials are default.

ssh://root@172.18.194.16:2200
http://172.18.194.16:8000

Diagnostic snapshot is attached to the bug.

Changed in fuel:
assignee: nobody → Fuel Python Team (fuel-python)
milestone: none → 4.1.1
importance: Undecided → High
Dmitry Pyzhov (dpyzhov) wrote :

nailgun-agent package contains outdated code. OSCI guys, please review all nailgun-related packages in 4.1.1 repo. It seems that automatic rebuild is broken.

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Fuel OSCI Team (fuel-osci)
status: New → Confirmed
Changed in fuel:
assignee: Fuel OSCI Team (fuel-osci) → Dmitry Burmistrov (dburmistrov)
status: Confirmed → In Progress
Dmitry Borodaenko (angdraug) wrote :

4.1.1 Ubuntu mirror has the updated nailgun-agent package, leaving the bug open because we still need to fix automatic rebuild.

Changed in fuel:
milestone: 4.1.1 → 4.1.2
tags: added: osci
Roman Vyalov (r0mikiam) on 2014-06-24
Changed in fuel:
status: In Progress → Fix Committed
Kirill Omelchenko (komelchenko) wrote :

 Verified on iso 4.1.1:
{"build_id": "2014-06-26_04-36-50", "mirantis": "yes", "build_number": "375", "nailgun_sha": "bdc747cd70721874d1e8af36181fd4179cce4fce", "ostf_sha": "f4f15b4d98459650c1945b0efc30290a619be824", "fuelmain_sha": "ae77ae1c21a8715a63c7b1ca3f7a7ecadaff68aa", "astute_sha": "55df06b2e84fa5d71a1cc0e78dbccab5db29d968", "release": "4.1.1", "fuellib_sha": "a93544b7d7395043f3e55fec055841b8257be620"}

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers