Predefined networks from neutron are not avaialble on horizon

Bug #1319942 reported by Tatyanka on 2014-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Mike Scherbakov
4.1.x
High
Fuel Library (Deprecated)

Bug Description

Steps to Reproduce:
1. Deploy neutron gre with ceilometer / sahara/ murano and ceph and change defaults user/login/tenant in setting to something other
2. Run ostf all tests
3. Navigate in horizon and repeat all test from ostf trough horizon

Actual result:
All sanity and smoke test passed, the same result if I boot instance using nova cli, but I can not launch instance in horizon according to predefined nets(net04 and net04_ext) in not available here. But it presents in cli for the same tenant/user as in horizon
[root@node-1 ~]# nova net-list
+--------------------------------------+-----------+------+
| ID | Label | CIDR |
+--------------------------------------+-----------+------+
| 2865c97f-2e30-4eca-ad27-d9f19bae73d8 | net04 | - |
| f9d9ea3d-18fe-49f2-9f7b-71aecb6bca1a | net04_ext | - |
+--------------------------------------+-----------+------+

also I can create in horizon the same network as net04(the same name and data) that leads to error in when I launch instance with net04(Multiply choise)

Reproduce on 199 and 205 isos

Tatyanka (tatyana-leontovich) wrote :
Tatyanka (tatyana-leontovich) wrote :
summary: - Predefined networks from neutron in not avaialble on horizon
+ Predefined networks from neutron are not avaialble on horizon
Changed in fuel:
importance: Undecided → High
assignee: nobody → Sergey Vasilenko (xenolog)
Changed in fuel:
assignee: Sergey Vasilenko (xenolog) → Sergii Golovatiuk (sgolovatiuk)
Mike Scherbakov (mihgen) on 2014-05-19
Changed in fuel:
status: New → Confirmed
Changed in fuel:
status: Confirmed → Triaged

Fix proposed to branch: master
Review: https://review.openstack.org/94621

Changed in fuel:
status: Triaged → In Progress
Sergii Golovatiuk (sgolovatiuk) wrote :

Tenant ID was not added to networks due to wrong data structure. It's been corrected.

Changed in fuel:
assignee: Sergii Golovatiuk (sgolovatiuk) → Mike Scherbakov (mihgen)

Reviewed: https://review.openstack.org/94621
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=40f2d50019d156f549ff2be0a446cd318fed67a6
Submitter: Jenkins
Branch: master

commit 40f2d50019d156f549ff2be0a446cd318fed67a6
Author: Sergii Golovatiuk <email address hidden>
Date: Wed May 21 13:48:00 2014 +0000

    Fix neutron predefined network settings

    Fix neutron predefined network settings when admin tenant is not admin.

    Change-Id: I9a84e4b05bbb79c0e07fb0369b664ec9292a0339
    Closes-Bug: #1319942

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/96884
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=e1a7191ffd1057ba13ebc8c10e432b7db69c0307
Submitter: Jenkins
Branch: stable/4.1

commit e1a7191ffd1057ba13ebc8c10e432b7db69c0307
Author: Sergii Golovatiuk <email address hidden>
Date: Wed May 21 13:48:00 2014 +0000

    Fix neutron predefined network settings

    Fix neutron predefined network settings when admin tenant is not admin.

    Change-Id: I9a84e4b05bbb79c0e07fb0369b664ec9292a0339
    Closes-Bug: #1319942

Meg McRoberts (dreidellhasa) wrote :

Documented as fixed in 4.1.1 Release Notes

Tatyanka (tatyana-leontovich) wrote :

verified 6.1-rc3

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers