Neutron l3 agent does not associate floating ip

Bug #1315338 reported by Vladimir Kuklin on 2014-05-02
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Fuel Library (Deprecated)
4.1.x
Critical
Fuel Library (Deprecated)

Bug Description

{"build_id": "2014-05-02_02-07-11", "mirantis": "yes", "build_number": "176", "ostf_sha": "134765fcb5a07dce0cd1bb399b2290c988c3c63b", "nailgun_sha": "621dbc810c52d5150ad0cc1edb8e8be379985097", "production": "docker", "api": "1.0", "fuelmain_sha": "95c35c199c2efc03fb105d090c5a42525430b7b3", "astute_sha": "3cffebde1e5452f5dbf8f744c6525fc36c7afbf3", "release": "5.0", "fuellib_sha": "b558bb39b7f94ce08ecfc3c20892742206c9878d"}

deploy simple neutron gre env

start a vm
VM is pingable from qrouter namespace

associate floating ip using neutron client with corresponding port of the VM

expected result:

qrouter namespace has floating ip assigned to qg-* interface and VM is reachable

actual result:

look into qrouter namespace: there are no NAT rules, no ip addresses assigned to the qg-* interface. vm is unreachable

restart l3 agent. ip is finally assigned to qg interface, VM is pingable.

Vladimir Kuklin (vkuklin) wrote :
Vladimir Kuklin (vkuklin) wrote :

the problem is report interval is twice time bigger than agent_down_time, that's why server is not considering them as alive

Reviewed: https://review.openstack.org/91767
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=cf69cc4475c18a8a5f70eada4431b6de9a8eb0d6
Submitter: Jenkins
Branch: master

commit cf69cc4475c18a8a5f70eada4431b6de9a8eb0d6
Author: Vladimir Kuklin <email address hidden>
Date: Fri May 2 15:06:32 2014 +0400

    Specify report interval for neutron configuration

    Set report interval to 5 seconds which is 3 times
    lower than agent_down_time or it may lead to
    agent status flapping and neutron server not
    communicating with agents

    Change-Id: I65dc90df6ea331de624f50ff5da97c46a881b06a
    Closes-Bug: #1315338

Changed in fuel:
status: Confirmed → Fix Committed
Anastasia Palkina (apalkina) wrote :

Verified on ISO #26
"build_id": "2014-05-27_05-51-41",
"mirantis": "yes",
"build_number": "26",
"ostf_sha": "a8b7660082a6f152794c610d6abe30d360fd577d",
"nailgun_sha": "bd09f89ef56176f64ad5decd4128933c96cb20f4",
"production": "docker",
"api": "1.0",
"fuelmain_sha": "505741e4f431f85a8d0252fc42754d10c0326c1a",
"astute_sha": "a7eac46348dc77fc2723c6fcc3dbc66cc1a83152",
"release": "5.0",
"fuellib_sha": "2f79c0415159651fc1978d99bd791079d1ae4a06"

Changed in fuel:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/96881
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=1af39176e685220316c174d28368760f3b07308b
Submitter: Jenkins
Branch: stable/4.1

commit 1af39176e685220316c174d28368760f3b07308b
Author: Vladimir Kuklin <email address hidden>
Date: Fri May 2 15:06:32 2014 +0400

    Specify report interval for neutron configuration

    Set report interval to 5 seconds which is 3 times
    lower than agent_down_time or it may lead to
    agent status flapping and neutron server not
    communicating with agents

    Change-Id: I65dc90df6ea331de624f50ff5da97c46a881b06a
    Closes-Bug: #1315338

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers