wrong port for swift-api in endpoint-list with radosgw

Bug #1307508 reported by Denis Egorenko on 2014-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Vladimir Kuklin
4.1.x
High
Vladimir Kuklin
5.0.x
High
Vladimir Kuklin

Bug Description

{"build_id": "2014-04-12_22-22-54", "mirantis": "yes", "build_number": "354", "nailgun_sha": "61410bcf3201cd737e68ece8ab15313acc746476", "production": "dev", "ostf_sha": "118c955085ea7829f3a34decd38d63554b74451c", "fuelmain_sha": "1c042c80f6d101800c393b2f626cd9279a8e45b1", "astute_sha": "401bc474b1d8cebb8ba70b3b6154107e08fd725d", "release": "5.0", "fuellib_sha": "101f3645ead182bc47024ff7568b04554de06bba"}

To reproduce:
1) Deploy HA;
2) Ubuntu or Centos;
3) Controller + Cinder LVM + Ceph OSD + Swift API;
4) Nova;

Ceph swift API is not available via public URL:

Service: object-store
+-------------+----------------------------------+
| Property | Value |
+-------------+----------------------------------+
| adminURL | http://192.168.0.1:6780/swift/v1 |
| id | 0b91660358ea4915a63ab729bd373d5d |
| internalURL | http://192.168.0.1:6780/swift/v1 |
| publicURL | http://172.16.0.2:6780/swift/v1 |
| region | RegionOne |
+-------------+----------------------------------+

root@node-8:~# swift list
[Errno 111] Connection refused
root@node-8:~# curl http://172.16.0.2:6780/swift/v1
curl: (7) couldn't connect to host

Update:
The problem is wrong port in endpoint list, should be 8080 instead 6780.

Bogdan Dobrelya (bogdando) wrote :

Maybe related to HAproxy moved to separated namespace

tags: added: ha
Changed in fuel:
status: New → Confirmed
milestone: none → 5.0
assignee: nobody → Fuel Library Team (fuel-library)
importance: Undecided → Critical
description: updated
description: updated
summary: - swift-api is not available
+ wrong port for swift-api in endpoint-list
summary: - wrong port for swift-api in endpoint-list
+ wrong port for swift-api in endpoint-list with radosgw

Fix proposed to branch: master
Review: https://review.openstack.org/87544

Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Vladimir Kuklin (vkuklin)
status: Confirmed → In Progress
tags: added: backports-4.1.1
Changed in fuel:
importance: Critical → High

Reviewed: https://review.openstack.org/87544
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=5b7d15a574bc133fb65814bb6fb3d5cb34bd12b2
Submitter: Jenkins
Branch: master

commit 5b7d15a574bc133fb65814bb6fb3d5cb34bd12b2
Author: Vladimir Kuklin <email address hidden>
Date: Tue Apr 15 15:04:17 2014 +0400

    Fix RGW endpoint port

    Change RGW endpoint port registered in keystone
    to 8080 as this is the real port on which
    haproxy is listening.

    Previously, until https://review.openstack.org/#/c/85195/
    was merged, RGW was working because virtual IP was located
    on one of the controllers and apache proxying RGW fastcgi
    application was answering on 6780 port. Currently, VIP moved
    into namespace and 6780 is no longer available.

    Change-Id: I2ad74b743561d21bb8e522c0648d26d93348657e
    Closes-Bug: #1307508

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/89669
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=13252771b4bb3d3342f3027589d9ba60dd11e3a7
Submitter: Jenkins
Branch: stable/4.1

commit 13252771b4bb3d3342f3027589d9ba60dd11e3a7
Author: Vladimir Kuklin <email address hidden>
Date: Tue Apr 15 15:04:17 2014 +0400

    Fix RGW endpoint port

    Change RGW endpoint port registered in keystone
    to 8080 as this is the real port on which
    haproxy is listening.

    Previously, until https://review.openstack.org/#/c/85195/
    was merged, RGW was working because virtual IP was located
    on one of the controllers and apache proxying RGW fastcgi
    application was answering on 6780 port. Currently, VIP moved
    into namespace and 6780 is no longer available.

    Change-Id: Ib5c20760af7c20a5b2b45fcc899cdc113845ea3f
    Closes-Bug: #1307508

Anastasia Palkina (apalkina) wrote :

Verified on ISO #216
"build_id": "2014-05-22_01-10-31",
"mirantis": "yes",
"build_number": "216",
"ostf_sha": "5c479f04c35127576d35526650ec83b104f9a33d",
"nailgun_sha": "31fcb161ff8d6bfb861b041467440752c0e9c537",
"production": "docker",
"api": "1.0",
"fuelmain_sha": "dda9cff27999e74b80e8e6a9e665e7e9677ab994",
"astute_sha": "9a0d86918724c1153b5f70bdae008dea8572fd3e",
"release": "5.0",
"fuellib_sha": "872b6a7a968b619a493ad46c504910020ea2edae"

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers