fuel-web verify tests overwrite nosetest.xml log

Bug #1304361 reported by Aleksandra Fedorova on 2014-04-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Ihor Kalnytskyi
4.1.x
High
Ihor Kalnytskyi
5.0.x
High
Ihor Kalnytskyi

Bug Description

run_tests.sh scripts runs Nailgun tests and Fuel client tests in separate nosetests processes. Each of them writes the log to the same nosetests.xml file.

Thus we get results only for the Fuel client.

Andrew Woodward (xarses) wrote :

Bumping to High since it creates a lot of pain parsing the results during reviews

Changed in fuel:
status: New → Confirmed
importance: Low → High
milestone: none → 5.0
assignee: nobody → Fuel Python Team (fuel-python)
tags: added: backports-4.1.1

Fix proposed to branch: master
Review: https://review.openstack.org/87550

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Igor Kalnitsky (ikalnitsky)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/87550
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=8185bba4f72c5bee4e2d2cd780d4c917a95507aa
Submitter: Jenkins
Branch: master

commit 8185bba4f72c5bee4e2d2cd780d4c917a95507aa
Author: Igor Kalnitsky <email address hidden>
Date: Tue Apr 15 14:27:02 2014 +0300

    run_tests.sh improvements

    1. Run shotgun's tests

    2. Write XUnit data to separate files

       Since now, the `run_tests.sh` writes XUnit XMLs as separate files.
       Both filenames and paths could be overridden by setuping next env variables:

       * NAILGUN_XUNIT (default: nailgun.xml)
       * FUELCLIENT_XUNIT (default: fuelclient.xml)
       * FUELUPGRADE_XUNIT (default: fuelupgrade.xml)
       * FUELUPGRADEDOWNLOADER_XUNIT (default: fuelupgradedownloader.xml)
       * SHOTGUN_XUNIT (default: shotgun.xml)

       Example:

           NAILGUN_XUNIT="~/reports/nailgun.xml" ./run_tests.sh --with-xunit

    Closes-Bug: #1304361
    Closes-Bug: #1311073

    Change-Id: I60e7733ed4c85e6decb29635d55e3ec8befa8ee1

Changed in fuel:
status: In Progress → Fix Committed
Igor Shishkin (teran) on 2014-05-20
Changed in fuel:
status: Fix Committed → Fix Released
Mike Scherbakov (mihgen) wrote :

Marked as Won't fix for 4.1.1. It affects only how we show results of tests in Jenkins CI. I think we can survive in 4.1.1 without this fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers