There are no logs for Murano (FUEL 4.1.1)

Bug #1298964 reported by Anastasia Kuznetsova on 2014-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Dmitry Teselkin

Bug Description

Environment:
CentOS, Multi-node, VLAN, Murano, 1 controller, 1 compute

Steps to reproduce:
1) Turn on logging for murano-api and murano-conductor in murano-api.conf and murano-conductor.conf
2) Navigate to WebUI
3) Create env with demo service and deploy it

Observed result:
Log files for murano-api and murano-conductor on master node in /var/log/remote/10.20.0.*/murano-*.log

Changed in fuel:
milestone: none → 4.1.1
tags: added: backports-4.1.1
Changed in fuel:
assignee: nobody → Bogdan Dobrelya (bogdando)
importance: Undecided → Low
Bogdan Dobrelya (bogdando) wrote :

Please provide the diagnostic snapshot

Changed in fuel:
status: New → Incomplete

The problem is in redirection logs in syslog.

I made this in murano-api.conf(turn off use_syslog):
# Set up logging. To use syslog just set use_syslog parameter value to 'True'.
log_file = /tmp/murano-api.log
#use_syslog = True
#syslog_log_facility = LOG_LOCAL0
#log_config=/etc/murano/murano-api-logging.conf

After that all work fine and murano-api log file is in /tmp/murano-api.log

Bogdan Dobrelya (bogdando) wrote :

Please elaborate, what is "1) Turn on logging for murano-api and murano-conductor in murano-api.conf and murano-conductor.conf"
Do you use some changes in manifests before to deploy an OS environment?

Bogdan Dobrelya (bogdando) wrote :

In the diagnostic snapshot, there are murano logs present
murano-dashboard-install.log murano-keystoneclient.middleware.auth_token.log
murano-eventlet.wsgi.log murano-muranoapi.api.v1.sessions.log

For now, we have a known issue for OS services provide python qualnames instead of application./service names. And it is a subject of fix for I-3 release and https://blueprints.launchpad.net/fuel/+spec/refactor-logging-puppet-openstack-services as well

Changed in fuel:
status: Incomplete → Invalid

Oh, sorry for misunderstanding.
Here "1) Turn on logging for murano-api and murano-conductor in murano-api.conf and murano-conductor.conf" I meant to set parameter "debug" to True in conf files.

"murano-dashboard-install.log murano-keystoneclient.middleware.auth_token.log
murano-eventlet.wsgi.log murano-muranoapi.api.v1.sessions.log" I saw these log files. But I searched for murano-api.log and murano-conductor.log (These files previously were on controller node in /var/log/remote/10.20.0.*/).

Changed in fuel:
status: Invalid → Confirmed
assignee: Bogdan Dobrelya (bogdando) → nobody
assignee: nobody → Dmitry Teselkin (teselkin-d)
tags: added: murano
description: updated
Changed in fuel:
importance: Low → Medium
Changed in fuel:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers