[provision] Controller has unallocated space, by default, using ceph as image backend

Bug #1295717 reported by Anastasiia Naboikina on 2014-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Valentin Kaplov

Bug Description

Steps to reproduce:
1. Create new cluster with usage of Ceph for Glance.
2. Add nodes with the following roles:
    - 1 controller
    - 1 compute + Ceph
    - 1 Ceph
3. Check that image storage is present in partitions for Controller node, leave partitions by default.
4. Deploy cluster.
5. Go to disc configuration tab of Controller node.

Expected result:
18,432 GB is used for Base Storage on /dev/vda, 32,140 GB is used for image storage;
/dev/vdb and /dev/vdc are fully partitioned for image storage.

Actual result:
The only partitions are present on /dev/vda, which is 18,432 GB for Base Storage, all other space is not recognized;
/dev/vdb and /dev/vdc disc partitions are not recognized.

The following results were gathered on Controller node:
lvm> pvscan
  PV /dev/vda5 VG image lvm2 [31,44 GiB / 128,00 MiB free]
  PV /dev/vdb4 VG image lvm2 [49,44 GiB / 0 free]
  PV /dev/vdc4 VG image lvm2 [49,44 GiB / 0 free]
  PV /dev/vda4 VG os lvm2 [18,03 GiB / 32,00 MiB free]
  Total: 4 [148,34 GiB] / in use: 4 [148,34 GiB] / in no VG: 0 [0 ]

root@node-4 ~]# parted /dev/vda print
Model: Virtio Block Device (virtblk)
Disk /dev/vda: 53,7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 17,4kB 25,2MB 25,1MB primary bios_grub
 2 25,2MB 235MB 210MB primary boot
 3 235MB 445MB 210MB ext2 primary boot
 4 445MB 19,8GB 19,4GB primary lvm
 5 19,8GB 53,6GB 33,8GB primary lvm
[root@node-4 ~]# parted /dev/vdb print
Model: Virtio Block Device (virtblk)
Disk /dev/vdb: 53,7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 17,4kB 25,2MB 25,1MB primary bios_grub
 2 25,2MB 235MB 210MB primary boot
 3 235MB 445MB 210MB ext2 primary boot
 4 445MB 53,5GB 53,1GB primary lvm

[root@node-4 ~]# parted /dev/vdc print
Model: Virtio Block Device (virtblk)
Disk /dev/vdc: 53,7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 17,4kB 25,2MB 25,1MB primary bios_grub
 2 25,2MB 235MB 210MB primary boot
 3 235MB 445MB 210MB ext2 primary boot
 4 445MB 53,5GB 53,1GB primary lvm

Reproduced on:
{"ostf_sha": "31c8316d4d9762f280da9e360d3d42e88464aac1", "fuelmain_sha": "d494e5cf2b8399899f00b5079eec1c5f70c0b66f", "astute_sha": "8b45a579eb64f659791b6f207d7640b5a79f6c52", "release": "5.0", "nailgun_sha": "e3f45ac84c9f21d657c4253a18e7987dbe945b37", "fuellib_sha": "0f2765736a2e4af7265eeb936161f0a90cdc9a2e", "mirantis": "no"}

description: updated

Image Storage partitions on Controller node are displayed as Unallocated Space by default before cluster deployment.

Tatyanka (tatyana-leontovich) wrote :

In case if we use ceph for glance(ceph as separate role) - we create one partition on controllers nodes. But in this case default space allocation is only 18,432 GB is used other space leaves as unallocated. For this case we should allocated all available space for base partiotion

Changed in fuel:
importance: High → Medium
status: New → Confirmed

Also, there is an invalid handling of unallocated space partitions by UI (as is shown on the screenshot attached to the bug).

tags: added: ui

Fix proposed to branch: master
Review: https://review.openstack.org/82283

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Dima Shulyak (dshulyak)
status: Confirmed → In Progress
Dima Shulyak (dshulyak) on 2014-03-22
tags: added: nailgun
removed: library ui

this behaviour repeats not only with ceph as glance backend
for example if we have ceph-osd node for os volume group only minimal size will be allocated, rest will be unused

Dima Shulyak (dshulyak) wrote :
Andrew Woodward (xarses) on 2014-03-24
tags: added: ceph

Reviewed: https://review.openstack.org/82283
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=b79a0947631509f35590e0294555b94a50d4ddeb
Submitter: Jenkins
Branch: master

commit b79a0947631509f35590e0294555b94a50d4ddeb
Author: Dima Shulyak <email address hidden>
Date: Tue Mar 25 14:59:47 2014 +0200

    Allocate all free space to single volume group

    In case we have volume that configured to allocate_size=min
    it wont allocate all free space even if no other groups present on node

    Change-Id: I32fdbae16d6ace271805eaffc7d2e042f9ae2a38
    Closes-bug: #1295717

Changed in fuel:
status: In Progress → Fix Committed
tags: added: inprogress

Verified on ISO #89
"build_id": "2014-04-09_03-54-32",
"mirantis": "yes",
"build_number": "89",
"nailgun_sha": "00b2e1015e50e486f1c7215791724aaefaaf609d",
"ostf_sha": "17f2fe6e56452f8e2f01a385be4c4b87bf3698a8",
"fuelmain_sha": "97b539a540a4f15899de661d614edfda47767ab6",
"astute_sha": "35473eb08b16f4778283e993126a4fd15eb1d00f",
"release": "5.0",
"fuellib_sha": "9056ddfb1047c0384d2f03d7b7d32ba8cb4c54d8"

tags: removed: inprogress
Changed in fuel:
status: Fix Committed → Fix Released

reproduced on {"build_id": "2014-05-13_12-25-26", "mirantis": "yes", "build_number": "199", "ostf_sha": "bff980b2277a5898266500a26224a03bad594612", "nailgun_sha": "192b32e5ebd78b8521ced8329c07665dd75f5948", "production": "docker", "api": "1.0", "fuelmain_sha": "ac5500c45b1b05a72caadc0c7ef36c4279e4b36d", "astute_sha": "1b97b4d8832c12a1000235175b960e0102c23ca5", "release": "5.0", "fuellib_sha": "027751fc9c9806c9eb38683baf8bc1faced85de4"}

Changed in fuel:
status: Fix Released → Confirmed
Mike Scherbakov (mihgen) on 2014-05-16
no longer affects: fuel/5.x
no longer affects: fuel/4.x
no longer affects: fuel/4.x
no longer affects: fuel/5.x
no longer affects: fuel/4.x
no longer affects: fuel/5.x
Dima Shulyak (dshulyak) wrote :

Fix was reverted because of cobbler or debian-installer limitations:

# File "/usr/lib/python2.6/site-packages/cobbler/pmanager.py", line 537, in validate
# raise Exception("OS volume group must be located on one disk")

For more info see https://bugs.launchpad.net/fuel/+bug/1306625

It will be addressed with general volume manager refactoring, to prevent low quality hacks

Mike Scherbakov (mihgen) on 2014-05-16
Changed in fuel:
milestone: 5.0 → 5.1
assignee: Dima Shulyak (dshulyak) → Fuel Python Team (fuel-python)
importance: Medium → High
Dmitry Ilyin (idv1985) wrote :

ISO: 206

Deployed successfully with dedicated Ceph nodes. Ceph partitions are created and formated normally.

Dima Shulyak (dshulyak) on 2014-06-19
tags: added: volumes
Dima Shulyak (dshulyak) on 2014-06-23
summary: - Image storage allocation fails when using Ceph as Glance
+ Controller has unallocated space, by default, using ceph as image
+ backend
Dmitry Pyzhov (dpyzhov) on 2014-07-15
no longer affects: fuel/5.1.x
Dmitry Ilyin (idv1985) on 2014-07-15
summary: - Controller has unallocated space, by default, using ceph as image
- backend
+ [provision] Controller has unallocated space, by default, using ceph as
+ image backend
Dmitry Pyzhov (dpyzhov) wrote :
Changed in fuel:
milestone: 5.1 → 6.0
status: Confirmed → Won't Fix
Mike Scherbakov (mihgen) on 2014-08-21
Changed in fuel:
status: Won't Fix → Confirmed
Dima Shulyak (dshulyak) wrote :

This can not be fixed with native installers, os partition on ubuntu can not be allocated on more than 1 disk

Dmitry Pyzhov (dpyzhov) on 2014-11-18
Changed in fuel:
milestone: 6.0 → 6.1
Dmitry Pyzhov (dpyzhov) on 2015-02-17
Changed in fuel:
milestone: 6.1 → 7.0
Dmitry Pyzhov (dpyzhov) on 2015-03-30
tags: added: module-volumes
removed: nailgun volumes
no longer affects: fuel
Dmitry Pyzhov (dpyzhov) wrote :

We need to add to release notes that Ubuntu can be installed only on first disk.

Changed in fuel:
milestone: none → 7.0
tags: added: release-notes
Dmitry Pyzhov (dpyzhov) on 2015-04-21
Changed in fuel:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Fuel Python Team (fuel-python)
tags: added: qa-agree-7.0
Dmitry Pyzhov (dpyzhov) on 2015-08-05
no longer affects: fuel/6.1.x
no longer affects: fuel/7.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Changed in fuel:
milestone: 8.0 → 9.0

We passed SCF in 8.0. Moving the bug to 9.0.

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Valentin Kaplov (vkaplov)
Changed in fuel:
assignee: Valentin Kaplov (vkaplov) → Fuel Python Team (fuel-python)
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Valentin Kaplov (vkaplov)
Valentin Kaplov (vkaplov) wrote :

Created environment with next configuration:
    - 1 controller + Ceph
    - 1 compute + Ceph
    - 1 Ceph

Deploy cluster.
Check disk configuration of controller:

# df -h
Filesystem Size Used Avail Use% Mounted on
udev 990M 12K 990M 1% /dev
tmpfs 201M 26M 175M 13% /run
/dev/dm-3 15G 2.5G 12G 18% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 1001M 60M 942M 6% /run/shm
none 100M 0 100M 0% /run/user
/dev/sda3 196M 39M 148M 21% /boot
/dev/mapper/logs-log 9.8G 75M 9.2G 1% /var/log
/dev/mapper/mysql-root 20G 466M 19G 3% /var/lib/mysql
/dev/mapper/horizon-horizontmp 11G 33M 11G 1% /var/lib/horizon
/dev/sdb3 64G 2.1G 62G 4% /var/lib/ceph/osd/ceph-0
/dev/sdc3 64G 2.1G 62G 4% /var/lib/ceph/osd/ceph-1

# parted /dev/sda print
Model: ATA VBOX HARDDISK (scsi)
Disk /dev/sda: 68.7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 26.2MB 25.2MB primary bios_grub
 2 26.2MB 236MB 210MB primary
 3 236MB 446MB 210MB ext2 primary
 4 446MB 20.8GB 20.3GB primary
 5 20.8GB 31.6GB 10.8GB primary
 6 31.6GB 53.1GB 21.5GB primary
 7 53.1GB 65.0GB 11.9GB primary
 8 65.0GB 65.0GB 21.0MB primary

# parted /dev/sdb print
Model: ATA VBOX HARDDISK (scsi)
Disk /dev/sdb: 68.7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 26.2MB 25.2MB primary bios_grub
 2 26.2MB 236MB 210MB primary
 3 236MB 68.2GB 67.9GB xfs primary

# parted /dev/sdb print
Model: ATA VBOX HARDDISK (scsi)
Disk /dev/sdb: 68.7GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 26.2MB 25.2MB primary bios_grub
 2 26.2MB 236MB 210MB primary
 3 236MB 68.2GB 67.9GB xfs primary

Looks like everything ok now. Bug not reproducing anymore on version: 8.0 build 457

Changed in fuel:
status: Confirmed → Invalid
Dmitry Pyzhov (dpyzhov) wrote :

The bug disappeared in 8.0 release and there is no need to highlight it in 9.0 release notes.

tags: removed: release-notes
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints