ssh public key not getting provisioned

Bug #1294792 reported by Gil McGrath on 2014-03-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Undecided
Unassigned

Bug Description

I am entering a public in the Fuel 4.1 GUI under the "settings" tab.
After the openstack servers are provisioned the public key is not included in /root/.ssh/authorized_keys.

The openstack servers are ubuntu 12.04.

tags: added: customer-found
Miroslav Anashkin (manashkin) wrote :

Greetings Gil,

I have tried to reproduce this issue and it didn't appeared on my machines.
All the nodes got my key added to /root/.ssh/authorized_keys successfully.

Please explain several following details:

How did you added the key - as path to the key file or did copy-paste of key contents?

How many keys - single or several - you did added at one time?

Have you ever opened Fuel UI of the previous version on this machine? If yes - please try to press Shift+Reload button of your web browser. And then please try to reproduce this issue one more time.
Sometimes I have strange issues after switching between the different Fuel versions and full page reload with cleanup helps.

Kind regards,
Miroslav

Gil McGrath (gmcgrath) wrote :

Ok - I redeployed the cluster - it worked on re-deployment.

Andrew Woodward (xarses) on 2014-03-22
Changed in fuel:
status: New → Won't Fix
Dmitry Pyzhov (dpyzhov) on 2014-08-13
Changed in fuel:
milestone: none → 4.1.1
Dmitry Pyzhov (dpyzhov) on 2014-08-14
Changed in fuel:
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers