[provision] UEFI support

Bug #1291128 reported by Vladimir Kozhukalov
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Invalid
Low
Vladimir Kozhukalov

Bug Description

At the moment master node as well as slave nodes do not support UEFI booting. However, some hardware even it is able to emulate legacy BIOS seems not to work well with legacy grub 0.97. So, we have to support UEFI booting.

Changed in fuel:
assignee: nobody → Vladimir Kozhukalov (kozhukalov)
status: New → Triaged
Revision history for this message
Vladimir Kozhukalov (kozhukalov) wrote :

Some additional information.

Hardware where the problem with UEFI appeared is Lenovo W520 laptop. W520 UEFI chip seems not to be able to emulate legacy BIOS correctly. It is not possible to boot from GPT bios_grub partition directry. However, it works pretty well for msdos partition table.

Another interesting point here is that only master node is not able to boot from GPT bios_grub partition because it is the only case when UEFI tries to boot directly from a disk. The problem is not actual (of course in a sense) for slave nodes because they do not boot from hard drive directly, but instead they try to boot from PXE rom and then chain32 loader tries to boot from hard drive. That is awesome because we added chain32 loader in our booting flow long time ago in order to solve completely another problem.

Changed in fuel:
milestone: none → 5.0
Revision history for this message
Andrey Korolyov (xdeller) wrote :

I`ve built grub-2 for Centos for some previous releases especially for Services team and you may use it instead. UEFI is very painful to work with and I am not recommending all of you to dive into in without an extreme need.

http://download.mirantis.com/epel-fuel-grizzly-3.2/SRPMS/grub2-1.98-3.el6.src.rpm

Changed in fuel:
importance: Undecided → Medium
Changed in fuel:
milestone: 5.0 → 5.1
Mike Scherbakov (mihgen)
tags: added: release-notes
Revision history for this message
Meg McRoberts (dreidellhasa) wrote :

Listed as "Known Issue" in 5.0 Release Notes.

Revision history for this message
Meg McRoberts (dreidellhasa) wrote :

Listed as "Known Issue" in 5.0.1 Release Notes.

Dmitry Ilyin (idv1985)
summary: - UEFI support
+ [provision] UEFI support
Revision history for this message
Dmitry Pyzhov (dpyzhov) wrote :
Changed in fuel:
importance: Medium → Low
status: Triaged → Won't Fix
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints