Min level filter changes from ERROR to INFO for orchestrator logs

Bug #1286110 reported by Anastasia Palkina on 2014-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Low
Kyrylo Galanov
7.0.x
Low
Fuel UI Team

Bug Description

"build_id": "2014-02-28_01-17-30",
"mirantis": "yes",
"build_number": "225",
"nailgun_sha": "12a7e7a99557f2bc302f0806ad3beef02e94b974",
"ostf_sha": "ceb3ea8c2c0da27306b30b9936f27dbc5044d2c6",
"fuelmain_sha": "ba019bf15a9597a154e7c1d6ecc840614d21414c",
"astute_sha": "f15f5615249c59c826ea05d26707f062c88db32a",
"release": "4.1",
"fuellib_sha": "61d3a150402da3ce1160836c8d659f6d9d1f9640"

1. Create new environment (CentOS, simple)
2. Choose VLAN segmentation
3. Add controller, compute
4. Start deployment.
5. After deployment move to tab 'Logs'
6. Choose 'Fuel Master' logs, source 'Web backend', min level 'ERROR'
7. Choose source 'REST API'. Min level stay 'ERROR'
8. Choose source 'Orchestrator'. Min level became 'INFO'

Mike Scherbakov (mihgen) on 2014-02-28
Changed in fuel:
milestone: 4.1 → 5.0
Evgeniy L (rustyrobot) on 2014-03-03
Changed in fuel:
importance: Undecided → Medium
status: New → Confirmed
Julia Aranovich (jkirnosova) wrote :

According to step 8 you expect ERROR level displayed for Orchestrator log source.
But this source doesn't have 'ERROR' in it's level list, so the first level from the list ('INFO') is displayed.
At the same time 'ERR' level is presented in Orchestrator level list.

Should log levels list be unified for each source? Should it be done on backend or UI?

Changed in fuel:
status: Confirmed → Opinion
assignee: Fuel UI Team (fuel-ui) → nobody
Mike Scherbakov (mihgen) on 2014-05-29
Changed in fuel:
milestone: 5.0 → 5.1
tags: added: astute
tags: added: ui
Changed in fuel:
status: Opinion → Confirmed
importance: Medium → Low
milestone: 5.1 → 6.0
assignee: nobody → Fuel Library Team (fuel-library)
Changed in fuel:
milestone: 6.0 → 6.1
Changed in fuel:
milestone: 6.1 → 7.0
milestone: 7.0 → 6.1
status: Confirmed → Won't Fix
Stanislaw Bogatkin (sbogatkin) wrote :

It seems for me that all default levels should be consistent and 'INFO'.

Vitaly Kramskikh (vkramskikh) wrote :

That happens because there are 2 different severity for different log types: ERROR and ERR. Unification will fix it. Thus, returning back to fuel-library

Matthew Mosesohn (raytrac3r) wrote :

It's not clear what Fuel Library should do here. Which log levels for which source logs have the wrong severity? How is fuel-master logging related to the default values for UI logs tab?

Vitaly Kramskikh (vkramskikh) wrote :

Matthew: please read by previous comment. UI only tries to preserve log level when switching to another log only if the current log level also exists for that log. ERROR and ERR are different log levels, so UI falls back to default. Fuel-library should unify log levels across the logs here

Dmitry Pyzhov (dpyzhov) on 2015-10-12
Changed in fuel:
milestone: 6.1 → 8.0
status: Won't Fix → Confirmed
no longer affects: fuel/8.0.x
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-library
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Kyrylo Galanov (kgalanov)

Fix proposed to branch: master
Review: https://review.openstack.org/246423

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/246423
Committed: https://git.openstack.org/cgit/openstack/fuel-astute/commit/?id=bae9c5f2ab7c9abd101718479285da52740eec02
Submitter: Jenkins
Branch: master

commit bae9c5f2ab7c9abd101718479285da52740eec02
Author: Kyrylo Galanov <email address hidden>
Date: Tue Nov 17 16:34:59 2015 +0200

    Set logging level same as other fuel services

    Astute was the only fuel service using short ERR and CRIT log levels,
    it led to unconvinient log viewing using the WebUI.

    Change-Id: I3dd8e7d80030f6a16d910ee28950102b31765af5
    Closes-bug: #1286110

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/246438
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=20bd7c0dfa0bc7e62b42869bc8fa9d6fc0b29fa3
Submitter: Jenkins
Branch: master

commit 20bd7c0dfa0bc7e62b42869bc8fa9d6fc0b29fa3
Author: Kyrylo Galanov <email address hidden>
Date: Tue Nov 17 17:04:07 2015 +0200

    Set astute log format equal to other Fuel services

    Depends-On: I3dd8e7d80030f6a16d910ee28950102b31765af5
    Change-Id: I3e34fc0e788f1d3761c9b1e4f9d553d0ceef489f
    Partial-Bug: #1286110

Anastasia Palkina (apalkina) wrote :

Verified on ISO #212

VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  openstack_version: "2015.1.0-8.0"
  api: "1.0"
  build_number: "212"
  build_id: "212"
  fuel-nailgun_sha: "13d1800be2452bd297555eedf051bda469b5663b"
  python-fuelclient_sha: "4f9a873b1ae68271bb848a1145b3cf912a176f4b"
  fuel-agent_sha: "f0e09fa7a30b5ab87e901601bfb6c1e339a6bdaa"
  fuel-nailgun-agent_sha: "b56f832abc18aee9a8c603fd6cc2055c5f4287bc"
  astute_sha: "d2c1b401816c6f0341902272f37018b9cec3c775"
  fuel-library_sha: "c892d2919620947225687ccde63d0e038784f0a2"
  fuel-ostf_sha: "5cf8c484a9a4f45f353468438cf98f1b5a5c5dfb"
  fuel-createmirror_sha: "9b335c8d551c87d788166947cb7ed519757881e8"
  fuelmenu_sha: "9627849843e84b7f01c44bd79898a8d62d96ce66"
  shotgun_sha: "34a081508b603723e14f9415a62373be39f3685f"
  network-checker_sha: "2c62cd52655ea6456ff6294fd63f18d6ea54fe38"
  fuel-upgrade_sha: "1e894e26d4e1423a9b0d66abd6a79505f4175ff6"
  fuelmain_sha: "daed38102b6074393821d675e3d7d866fcdb3da5"

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers