Improper behavior for reset environment

Bug #1286024 reported by Nastya Urlapova on 2014-02-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Nikolay Markov

Bug Description

iso #225

Deploy simple cluster:
1xController
1xCompute

After successful deploy push "Reset environment".
Add some new option for cluster and add one compute node for example.

Old stuff have discovered status and possible to deploy changes.

Tags: ui Edit Tag help
Nastya Urlapova (aurlapova) wrote :
Changed in fuel:
milestone: none → 4.1
Nastya Urlapova (aurlapova) wrote :
Changed in fuel:
assignee: nobody → Vladimir Sharshov (vsharshov)
importance: High → Critical
Nastya Urlapova (aurlapova) wrote :
Changed in fuel:
importance: Critical → High
Evgeniy L (rustyrobot) wrote :

We have here several problems

1. dissipated node, somehow this node was assigned to another cluster (see nailgun/api.log)

2. deployment wasn't started on nodes which were reseted, it looks like deploy button was pressed before nodes was moved to discovery state

Changed in fuel:
status: New → Confirmed
Vladimir Sharshov (vsharshov) wrote :

Could not reproduce. Try twice: 1 - add new node after succeed reset env and nodes back to online, 2 - add nodes after succeed and nodes was offline. In both case deploy succeed.

Evgeniy L (rustyrobot) wrote :

1. we assume that first problem was occured because system tests assigned this node to another cluster

2. problem 2 is in nailgun, in case of inaccessible nodes nailgun doesn't update their statuses

2014-02-28 08:27:16.895 INFO [7fe5d6683700] (receiver) RPC method reset_environment_resp received: {"status": "ready", "progress": 100, "task_uuid": "fe837ea6-4123-4bf1-8bba-2f64611b44a0", "inaccessible_nodes": [{"uid": "6", "error": "Node not answered by RPC."}, {"uid": "7", "error": "Node not answered by RPC."}], "nodes": []}

https://github.com/stackforge/fuel-web/blob/master/nailgun/nailgun/rpc/receiver.py#L528-L533

Changed in fuel:
status: Confirmed → Triaged
assignee: Vladimir Sharshov (vsharshov) → Fuel Python Team (fuel-python)
milestone: 4.1 → 5.0
milestone: 5.0 → 4.1.1
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Nikolay Markov (nmarkov)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/77584
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=507f5085e53f7210b810b238a844efa3fb40f633
Submitter: Jenkins
Branch: master

commit 507f5085e53f7210b810b238a844efa3fb40f633
Author: Nikolay Markov <email address hidden>
Date: Mon Mar 3 17:09:12 2014 +0400

    Inaccessible nodes are also updated on stop/reset

    Closes-Bug: #1286024

    Change-Id: Ic7bcb3d71cebfb0c6d10f02490fa32dc5d4ef909

Changed in fuel:
status: In Progress → Fix Committed
tags: added: in progress

Verified on iso 235.

Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: in progress
Vladimir Kuklin (vkuklin) wrote :

should be backported to stable/4.1

Changed in fuel:
status: Fix Released → In Progress

Reviewed: https://review.openstack.org/84137
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=a2ae66f22dd7fff9cb4cfaae87aca4e6c7aad331
Submitter: Jenkins
Branch: stable/4.1

commit a2ae66f22dd7fff9cb4cfaae87aca4e6c7aad331
Author: Nikolay Markov <email address hidden>
Date: Mon Mar 3 17:09:12 2014 +0400

    Inaccessible nodes are also updated on stop/reset

    Closes-Bug: #1286024

    Change-Id: Ic7bcb3d71cebfb0c6d10f02490fa32dc5d4ef909

Dmitry Pyzhov (dpyzhov) on 2014-04-03
Changed in fuel:
status: In Progress → Fix Committed

verified on {"build_id": "2014-04-03_04-17-26", "mirantis": "yes", "build_number": "266", "nailgun_sha": "7a05e365240ab27c492b20585ef8ac8557102cc0", "ostf_sha": "de0222fed646525d248dc6892eeceab139d5c469", "fuelmain_sha": "16637e2ea0ae6fe9a773aceb9d76c6e3a75f6c3b", "astute_sha": "5bcacc84cdaee3b31f1178d92a1c0681dc6ce520", "release": "4.1", "fuellib_sha": "52e7f57695f33bafa5d84d524d77f1bc3a2289b2"}

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers