Relogin in horizon doesn't work

Bug #1284241 reported by Andrew Lazarev on 2014-02-24
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Miroslav Anashkin

Bug Description

Steps to repro:

1. Login to horizon
2. Wait session timeout
3. click something

Expected behavior: login screen

Observed behavior:
404 Not Found

The requested URL /auth/logout/ was not found on this server.

Removing "/auth/logout" from browser URL fixes the issue.

Image: fuel-4.1.ceph.20140212.1345-centos-6.4-x86_64.iso

[root@nailgun ~]# cat /etc/nailgun/version.yaml
VERSION:
  mirantis: "no"
  release: "4.1"
  fuellib_sha: "8ebe363bca2a25b443d57d171f96b5cacccf9cc4"
  astute_sha: "7eed50fc30cec675fff7787c37fcf6da6dd518ee"
  ostf_sha: "f86abe5544b5ffcf621e0c450bca15737c92361f"
  nailgun_sha: "d6cfe157704feeaa53b3f2ea2d0816147d686270"
  fuelmain_sha: "7ff45b21abdb78a3d601356711c753fa37f457e2"

Andrew Woodward (xarses) wrote :

Adding customer found since I've seen this with several people.

I think this is a horizon problem but we should still see if there is anything we can do.

tags: added: customer-found
Changed in fuel:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 5.0
Changed in fuel:
assignee: nobody → Fuel Library Team (fuel-library)
Dmitry Pyzhov (dpyzhov) wrote :

We miss LOGOUT_URL in ubuntu patch. I believe centos is fine.

Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Roman Vyalov (r0mikiam)
status: Confirmed → Triaged
Roman Vyalov (r0mikiam) on 2014-02-25
Changed in fuel:
assignee: Roman Vyalov (r0mikiam) → Fuel OSCI Team (fuel-osci)
Dmitry Pyzhov (dpyzhov) wrote :

LOGOUT_URL='/horizon/auth/logout/'
Missed line should be added to debian/patches/ubuntu_settings.patch next to LOGIN_URL

Matthew Mosesohn (raytrac3r) wrote :

https://bugs.launchpad.net/fuel/+bug/1286089 may be a duplicate, but it is already marked as a duplicate of https://bugs.launchpad.net/bugs/1285449

Fix proposed to branch: master
Review: https://review.openstack.org/83174

Changed in fuel:
assignee: Fuel OSCI Team (fuel-osci) → Miroslav Anashkin (manashkin)
status: Triaged → In Progress

Reviewed: https://review.openstack.org/83174
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=7fae036f384eb5b8c20a3c882822f7496b708a94
Submitter: Jenkins
Branch: master

commit 7fae036f384eb5b8c20a3c882822f7496b708a94
Author: Miroslav Anashkin <email address hidden>
Date: Wed Mar 26 23:01:11 2014 +0400

    Fixed Relogin in horizon doesn't work

    Added missing LOGOUT_URL to local_settings.py template

    Change-Id: I1378dab60247246fed24873b0d04430429d3d079
    Partial-Bug: #1284241

Changed in fuel:
status: In Progress → Fix Committed
milestone: 5.0 → 4.1.1
tags: added: backports-4.1.1
Changed in fuel:
status: Fix Committed → Triaged

Reviewed: https://review.openstack.org/89621
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=e0ad861ce7702fb76b49600a103d4bbd0b3419ca
Submitter: Jenkins
Branch: stable/4.1

commit e0ad861ce7702fb76b49600a103d4bbd0b3419ca
Author: Miroslav Anashkin <email address hidden>
Date: Wed Mar 26 23:01:11 2014 +0400

    Fixed Relogin in horizon doesn't work

    Added missing LOGOUT_URL to local_settings.py template

    Change-Id: I1378dab60247246fed24873b0d04430429d3d079
    Partial-Bug: #1284241

Changed in fuel:
status: Triaged → Fix Committed

verified on {

    "build_id": "2014-06-04_09-16-08",
    "mirantis": "yes",
    "build_number": "341",
    "nailgun_sha": "a828d6b7610f872980d5a2113774f1cda6f6810b",
    "ostf_sha": "c959aa55f83fe2555cf2d382559271c7a9b17467",
    "fuelmain_sha": "7ed0f85acc0bab4b9157703a618b8cc9fd7de3e1",
    "astute_sha": "55df06b2e84fa5d71a1cc0e78dbccab5db29d968",
    "release": "4.1B",
    "fuellib_sha": "0e96fc5a340cd57f75c454ea8536471379299494"

}

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers