Wrong data in hiera murano hash

Bug #1598177 reported by Denis Egorenko on 2016-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fuel-plugin-murano
High
Denis Egorenko

Bug Description

After downscale operations in cluster, murano hash has wrong data during puppet run.

For example, deploy cluster with 3 controllers and then destroy 2 of them. There are no any updates
in murano_haproxy task, because hiera returns old node information.

This is because base fuel task globals has same base hash name for murano. After second run it will
use old plugin data with old information. Then, after updating plugin.yaml with correct info,
on each puppet run will be returned wrong information, because information from globals.yaml and plugins.yaml will be merged into one hash (because of default hiera hash strategy).

Changed in fuel-plugin-murano:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Denis Egorenko (degorenko)
Denis Egorenko (degorenko) wrote :
Changed in fuel-plugin-murano:
status: Confirmed → In Progress
Changed in fuel-plugin-murano:
status: In Progress → Fix Committed
Changed in fuel-plugin-murano:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers