GTK icon cache fails to update

Bug #1092727 reported by Aditya V on 2012-12-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
FS Icons Ubuntu
High
Unassigned

Bug Description

When installing FS Icons Ubuntu from the daily PPA in the command line, this was the output:

Setting up fs-icons-ubuntu (0.5.2-0~ppa4+r199+pkg39+1~precise1) ...
gtk-update-icon-cache-3.0: The generated cache was invalid.
WARNING: icon cache generation failed for /usr/share/icons/fs-icons-ubuntu
Setting up fs-icons-ubuntu-mono-dark (0.5.2-0~ppa4+r199+pkg39+1~precise1) ...
gtk-update-icon-cache-3.0: The generated cache was invalid.
WARNING: icon cache generation failed for /usr/share/icons/fs-icons-ubuntu-mono-dark
Setting up fs-icons-ubuntu-megypt-mono-dark (0.5.2-0~ppa4+r199+pkg39+1~precise1) ...
Setting up fs-icons-ubuntu-megypt (0.5.2-0~ppa4+r199+pkg39+1~precise1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

The problem here is the "gtk-update-icon-cache-3.0: The generated cache was invalid.". According to bug 741387 (https://bugs.launchpad.net/ubuntu/+source/ubuntu-mono/+bug/741387), the problem could be something to do with symlinks.

Aditya V (kroq-gar78) on 2012-12-23
Changed in fs-icons-ubuntu:
status: New → Triaged
Revision history for this message
Khairul Aizat Kamarudzzaman (fenris) wrote :

(gtk-update-icon-cache:32540): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

(gtk-update-icon-cache-3.0:32541): GdkPixbuf-WARNING **: Cannot open pixbuf loader module file '/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

error occur when upgrading from quantal to raring

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers