Fonts not rendered correctly in OOo - Times New Roman looks bold above 13pt

Bug #256058 reported by flar on 2008-08-08
6
Affects Status Importance Assigned to Milestone
FreeType
New
Undecided
Unassigned
freetype (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

I just installed Hardy and the fonts in documents look terrible in OpenOffice. Specifically I'm using Times New Roman. I have msttcorefonts installed and all other apps are fine. The letters look unevenly spaced and different font sizes look like completely different fonts.

I have attached screenshots from Gutsy and Hardy to show the difference. Notice how in Gutsy everything was uniform, and all the letters can be seen clearly. In Hardy, the letters run together and the 11 point font in the quotation looks much different than the 12 point font used in the rest of the text. The text on Hardy looks cheap and amateur.

I installed upstream version of OpenOffice for comparison and these problems are not evident. So the problem seems to be the result of an Ubuntu patch to OpenOffice. Why change this? Font rendering in OpenOffice was perfectly fine in Gutsy. This is a show stopper for me because I use this computer for work, and these fonts make it difficult to read.

flar (asegaert) wrote :
Parthan SR (parth-technofreak) wrote :

For me the font themselves looks a bit different. Can you confirm that both the fonts are same?

flar (asegaert) wrote :

They are both Times New Roman.

 I have the same results on my laptop and desktop computers as well. I have run Ubuntu on my desktop since Warty and this has never been an issue until Hardy.

guidol (monk-e) wrote :

Confirmed on Hardy 8.04.1

Changed in openoffice.org:
status: New → Confirmed
flar (asegaert) wrote :

Any movement on this? I think it's quite serious--surely there must be people who use openoffice on ubuntu for serious work?

glass.dimly (jmjohn) wrote :

I have this same problem-- this has to be some sort of priority, as I'm sure that many people need these fonts.

Attached it a screenshot of Garamond looking terrible.

flar (asegaert) wrote :

Surely this must be considered a serious bug. The flagship open source word processor doesn't work properly on Hardy. This precludes the use of Hardy for any kind of office use or serious work, or at least makes Ubuntu look inferior to anyone who attempts to use it.

flibble (flibble-fastmail) wrote :

I have the same issue with Openoffice 2.4, Hardy 8.4.0.1, on a thinkpad T60 and three workstations based on various asus M2N boards (nvidia geforce4, nforce 430 chipset drivers).

Some help with this would be great. These workstations are not usable for academic work with fonts like this, and I'm trying to convince the head of school to trial Ubuntu in one of our labs.

For test purposes, I installed both openSUSE 11.0 (gnome) and Fedora 9.0 on all four of these test machines and the problem does not occur on any of them, only Ubuntu Hardy 8.04.

Are freetype or other libraries modified for Ubuntu? Could one of them have the bug?

Chris Cheney (ccheney) wrote :

I think this is an issue with freetype, at least the part with respect as the font size increases it jumps in darkness quite a bit somewhere between 10-15 point, it seems to vary depending on font when this happens.

Changed in openoffice.org:
status: Confirmed → New
flar (asegaert) wrote :

Chris Cheney wrote:
"I think this is an issue with freetype, at least the part with respect as the font size increases it jumps in darkness quite a bit somewhere between 10-15 point, it seems to vary depending on font when this happens."

If it is a problem with freetype, then why do the fonts look fine in the version of OpenOffice downloaded from OpenOffice.org?
The original version of OpenOffice works, the Ubuntu-modified version does not. That suggests that Ubuntu modified something in OpenOffice to make it not work.

Chris Cheney (ccheney) on 2009-01-21
Changed in openoffice.org:
importance: Undecided → Low
status: New → Triaged
Changed in freetype:
status: New → Invalid
Changed in freetype:
status: Unknown → Confirmed

This bug does appear to be in freetype since Novell testers were able to reproduce the issue in other applications as well as upstream OOo and the ooo-build version of OOo.

https://bugzilla.novell.com/show_bug.cgi?id=467844

Changed in freetype:
importance: Unknown → Undecided
status: Confirmed → New
status: Invalid → New
Chris Cheney (ccheney) wrote :

I have attached a screenshot showing both upstream and Ubuntu versions exhibiting this bug. Novell has also claimed this bug affects other applications besides OOo so is most probably a freetype bug.

Thanks,

Chris Cheney

Changed in freetype:
importance: Undecided → Medium
status: New → Confirmed
Chris Cheney (ccheney) on 2009-02-04
Changed in freetype:
milestone: none → ubuntu-9.04-beta
Martin Pitt (pitti) wrote :

Not a regression, thus it shouldn't block the 9.04 beta release.

Changed in freetype:
milestone: ubuntu-9.04-beta → none
Chris Cheney (ccheney) wrote :

This doesn't actually appear to be an OOo bug but rather a freetype issue of some sort.

Changed in openoffice.org (Ubuntu):
importance: Low → Undecided
status: Triaged → Invalid
gfx (oce) wrote :

Subpixel aliasing in openoffice behaves different from the system default (in xubuntu)
When using hinting: full (rgb) openoffice apps look all-right. The desktop looks better when hinting is set to slight

Chris Cheney (ccheney) wrote :

gfx,

That is a different bug that is already covered by bug 271283

Arnaud Renevier (arenevier) wrote :

Many fonts (at least truetype fonts), when rendered with freetype, have a point with a big thickness increase. For times new roman, that point is between 13pt and 14pt.

This behaviour only happens when hinting is activated. When a glyph is loaded in freetype without hinting (ie: with flag FT_LOAD_NO_HINTING), thickness increase is more smooth.

When hinting is activated for a truetype font, the font manages its hinting itself with some special instructions. So, I'm not sure if problem lies in freetype, in the way it's called by openoffice, or in the times new roman font file itself.

As a demonstration, here is an webpage using times new roman at 13pt and 14pt:
http://renevier.net/misc/font.html
The thickness increase also happens on windows with firefox, safari, and ie6 (but not with ie>=7)

Adolfo Jayme (fitojb) wrote :

I agree with Arnaud, this is a detail in the font itself that can be seen in Windows as well, in Ubuntu does not happen by default anymore since it uses "slight" hinting.

no longer affects: openoffice.org (Ubuntu)
Changed in freetype (Ubuntu):
importance: Medium → Low
status: Confirmed → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.