Could not find shadowed session

Bug #654899 reported by Dept.Técnico (Extreme Micro S.L.) on 2010-10-04
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
FreeNX Server
Undecided
Unassigned

Bug Description

nxserver from lucid amd64 fail to shadow a session with the following error:

NX> 596 Could not find shadowed session CE90CDE2BA9CBB1A33058D733FFDDD09. Session failed.

Versión: 0.7.3.git100327.e224628-0~ppa7~lucid

Further investigation revealed that previous hardy packages work in my ubuntu lucid... so freenx debs:

freenx-server_0.7.3+teambzr104-0freenxteam1~hardy1_amd64.deb 06-Apr-2009 15:21 106K
freenx-rdp_0.7.3+teambzr104-0freenxteam1~hardy1_all.deb 06-Apr-2009 15:21 20K
freenx-session-launcher_0.7.3+teambzr104-0freenxteam1~hardy1_amd64.deb 06-Apr-2009 15:21 24K
freenx-vnc_0.7.3+teambzr104-0freenxteam1~hardy1_all.deb 06-Apr-2009 15:21 20K
freenx_0.7.3+teambzr104-0freenxteam1~hardy1_all.deb 06-Apr-2009 15:21 20K

downloaded from http://ppa.launchpad.net/freenx-team/ubuntu/pool/main/f/freenx-server/?C=M;O=A
have shadowing feature working. Anyway, I must mention that nomachine client continue to show me faulty info when listing sessions. I don't know if it's normal or not... i'm using other NX servers from nomachine and show me correct session names, etc.

To anyone with problems shadowing sessions in ubuntu lucid with this error in log:
NX> 596 Could not find shadowed session 3930B2635E8257321B86F641BDA27779. Session failed.
Try to install previous mentioned packages to solve the problem by now.

Jeremy Wilkins (wjeremy) wrote :

This is a known issue and it is likely your bug is related to bug #589723. I will be fixed session shadowing soon with a repatched nxserver and nxnode that resembles the old packages. Many of the good bug fixes that existed in the old packages have been removed from this newer version because it is a cleaner package from the original FreeNX git repository. Many of the changes that existed on the ones in the bazaar repo are not there, so I am going to pull the patches from the bazaar repository and apply them to the current git tree as best as possible and any patches that were applied already will be excluded.

Andy Jackson (snadrus) wrote :

I'm using the Lucid package in AMD64 Maverick with NoMachine Client on the same box. I get 2 possible entries to resume, then this error.

noobish (noobish) wrote :

I still get this behavior in Natty 64 using lucid package 0.7.3.git110520.3884279-0ubuntu1ppa4 (as recommended on the ubuntu howto).

Changing group of /var/lib/nxserver/db/running to nx on the server does not help. It also lists two sessions both called X0 as snadrus is seeing.

apavlov (apavlov) wrote :

Observing the same erroneous behavior as specified by noobish on Ubuntu 12.04 LTS (Precise Pangolin). Is there any way to work this around? Changing group of /var/lib/nxserver/db/running to nx on the server does not help either.

I also get "Could not find shadowed session 919DC46021301D9B01489AAB2BA11B80. Session failed." and two local sessions instead of one in the session list.

wayneg (wg-sfnet) wrote :

Running Ubuntu 12.04 with the same problem as noobish. To possible (nameless) sessions to resume.

NX> 596 Could not find shadowed session 3B6DE5229B9569BCF9000A06DF181FBA. Session failed.

geolr (rudolf-maurer) wrote :

12.10 and the same thing:

NX> 596 Could not find shadowed session 7xx5CxxxxxxxxxxxxxxxxxxxxxxxxC75ADC. Session failed.
NX> 596 Sharing:
NX> 105 NX> 280 Exiting on signal: 15

I have:
freenx-server 0.7.3.zgit.120322.977c28d-0~ppa11
installed from ppa:freenx-team/ppa in mid February 2013

I also see two local sessions when trying to log on. Both seem identical in the list of the client.

Tried qtnx as client, but that has no shadowing functionality

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers