How to install in Lucid

Bug #576359 reported by razor7 on 2010-05-06
72
This bug affects 15 people
Affects Status Importance Assigned to Milestone
FreeNX Server
Undecided
Unassigned

Bug Description

Hi...i have installed FreeNX using the testing PPA of FreeNX team, but the upstart script doesn't seems to work, by issuing this command sudo "restart freenx-server" or "sudo service freenx-server restart" upstart says "Unknown job".

Also, on connecting (after configuring my own keys and SSHd)I can not connect, I get this on client

"NX> 203 NXSSH running with pid: 5280

NX> 285 Enabling check on switch command

NX> 285 Enabling skip of SSH config files

NX> 285 Setting the preferred NX options

NX> 200 Connected to address: 10.0.0.2 on port: 5700

NX> 211 The authenticity of host '[10.0.0.2]:5700 ([10.0.0.2]:5700)' can't be established.

RSA key fingerprint is b1:22:a1:c2:b5:dc:d3:58:1c:e3:7c:ff:07:5b:a5:3c.

Are you sure you want to continue connecting (yes/no)?

Warning: Permanently added '[10.0.0.2]:5700' (RSA) to the list of known hosts.

NX> 202 Authenticating user: nx

NX> 208 Using auth method: publickey

HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.4.0)

NX> 105 hello NXCLIENT - Version 3.2.0

NX> 134 Accepted protocol: 3.2.0

NX> 105 SET SHELL_MODE SHELL

NX> 105 SET AUTH_MODE PASSWORD

NX> 105 login

NX> 101 User: martin

NX> 102 Password:

NX> 103 Welcome to: internet user: martin

NX> 105 listsession --user="martin" --status="suspended,running" --geometry="1024x768x32+render" --type="unix-gnome"

NX> 127 Sessions list of user 'martin' for reconnect:

Display Type Session ID Options Depth Screen Status Session Name

------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: martin

NX> 105 startsession --link="adsl" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="Internet" --type="unix-gnome" --geometry="1024x738" --client="winnt" --keyboard="pc102/es" --screeninfo="1024x738x32+render"

NX> 1000 NXNODE - Version 3.2.0-74-SVN OS (GPL, using backend: 3.4.0)

NX> 700 Session id: internet-2000-D177FD1BB6ED4C17486CFE287CCADFA1

NX> 705 Session display: 2000

NX> 703 Session type: unix-gnome

NX> 701 Proxy cookie: 518af4995f36db3f23cca985c859e830

NX> 702 Proxy IP: 127.0.1.1

NX> 706 Agent cookie: 518af4995f36db3f23cca985c859e830

NX> 704 Session cache: unix-gnome

NX> 707 SSL tunneling: 1

NX> 105 NX> 596 Session startup failed.

NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set SESSION_LOG_CLEAN=0 in node.conf and investigate "/home/martin/.nx/F-C-internet-2000-D177FD1BB6ED4C17486CFE287CCADFA1/session". You might also want to try: ssh -X myserver; /usr/lib/nx/nxnode --agent to test the basic functionality. Session log follows:

/usr/bin/nxserver: línea 1584: 3069 Terminado sleep $AGENT_STARTUP_TIMEOUT

Can't open /var/lib/nxserver/db/running/sessionId{D177FD1BB6ED4C17486CFE287CCADFA1}: No existe el fichero ó directorio.

NX> 1006 Session status: closed

NX> 1009 Session status: starting

mv: no se puede efectuar «stat» sobre «/var/lib/nxserver/db/running/sessionId{D177FD1BB6ED4C17486CFE287CCADFA1}»: No existe el fichero ó directorio

NX> 1009 Session status: starting

NX> 280 Exiting on signal: 15

"

Download full text (3.7 KiB)

Hi,

from what I know NX is started as shell of user nx upon login.
No daemon or initd service is used.

Christian

Am 06.05.2010 14:11, schrieb razor7:
> Public bug reported:
>
> Hi...i have installed FreeNX using the testing PPA of FreeNX team, but
> the upstart script doesn't seems to work, by issuing this command sudo
> "restart freenx-server" or "sudo service freenx-server restart" upstart
> says "Unknown job".
>
> Also, on connecting (after configuring my own keys and SSHd)I can not
> connect, I get this on client
>
> "NX> 203 NXSSH running with pid: 5280
>
> NX> 285 Enabling check on switch command
>
> NX> 285 Enabling skip of SSH config files
>
> NX> 285 Setting the preferred NX options
>
> NX> 200 Connected to address: 10.0.0.2 on port: 5700
>
> NX> 211 The authenticity of host '[10.0.0.2]:5700 ([10.0.0.2]:5700)'
> can't be established.
>
> RSA key fingerprint is b1:22:a1:c2:b5:dc:d3:58:1c:e3:7c:ff:07:5b:a5:3c.
>
> Are you sure you want to continue connecting (yes/no)?
>
> Warning: Permanently added '[10.0.0.2]:5700' (RSA) to the list of known
> hosts.
>
> NX> 202 Authenticating user: nx
>
> NX> 208 Using auth method: publickey
>
> HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.4.0)
>
> NX> 105 hello NXCLIENT - Version 3.2.0
>
> NX> 134 Accepted protocol: 3.2.0
>
> NX> 105 SET SHELL_MODE SHELL
>
> NX> 105 SET AUTH_MODE PASSWORD
>
> NX> 105 login
>
> NX> 101 User: martin
>
> NX> 102 Password:
>
> NX> 103 Welcome to: internet user: martin
>
> NX> 105 listsession --user="martin" --status="suspended,running"
> --geometry="1024x768x32+render" --type="unix-gnome"
>
> NX> 127 Sessions list of user 'martin' for reconnect:
>
>
> Display Type Session ID Options Depth
> Screen Status Session Name
>
> ------- ---------------- -------------------------------- -------- -----
> -------------- ----------- ------------------------------
>
>
> NX> 148 Server capacity: not reached for user: martin
>
> NX> 105 startsession --link="adsl" --backingstore="1" --encryption="1"
> --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0"
> --composite="1" --media="0" --session="Internet" --type="unix-gnome"
> --geometry="1024x738" --client="winnt" --keyboard="pc102/es"
> --screeninfo="1024x738x32+render"
>
>
> NX> 1000 NXNODE - Version 3.2.0-74-SVN OS (GPL, using backend: 3.4.0)
>
> NX> 700 Session id: internet-2000-D177FD1BB6ED4C17486CFE287CCADFA1
>
> NX> 705 Session display: 2000
>
> NX> 703 Session type: unix-gnome
>
> NX> 701 Proxy cookie: 518af4995f36db3f23cca985c859e830
>
> NX> 702 Proxy IP: 127.0.1.1
>
> NX> 706 Agent cookie: 518af4995f36db3f23cca985c859e830
>
> NX> 704 Session cache: unix-gnome
>
> NX> 707 SSL tunneling: 1
>
> NX> 105 NX> 596 Session startup failed.
>
> NX> 1004 Error: NX Agent exited with exit status 1. To troubleshoot set
> SESSION_LOG_CLEAN=0 in node.conf and investigate
> "/home/martin/.nx/F-C-internet-2000-D177FD1BB6ED4C17486CFE287CCADFA1/session".
> You might also want to try: ssh -X myserver; /usr/lib/nx/nxnode --agent
> to test the basic functionality. Session log follows:
>
> /usr/bin/nxserver: línea 1584: 3069 Termina...

Read more...

razor7 (ghiamar) wrote :

OK..so...looking at the log...what is wrong here?, because i could not initiate session from remote NX client...

razor7 (ghiamar) wrote :

Well, I finally managed to get it working using Lucid repo.

For custom keys:
    $ sudo apt-get install freenx
    $ sudo /usr/lib/nx/nxkeygen
    $ sudo /usr/lib/nx/nxsetup --install
    $ sudo dpkg-reconfigure freenx-server (select custom keys)
    $ use key located in /var/lib/nxserver/home/.ssh/client.id_dsa.key

If you dont have "nxsetup" script, just download it above and extract it with
    tar xzvf nxsetup.tar.gz

I think that nxsetup is missing on the packages

Best regards

frell (lee) wrote :

Freenx was working perfect for me in Lucid until today when i did "aptitude upgrade" and apt installed;

Get:16 http://ppa.launchpad.net/freenx-team/ppa/ubuntu/ lucid/main freenx-vnc 0.7.3.git100327.e224628-0~ppa4~lucid1 [21.2kB]
Get:17 http://ppa.launchpad.net/freenx-team/ppa/ubuntu/ lucid/main freenx-server 0.7.3.git100327.e224628-0~ppa4~lucid1 [113kB]
Get:18 http://ppa.launchpad.net/freenx-team/ppa/ubuntu/ lucid/main freenx-smb 0.7.3.git100327.e224628-0~ppa4~lucid1 [24.3kB]

Now im getting this same issue.

In my case running the steps razor7 suggests didnt help and im still getting;

start: Unknown job: freenx-server

I think its something to do with this update changes the init.d scripts to use upstart?

razor7 (ghiamar) wrote :

Hi...I really dont think that is needed as a service, because FreeNX works this way:
1 Log into SSH Server
2 As "nx" user, launch nxserver

Thats all...

Jeremy Wilkins (wjeremy) wrote :

There is a file that loads in the service loading process, but all it does is clear the X temp files and run some cleanup and startup scripts. There are no daemons that run. I am also not aware that we ever went to a GIT repository and if so I was not notified of it. I came here to investigate.

Jeremy Wilkins (wjeremy) wrote :

I am not aware when this ppa was passed over to the MOTU developers, but it seems this is the case now as of Lucid unless this is some hack job. Either way, it seems that whoever uploaded this broken package set was from the Ubuntu MOTU developer's group. I will try to contact them to organize this better.

razor7 (ghiamar) wrote :

Hi I mailed the ppa maintainer on 05/07/2010, and replied this.

Marcelo Boveto Shima escribió:
> Launchpad is broken. I cannot copy the packages from the testing ppa
> to the stable ppa.
>
> Please use the testing ppa for now.
> https://edge.launchpad.net/~freenx-team/+archive/testing
>
> Regards.

Jeremy Wilkins (wjeremy) wrote :

I spoke with Marcelo Boveto Shima as well since we usually work together and it seems the packages were moved to a git repository and are maintained in the altlinux.org repository now. So the FreeNX-KNX mailing list is now the support line for those needing help. I am not going to endorse these packages yet, since i have not had a look at the changes, but they are legit. If you are having troubles, you can email the mailing list for support.

Obvious question.
Why aren't the packages being maintained via
http://ppa.launchpad.net/freenx-team/ppa/ubuntu. Is there a desire to
abandon Launchpad completely?

Lewis

On Mon, May 17, 2010 at 9:27 AM, Jeremy Wilkins <email address hidden> wrote:

> I spoke with Marcelo Boveto Shima as well since we usually work together
> and it seems the packages were moved to a git repository and are
> maintained in the altlinux.org repository now. So the FreeNX-KNX
> mailing list is now the support line for those needing help. I am not
> going to endorse these packages yet, since i have not had a look at the
> changes, but they are legit. If you are having troubles, you can email
> the mailing list for support.
>
> --
> How to install in Lucid
> https://bugs.launchpad.net/bugs/576359
> You received this bug notification because you are a member of FreeNX
> Team, which is the registrant for FreeNX Server.
>

Jeremy Wilkins (wjeremy) wrote :

I will continue to support the Launchpad site whether Marcelo does or not. I will keep in contact with him to understand the situation.

razor7 (ghiamar) wrote :

Thanks a lot!, please keep the launchpad support.

PS: We can still use FreeNX from the testing PPA.

ludovicus (lewis-schmidt) wrote :

All hail the Launchpad!
thanks, lemme know if there is anything you'd like me to do.
Lewis

On Tue, May 18, 2010 at 11:32 AM, razor7 <email address hidden> wrote:

> Thanks a lot!, please keep the launchpad support.
>
> PS: We can still use FreeNX from the testing PPA.
>
> --
> How to install in Lucid
> https://bugs.launchpad.net/bugs/576359
> You received this bug notification because you are a member of FreeNX
> Team, which is the registrant for FreeNX Server.
>

Seems we have some misunderstanding.

I am still maintaining the FreeNX Team ppa.
I said razor7 to use freenx-team/testing because launchpad was refusing
to copy the packages from testing to the stable ppa. But now it is done.

About the git branch. This is simple. I created a snapshop from:
http://git.altlinux.org/people/boris/packages/?p=freenx-server.git;a=summary
And uploaded it.
But before the upload I revised every change.

Regards.

Jeremy Wilkins (wjeremy) wrote :

Does this mean that the stable ppa now has working packages?

Aukusti Saarinen (sotkelo) wrote :

I can't get this working. I installed it using the stable PPA, had to manually download the nxsetup script from a post I saw on ubuntu-forums since it was missing, ran it with nxsetup --install which ran fine. I get the unknown job-error trying to start/stop the server, and if I try to connect to it with Nomachine's NXclient , it just says NX access not available or disabled, so obviously the server isn't starting. Any idea what that problem might be? Contrary to the original poster, I can't even connect to it, so the problem is not just the upstart script, the server doesn't seem to be running at all. :/

Aukusti Saarinen (sotkelo) wrote :

Hmm, the server seems to be running after all even with that error showing up, since nxserver --start says service is running, but it won't accept any connections to it. Weird.

Aukusti Saarinen (sotkelo) wrote :

Stupid me - it was related to creating custom ssh keys that didn't work right. Ignore what I said. The upstart thing is still a problem though.

DodgeThis (pedromesquita) wrote :

Hi there!
Try Remove with aptitude and install with karmic repo

frell (lee) wrote :

Thanks DodgeThis. That fixed it for me, freenx is working again.

Issue is still there.

In /etc/init/freenx-server.conf change "PATH_BIN=/usr/lib/nx" to "env PATH_BIN=/usr/lib/nx"

Jeremy Wilkins (wjeremy) wrote :

Well, something I noticed with this ppa package is that it was getting the security wrong for the path:
/var/lib/nxserver/home and all the decending directories. They should be owned by the nx user or at least readable by the nx group.
When I ran the following command my login issues went away:
sudo chown nx:root -R /var/lib/nxserver/home

This makes the nx user the owner of those directories. It should be the owner because it is the active user at the nxserver shell that the login is performed with and that is the home directory for the nx user.

Jeremy Wilkins (wjeremy) wrote :

Oh, BTW that nx user home directory also contains the NX ssh keys which are required to log in with the commercial NX client without needing to copy the keys manually to the clients. That is the reason that running nxsetup script seemed to fix it some.

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Lewis

Lewis Schmidt
Clinical Analyst at HCTec
Melbourne, Florida Area

Confirm that you know Lewis Schmidt:
https://www.linkedin.com/e/k6wwm5-hmzi1u3y-59/isd/17425437139/Wpi8DWt-/?hs=false&tok=2v7yOPofOSx5Y1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/k6wwm5-hmzi1u3y-59/zMztvgjRbGEt7gb6Bp76HwERIAjpWIfG80TJndq/goo/576359%40bugs%2Elaunchpad%2Enet/20061/I5772747703_1/?hs=false&tok=0SvExMyLOSx5Y1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments