per-maptype maximum zoom level

Bug #665776 reported by Paul Wise (Debian) on 2010-10-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
FoxtrotGPS
Wishlist
Unassigned

Bug Description

It would be nice if the maximum zoom level could be set on a per-maptype basis. For example the Google map tiles go up to zoom 19 but the openstreetmap ones only go to 17.

Joshua Judson Rosen (rozzin) wrote :

What happens when you go past the server's limit?

Paul Wise (Debian) (pabs) wrote :

Exactly the same as what happens now? OSM only goes to 17 but the default maximum in FoxtrotGPS is 18. When you have FoxtrotGPS set to 18 but displaying OSM you get blurry tiles at zoom level 18.

"Paul Wise (Debian)" <email address hidden> writes:
>
> Exactly the same as what happens now? OSM only goes to 17 but the
> default maximum in FoxtrotGPS is 18. When you have FoxtrotGPS set to 18
> but displaying OSM you get blurry tiles at zoom level 18.

So is the change just to cut down on superfluous network traffic?

Or is it to automatically set the limit on the slider based on
the highest zoom-limit defined for any map?

Or something else?

--
"Don't be afraid to ask (λf.((λx.xx) (λr.f(rr))))."

Paul Wise (Debian) (pabs) wrote :

Both of those.

And also to allow access to higher zoom levels. Google maps goes up to 20, Google satellite imagery goes up to 19.

Seems very silly to hard-code something that completely depends on the server you are using.

Changed in foxtrotgps:
importance: Undecided → Wishlist
status: New → Triaged
Richard (richardwest) wrote :

I would just like to add my vote for this feature as I have maps with maximum zoom of 18 and 19.

robin (robinp) wrote :

OSM tiles now exist for zoom 19; it'd be good to allow extended zoom levels, even better for configurable for different repos.

robin (robinp) wrote :

Line 127 of "tile_management.c", increase that from 18 to 19 and it's done

Paul Wise (Debian) (pabs) wrote :

I've committed a change to make the default maximum zoom level 20
instead of 18 to accommodate both Google Maps and OSM.

https://bazaar.launchpad.net/~foxtrotgps-team/foxtrotgps/trunk/revision/324

Fixing this properly will need us to be able to edit the GladeXML
files, but modern versions of the Glade tool only support GtkBuilder,
so we will need to switch to that before we can implement per-source
defaults for maximum zoom levels.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers