Nautilus is not showing custom icon & emblem

Bug #1447257 reported by costales on 2015-04-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Folder Color
High
Unassigned
Nautilus
Confirmed
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

FYI In Utopic is working right with:
nautilus 1:3.10.1
nautilus-data 1:3.10.1

In Vivid is not working with:
nautilus 1:3.14.2
nautilus-data 1:3.14.2

Test:
For a folder, check folder:
    costales@VM:~/Desktop$ gvfs-info -a metadata::emblems ~/Documents
    uri: file:///home/costales/Documents
    attributes:
    costales@VM:~/Desktop$

Set an emblem:
    gvfs-set-attribute -t stringv ~/Documents metadata::emblems "folder_emblem_in_progress"

Set an icon:
    gvfs-set-attribute -t string ~/Documents metadata::custom-icon-name "brasero"
BUG: This is overwriting the emblem. But the emblem is there yet:
    costales@VM:~/Desktop$ gvfs-info -a metadata::emblems ~/Documents
    uri: file:///home/costales/Documents
    attributes:
      metadata::emblems: [folder_emblem_in_progress]
    costales@VM:~/Desktop$

Unset icon:
    gvfs-set-attribute -t unset ~/Documents metadata::custom-icon-name
AS YOU CAN SEE: The emblem is there yet.
    gvfs-set-attribute -t unset ~/Documents metadata::emblems

Nautilus should show a custom icon & custom emblem together as in previous versions.

Thanks in advance!

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
costales (costales) on 2015-05-03
Changed in folder-color:
importance: Undecided → High
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.