socks proxy ignored

Bug #1041240 reported by Thorsten2k3 on 2012-08-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fogger
Medium
Owais Lone

Bug Description

i've a proxy script at work that opens an ssh-tunnel with:

  ssh -NTCf -D 127.0.0.1:5000 $TUNNELS $HOST

and sets the gnome-settings as well:

  gsettings set org.gnome.system.proxy.socks host 'localhost'
  gsettings set org.gnome.system.proxy.socks port 5000
  gsettings set org.gnome.system.proxy mode 'manual'
  gsettings set org.gnome.system.proxy ignore-hosts "['localhost', '127.0.0.0/8']"
  gsettings set org.gnome.system.proxy.http enabled false

I set the http-proxy to false but fogger still want to connect to the none existing proxy. All i get from the UI is 'Cannot resolve proxy hostname ()' and the log isn't really helpful.

The next bad omen: the python-lib 'requests' your using seams to never heard of something like socks-proxy.

btw.: i would love to knew if fogger uses the proxies after the verfiy in FoggerWindow.py.

Thorsten2k3 (thorsten-projekt1) wrote :
Download full text (3.5 KiB)

DEBUG:fogger: set_up_logging() 'logging enabled'
DEBUG:fogger_lib: __init__() 'consider using a pythonic name instead of design name 'treeview-selection1''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'download_view', 'button-press-event', 'on_download_clicked''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'button1', 'clicked', 'open_downloads_folder''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'downloads', 'activate', 'show_download_window''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'back', 'activate', 'on_go_back''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'forward', 'activate', 'on_go_forward''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'reload', 'activate', 'on_reload''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'home', 'activate', 'on_go_home''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'zoom_in', 'activate', 'on_zoom_in''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'zoom_out', 'activate', 'on_zoom_out''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'zoom_reset', 'activate', 'on_zoom_reset''
DEBUG:fogger_lib: connect_signals() 'connect builder by design 'fullscreen', 'activate', 'on_go_fullscreen''
DEBUG:fogger_lib: do_connect() 'connect builder by name 'mnu_preferences','activate', 'on_mnu_preferences_activate''
DEBUG:fogger_lib: do_connect() 'connect builder by name 'fogger_app_window','destroy', 'on_destroy''
DEBUG:fogger_lib: do_connect() 'connect builder by name 'fogger_app_window','size_allocate', 'on_size_allocate''
DEBUG:fogger_lib: do_connect() 'connect builder by name 'mnu_contents','activate', 'on_mnu_contents_activate''
DEBUG:fogger_lib: do_connect() 'connect builder by name 'mnu_about','activate', 'on_mnu_about_activate''
DEBUG:fogger_lib: do_connect() 'connect builder by name 'mnu_close','activate', 'on_mnu_close_activate''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_fogger_app_remove''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_resource_request_starting''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_frame_load_status''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_title_changed''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_fogger_autostart_changed''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_create_webview''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_preferences_dialog_destroyed''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_web_view_ready''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_fogger_app_reset''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_load_status_changed''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_request_geo_permission''
DEBUG:fogger_lib: log_unconnected_functions() 'Not connected to builder 'on_database_quota_exceeded''
DEBUG:fogger_lib: log_unconnected_functions() 'Not co...

Read more...

description: updated
Owais Lone (loneowais) wrote :

Fogger does not read socks settings because python-request does not support socks proxy yet. I'll either patch python-requests to use socks and send that upstream or use a different library to make socks works.

Thanks for bringing this up and reminding me about this.

Changed in fogger:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Owais Lone (loneowais)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers