Redirect break loop is not working

Bug #907860 reported by LadyStardust on 2011-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
FlexHub
Low
FlipFlop™

Bug Description

!set rd_breakloop_enable etc

reported by Greenbee

endator (endator) on 2011-12-27
Changed in flexhub:
assignee: nobody → endator (endator)
endator (endator) wrote :

possible pixed in svn 1251, at least it makes more sence now

Changed in flexhub:
status: Confirmed → In Progress
LadyStardust (ladystardust-dc) wrote :

[18:54:43] <Winterfell> You have entered a redirect-loop to this hub, you're redirected to 123.123.123.123:100 now.

Looks like pix is working now

endator (endator) wrote :

then i'll mark this as pixed until someone else finds more that is wrong with it.

Changed in flexhub:
status: In Progress → Fix Committed
assignee: endator (endator) → LadyStardust (ladystardust-dc)
Changed in flexhub:
status: Fix Committed → Fix Released
FlipFlop™ (flup-flop) wrote :

Greenbee reported there's still a problem with this, users keep connecting.

Might have to do with line 144 in Hub-Redirect.lua:

local vip = client.sNick or client.sIP

Can't figure out why sNick was used here instead of just the IP or IPEx...

Changed in flexhub:
status: Fix Released → In Progress
assignee: LadyStardust (ladystardust-dc) → FlipFlop™ (flup-flop)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers