Account problems after !changereg command

Bug #902879 reported by LadyStardust on 2011-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
FlexHub
Low
LadyStardust

Bug Description

[20:09:14] <Winterfell> *** !changereg NMDC User
[20:10:42] <Winterfell> *** !ui NMDC
[20:10:42] <Winterfell>

 Showing info of: NMDC
 ________________________________________________________________________________
 General information:
 ________________________________________________________________________________
  • User: NMDC (Protected)
  • SID: 7ODA
  • CID: JEFD7XM4WQRBRM6AVRDFAVWNNAHZL35FY3ZIDHY
  • Protocol: NMDC
  • Profile: Admin (7)

Account still exists - so we have 2 accounts now (NMDC and User).

description: updated
endator (endator) wrote :

I could not confirm getting two accounts after a !changereg, but changing nick for an online user wasnt finished in code, should work much better now.

Also changed the user feedback message to state the new nick both in main and in pm

Changed in flexhub:
status: New → Fix Committed
assignee: nobody → LadyStardust (ladystardust-dc)
LadyStardust (ladystardust-dc) wrote :

Account is gone, moved to the new account that was created.
Now problem is that "old" users is offline for hubsoft, when that user is online all the time, ie:
- [21:47:28] <Winterfell> *** !changereg NMDC ADC
- [21:47:28] <Winterfell> Changed registered nickname from: NMDC to: ADC
- [21:47:37] <Winterfell> *** !ui NMDC
- [21:47:37] <Winterfell>

 Showing info of: NMDC
 ________________________________________________________________________________
 General information:
 ________________________________________________________________________________
  • User: NMDC
  • SID: <USER OFFLINE>

NMDC user is online the whole time (hub says USER OFFLINE), tho hub says also that user ADC is online - where that is not truth. That is a bit confusing. And I cant !userinfo NMDC as an online user (if I make myself clear).

Changed in flexhub:
assignee: LadyStardust (ladystardust-dc) → endator (endator)
status: Fix Committed → In Progress
LadyStardust (ladystardust-dc) wrote :

[21:47:28] <Winterfell> Your registered nickname was changed from: NMDC to: ADC:
 Nickname: ADC
 Profile: Vip
 HubName: Game of Thrones
 Hub: NMDC: dchub://nature_is_freaking_amazing.com:8008 ADC: adc://nature_is_freaking_amazing.com:8008

Please put this in your Favorite hub options and reconnect to this hub.

Also after !changereg cmd is used, PM info doesnt contain password of a user. Dont know if thats on purpose.

endator (endator) wrote :

thats correct, its on purpose it doesnt send the password

Changed in flexhub:
status: In Progress → Fix Released
LadyStardust (ladystardust-dc) wrote :

Ghost user still there.

Changed in flexhub:
status: Fix Released → Confirmed
endator (endator) wrote :

another fix added to svn 1285

Changed in flexhub:
status: Confirmed → Fix Committed
endator (endator) on 2012-03-06
Changed in flexhub:
assignee: endator (endator) → LadyStardust (ladystardust-dc)
LadyStardust (ladystardust-dc) wrote :

[15:02:09] <Winterfell> *** !changereg NMDC User
[15:02:09] <Winterfell> Changed registered nickname from: NMDC to: User
[15:02:18] <Winterfell> *** !ui nmdc
[15:02:18] <Winterfell>

 Showing info of: nmdc
 ________________________________________________________________________________
 General information:
 ________________________________________________________________________________
  • User: NMDC
  • SID: <USER OFFLINE>
  • CID: JEFD7XM4WQRBRM6AVRDFAVWNNAHZL35FY3ZIDHY
  • Protocol: NMDC
  • Profile: User (-1)
  • IP: 192.168.56.1 (Online with same IP: User )

In SID section it states "offline" and in IP states "online". After !changereg command I get 2 nicks in a userlist again.

Changed in flexhub:
status: Fix Committed → In Progress
assignee: LadyStardust (ladystardust-dc) → nobody
endator (endator) wrote :

svn 1297

okay, this is now fixed again, for real ( i hope) :D

Originally there were a couple of problems and bugs wich made me miss some parts of the whole problem.

The actual accounts change has been working for a few revs, but with this rev also the updating of user list etc should work as intended:

For offline users there is no problems at all, the account is just renamed.
For an online NMDC user the account is renamed and thats about all that happens, the user MUST logout and login again with the new nick.
For an online ADC user the account is renamed and a BINF NI update is sent to all users with the new nick which completes the change for the ADC user ( I'd still recommend a relogin but only to verify that the user remembered to change the nick in his favs).

It is not possible to rename an account if the new nick is already registered or if a user with that nick is online in the hub.

Changed in flexhub:
assignee: nobody → LadyStardust (ladystardust-dc)
status: In Progress → Fix Committed
Changed in flexhub:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers