Search and Filelist not working on build 1409

Bug #1104901 reported by Varun Yellina on 2013-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
FlexHub
Low
endator

Bug Description

This problem is specific to users have Admin , Hubowner privileges. I used the built-in update feature. Unreg users are definitely able to download. Haven't tested with Reg profile.

endator (endator) wrote :

Not sure I understand this, do you have any logs from the hub showing the issue?

setting feed to level 2 for a while should show enough info, !set feed_debuglevel 2 to set the feed

regards
/d

Varun Yellina (varunyellina) wrote :

I'm running my hub on a lan network. Recently after using the built-in update command i've been unable to download/search anything. I've found this to be an issue only for people above the Reg profile. Also of late HUB-FEED gives me an error saying its unable to kick a user because the ip matches a local protected address. But interestingly when i try for protected ip addresses the only ones are my hubowner ips.

Also relating to the above issue, could this be the issue?

[00:11:10] <HUB-BOT> [FI] [2] [Security] [SR] [MaxLength] [Ignore] <thy~DJ> IP: 172.16.49.135 / Reason: The searchreply is too long, maximum length = 256 characters. / Your searchreply is too long, maximum length = 256 characters.

I tried !set sr_maxlength 10000
Now I stopped getting the above messages, but that didn't fix the issue of no search results

Varun Yellina (varunyellina) wrote :

I think my issue is solved..

Original setting before update(I didn't change it before update):
!set regonly false

Setting after update(I didn't change it after update):
!set regonly false

The above were the settings before I performed the following

!set regonly true
!set regonly false

Enabling and then disabling it worked for me. I'm able to search and download again now.
I'm confused, could this be possible?

endator (endator) wrote :

We made a change for this release regarding what ip ranges are considered local ( before not all A,B and C ranges were detected)

It is possible that some setting got reset in the process, I will check it to make sure it doesnt happen again

Changed in flexhub:
status: New → In Progress
assignee: nobody → endator (endator)
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers