flash problem in aurora after update, installing adobe flash intaller will remove firefox

Bug #955601 reported by jose luis on 2012-03-14
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
New
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned

Bug Description

after update new pluging for flash needed to be installed, I installed the default " gnash " but it was not working properly
I attempted to install adobe flash player but it removes firefox-global menu

sudo apt-get install flashplugin-installer

Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  msttcorefonts ttf-bitstream-vera ttf-dejavu ttf-xfree86-nonfree xfs
The following packages will be REMOVED:
  firefox firefox-globalmenu
The following NEW packages will be installed:
  flashplugin-installer
0 upgraded, 1 newly installed, 2 to remove and 0 not upgraded.
Need to get 9,536 B of archives.
After this operation, 39.2 MB disk space will be freed.
Do you want to continue [Y/n]?

I typed "Y" and lost firefox icon, I typed firefox in terminal and it suggested to install firefox

then I installed firefox but flashplugin had to be removed.

so there is not way to install one without removing the other, Gnash is working really badly on youtube crash very often, on other sites is not working at all: flash buttons or pop up windows do not work, any sugestion?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: firefox 12.0~a2~hg20120313r87346-0ubuntu1~umd1~oneiric
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic-pae 3.0.22
Uname: Linux 3.0.0-17-generic-pae i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: dorman 1663 F.... pulseaudio
 /dev/snd/controlC0: dorman 1663 F.... pulseaudio
BuildID: 20120313062126
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xda100000 irq 49'
   Mixer name : 'IDT 92HD75B3X5'
   Components : 'HDA:111d7603,103c3628,00100202'
   Controls : 21
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xda010000 irq 50'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: aurora
Date: Wed Mar 14 18:49:15 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IncompatibleExtensions:
 Ubuntu Firefox Modifications - <email address hidden>, Version=1.0.2, minVersion=4.0b6, maxVersion=10.*, Location=app-global, Type=extension, Active=Yes
 BetterPrivacy - ID={d40f5e7b-d2cf-4856-b441-cc613eeffbe3}, Version=1.68, minVersion=3.5, maxVersion=11.*, Location=app-profile, Type=extension, Active=Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
IpRoute:
 default via 186.92.96.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 186.92.96.0/19 dev eth0 proto kernel scope link src 186.92.124.196 metric 1
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=12.0a2/20120313062126 (Running)
RunningIncompatibleAddons: True
SourcePackage: firefox
UpgradeStatus: Upgraded to oneiric on 2012-03-14 (0 days ago)
dmi.bios.date: 06/12/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.24
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3628
dmi.board.vendor: Quanta
dmi.board.version: 18.37
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.24:bd06/12/2009:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvrRev1:rvnQuanta:rn3628:rvr18.37:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Related branches

jose luis (joseluis4646) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Taras Cavin (tasc) wrote :

https://launchpadlibrarian.net/96596003/firefox_12.0~a2~hg20120311r87339-0ubuntu1~umd1_12.0~a2~hg20120313r87346-0ubuntu1~umd1.diff.gz
Here's where the change was introduced, second chunk in the diff. I don't see anything mentioned in the changelog re this modification.

Taras Cavin (tasc) wrote :

Seems to be fixed now with the release of the Aurora 13

Changed in firefox (Ubuntu):
status: Confirmed → Invalid
Greg Whiteley (greg-whiteley) wrote :

As this is marked invalid as "fixed in Aurora 13" I've logged a new bug covering the bug in firefox 12 beta (firefox-next)

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/962765

Juan-e (globalpegasus) wrote :

The bug is back again: I just have the same problem with Aurora: firefox (13.0~a2~hg20120411r90716-0ubuntu1~umd2~natty) and flashplugin-installer (11.2.202.228ubuntu0.11.04.1). After I looked for a real solution, I had to try to restore the Flash Plugin without packages, following the official instructions https://support.mozilla.org/en-US/kb/installing-flash . I hope that this bug will have a real fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers