Implement Unity Launcher API in Firefox for downloads' progress and quicklist

Bug #871325 reported by Mar-castelluccio on 2011-10-09
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
One Hundred Papercuts
Low
Unassigned
firefox (Ubuntu)
Low
Unassigned

Bug Description

In Ubuntu, Firefox should use the Unity Launcher API to show progress of the downloads and to show a quicklist (for example, New Window).
There's yet an extension about the downloads' progress: UnityFox (https://launchpad.net/unityfox).
Could you integrate the extension in Firefox by default?

I don't know if this is a bug for Mozilla or for Ubuntu developers.
I think we should make use of Unity's Launcher API (https://wiki.ubuntu.com/Unity/LauncherAPI) to implement the progress bar and the quicklist.
There's an addon for the progress bar, UnityFox.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed

I've seen that the desktop file in /usr/share/applications contains the "New Window" shortcut, so the problem is only the downloads' progress bar.
There are two choices: integrate the UnityFox extension (maybe doing a unique extension with firefox-globalmenu) or use Unity Launcher API in Firefox itself.

Do you plan to solve this bug? Will you integrate the UnityFox extension? (possibly an unique extension with firefox-globalmenu)
Or do you think this is a problem of Firefox that should be solved by Firefox?

I've filed a bug in Launchpad (https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/871325), I've asked if they want to add UnityFox to their addon (actually they have two different addons, one for Unity globalmenu integration and one for other things, like apt support).
If their reply will be negative, I'll try to implement the progress bar directly into Firefox.

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in hundredpapercuts:
status: New → Invalid

Chris, is there a plan to solve this issue?

Mike L (helgalo) wrote :

I certainly hope this bug is fixed. I can only say that this bug effects me, and try to bump this bug up by doing whatever I can with my limited power.

Changed in hundredpapercuts:
status: Invalid → Confirmed
Chris Wilson (notgary) on 2012-06-10
Changed in hundredpapercuts:
milestone: none → quantal-9-internet
Chris Wilson (notgary) on 2012-10-22
Changed in hundredpapercuts:
milestone: quantal-9-internet → raring-round-7
Adolfo Jayme (fitojb) on 2013-03-03
Changed in firefox (Ubuntu):
importance: Undecided → Low
Chris Wilson (notgary) on 2013-03-04
Changed in hundredpapercuts:
importance: Undecided → Low
Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-firefox

(In reply to Marco Castelluccio [:marco] from comment #2)
> Chris, is there a plan to solve this issue?

Unfortunately, not at the moment. I'm only working on Firefox in my spare time now, which is quite limited already :/

(In reply to Chris Coulson from comment #3)
> (In reply to Marco Castelluccio [:marco] from comment #2)
> > Chris, is there a plan to solve this issue?
>
> Unfortunately, not at the moment. I'm only working on Firefox in my spare
> time now, which is quite limited already :/

Is libunity stable enough? Do you think we can use it in Firefox like it's used in your UnityFox extension?

Yeah, it's certainly ok to use for current Ubuntu releases (I think all current releases have the same ABI). It could change again before the next LTS though. It's a shame I didn't get around to this before changing roles

(In reply to Chris Coulson from comment #5)
> Yeah, it's certainly ok to use for current Ubuntu releases (I think all
> current releases have the same ABI). It could change again before the next
> LTS though. It's a shame I didn't get around to this before changing roles

I don't know if the library can be used if it isn't so stable (and I don't know who should decide about this matter). In case it can be used, I could work on this as soon as I have some time available.

This statement asserts that libunity is preferred over the DBus interface:
"While the libunity API is stable, the DBus protocol underneath is not. We strongly discourage anyone from relying on it."

If libunity ends up changing, we can expect the soname to change, and so the worst that will happen is that Gecko will fail to find the library and will fall back to current behavior. Even then, it probably won't be too difficult to adjust Gecko for changes in the libunity API. So using libunity sounds fine.

What entries would you add in the quicklist by the way? One of the reasons I never added a quicklist for the Unityfox addon is that Unity doesn't provide a way to make it available when Firefox isn't running (so, for example, your most frequently visited sites would only appear in the menu once you'd already opened Firefox).

I did mention this limitation to the Unity developers nearly 2 years ago, but nothing happened with it

Paolo, this is an Unity-only solution, on other DEs we'll still need to display a notification (we could use libnotify in the other cases, but it's still a notification :D).

Changed in firefox:
status: Confirmed → Invalid
Changed in firefox:
status: Invalid → New
Changed in firefox:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.