Firefox doesn't use overlay scrollbars

Bug #767040 reported by Laryllan
866
This bug affects 200 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Won't Fix
Medium
overlay-scrollbar
Undecided
Unassigned
firefox (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: firefox

The Firefox 4 browser in 11.04 doesn't use Unitys scrollbars (the light ones with the up/down button showing as soon as you move the mouse pointer over it).
Instead, it uses standard scrollbars.

I believe this is an inconsistency in the UI, as other programs (e.g. Nautilus) show them correctly.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: firefox 4.0+nobinonly-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia wl
Architecture: i386
Date: Wed Apr 20 12:55:44 2011
EcryptfsInUse: Yes
FirefoxPackages:
 firefox 4.0+nobinonly-0ubuntu3
 flashplugin-installer 10.2.159.1ubuntu1
 adobe-flashplugin N/A
 icedtea-plugin 1.1~20110406-0ubuntu2
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
ProcEnviron:
 LANGUAGE=de:C:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Laryllan (laryllan) wrote :
Revision history for this message
larlin (larlin) wrote :

Thunderbird is also affected by this.

Revision history for this message
Christian Titze (christitze) wrote :

Firefox 5 also has this problem.

Revision history for this message
Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. Firefox is still using xul to generate its scrollbars. I am marking this as a wishlist bug and triaged. Please report any other issues you may find.

affects: thunderbird → null
summary: - Firefox 4 doesn't use Unity scrollbars
+ Firefox doesn't use overlay scrollbars
Changed in firefox (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in null:
status: New → Invalid
Revision history for this message
In , cicoandcico (cicoandcico) wrote :

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110929022028

Steps to reproduce:

Firefox does not support Ayatana scrollbars in Ubuntu 10.10. Scrollbars are rendered as plain GTK.

Launchpad bug: https://bugs.launchpad.net/ayatana-scrollbar/+bug/847922

Revision history for this message
In , Ragas (bjoern-online) wrote :

Actually this is not a Bug of Firefox but of the Ayanata Scrollbar so it should be fixed there and not here.

Curtis Hovey (sinzui)
no longer affects: null
Revision history for this message
Ryan G (rtgkid) wrote :

---Affects everybody running Oneiric now as well.

Revision history for this message
In , Sq2d3bipy0t2-paul (sq2d3bipy0t2-paul) wrote :

(In reply to bjoern.online from comment #1)
> Actually this is not a Bug of Firefox but of the Ayanata Scrollbar so it
> should be fixed there and not here.

Can you tell us more about this?

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

And Precise, as of Beta 1.

tags: added: precise
Revision history for this message
sticks (orawas) wrote :

This is quite the eye sore...

Changed in firefox:
importance: Unknown → Medium
status: Unknown → New
Revision history for this message
Logan Symons (noboost) wrote :

Still present in Ubuntu 12.04 with Firefox 12.0

Revision history for this message
RobinJ (robinj) wrote :

Precise Pangolin just failed at reaching its "pixel perfection"...

Changed in firefox (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Pedro Bessa (pedbessa) wrote :

Firefox won't fix, but Ayatana Scrollbar (I hope) will fix.

Revision history for this message
Andrea Cimitan (cimi) wrote :

not a bug in ayatana-scrollbar. It's a bug in firefox. We should either work upstream or patch in firefox (ubuntu)

Changed in ayatana-scrollbar:
status: New → Won't Fix
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Heh, wrong bug ;)

Changed in firefox (Ubuntu):
status: Won't Fix → Triaged
Revision history for this message
Dr. Amr Osman (dr3mro) wrote :

+1

Revision history for this message
Stéphane Guillou (stephane-guillou) wrote :

This is still a problem in Ubuntu 12.04 with Firefox 13.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

That is no great surprise, seeing as the work hasn't been done yet. Really, there is no need for people to be adding "+1"'s and reminding us that it is still a problem.

Revision history for this message
In , Vincent (vinnl) wrote :

It looks like something that should be fixed in Firefox (and Thunderbird), just as the similar bug 636564 on OS X is being fixed in Firefox.

Revision history for this message
Juan Pablo (juanps90) wrote :

Problem still persists, Ubuntu 12.04 Firefox 13.0.1

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Yes, there really is no need to keep pointing that out

Adolfo Jayme (fitojb)
tags: added: oneiric quantal raring
Revision history for this message
In , AJ Jordan (strugee) wrote :

Reporter: please change the Product field to "Core", the Component field to "Widget: Gtk", the Hardware field to "All", and the Branch field to "Trunk". Thanks!

Revision history for this message
In , Ken-k (ken-k) wrote :

Changes Alex Jordan requested have been made, except for "Widget: Gtk" as it is not an option on the component dropdown.

Revision history for this message
In , Quequotion-7 (quequotion-7) wrote :

Almost a year since the last post, using firefox 30; no overlay-scrollbars :(

Was there any more progress on this issue?

Changed in firefox:
status: New → Won't Fix
tags: added: artful bionic
Revision history for this message
Sebastien Bacher (seb128) wrote :

overlay-scrollbars has been deprecated/isn't used in Ubuntu anymore

Changed in firefox (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

I have to disagree a bit about the the duplicates here. This very old bug was when Firefox was using GTK2, and back then the scroll bars in Firefox were GTK2-standard and didn't use the overlay scrollbars (up and down buttons).

All the newer bugs have GTK3 Firefox, and that the scroll bar in Firefox is thin and does not expand, or is not thick by default as in Adwaita. In Adwaita, the scroll bar is already thick and easily handled.

Revision history for this message
Brian K. White (bkw777) wrote :

The same too-small scrollbars are in Mozilla Thunderbird too.
I don't know how/why this is not considered a bug or at least a regression. Thunderbird and Firefox used to be usable, and now they are both more difficult to use. Other apps on the same system/desktop don't have the problem.

Revision history for this message
Andrea Corbellini (andrea.corbellini) wrote :

This is not considered a bug because overlay scrollbars are gone, they are not used in Ubuntu anymore, and therefore cannot be applied to Firefox.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.